• Hello Guest! SynoForum.com is celebrating its 5th anniversary! 🥳🎉 Read more...

Mayan EDMS help

Currently reading
Mayan EDMS help

99
8
NAS
DS213J, DS918+
Operating system
  1. macOS
Mobile operating system
  1. iOS
Background: Synology user back since 213J first came out, which was my 3rd NAS, but up until I bought my 918+ when it came out I was a basic user with mainly built in Synology apps. More recently finally trying to take advantage of the power of 918+ and docker, but I do not have a ton of linux background and have been muddling my way through it. So far I have been able to get Bitwarden self hosted up and running well, as well as a watchdog distribution of OCRmyPDF to do background OCR of PDF files. I saw that Mayan EDMS may be a better option to just have it manage (and subsequently OCR all my PDF as I am completely paperless/digital house for >5 years).

I am trying to install everything through the Docker interface in Synology. I sometimes seem to have a bit of trouble understanding the repositories and how some of the settings need to be mapped, which volumes need to be named what, etc when using the Synology app. I have SSH'ed into the Synology and set docker's running, but when they work seem so much easier to use the docker app and then just relaunch, or copy settings and easily have multiple instances ready to go, or to make changes, etc.

I have the postgres docker and the Mayan docker installed, however I am not sure that everything is set up correctly...I am able to load Mayan and it initialized, I have made a new user and see the interface, but when I am trying to upload documents I continue to get an error

ERROR/MainProcess] consumer: Cannot connect to amqp://guest:**@127.0.0.1:5672//: [Errno 111] Connection refused

I am guessing this is an error to the postgres? Can anyone help walk me through what I need to do (or even point me to a Mayan EDMS Synology docker walkthrough?

TL;DR -> mayan loads on Synology docker, but won't process images, help!

Thanks
 
If your Postgres DB is running on port 5672 then that will be an error related to DB. Can you confirm this?

These are the variables that I'm running with as well as 2 volume maps:

Screenshot 2019-12-30 at 09.21.20.png


Screenshot 2019-12-30 at 09.21.32.png
 
I have adjusted my volumes file/folder to the "mount path"'s that you have listed above of scanned files and var/lib/mayan. I do not have all of your variables running. Can you give me some assistance on the values (specifically for database engine, host/port, etc). Thank you.
 
Thank you.

I am obviously doing something wrong. I am wondering if I have Postgres set up correct as well.

From the docker file Postgres should be port 5432:5432, but it says this port is in use so I changed local port to 5433. I included the variables below.

I have also included the variables from the mayan docker as well.

I am now in an endless cycle of mayan restarting and getting the following error from the log
CommandError: Error during pre_upgrade signal: FATAL: could not open file "global/pg_filenode.map": Permission denied

Thanks again for the help.
 

Attachments

  • Screen Shot 2019-12-30 at 8.45.19 PM.png
    Screen Shot 2019-12-30 at 8.45.19 PM.png
    370 KB · Views: 95
  • Screen Shot 2019-12-30 at 8.46.07 PM.png
    Screen Shot 2019-12-30 at 8.46.07 PM.png
    410.4 KB · Views: 97
The problem here is postgres container. You need to set it up so that it’s username and password are variables for the main postgres instance.

After that you can setup multiple DBs and schemas for various apps including mayan that you need

So configure postgres fresh and then on top of that create another container with pgadmin docker image. This will give you a web ui view for postgres db administration. Use it to configure mayan username password and a new separate db. Then try again.
 
Still struggling with getting it set up. Having issues with the DB, so even tried to use MariaDB and made the database there and reset up Mayan but having issues getting it set up.

If someone was able to put a full walkthrough in the Resource section it would be great and I would try, but I think for my needs it is likely too complex to be a workable solution. I have concerns putting my data into a docker that I would have to maintain.

I will continue to use OCRmyPDF to make searchable PDF and just use the Synology Drive app which allows search within pdf which is the primary reason I was wanting to use Mayan. Thanks for your help.
 
If someone was able to put a full walkthrough in the Resource section it would be great and I would try, but I think for my needs it is likely too complex to be a workable solution. I have concerns putting my data into a docker that I would have to maintain.
Reasonable thinking still after you get it up and running is not much that you need to worry about. Still maintaining your docker environment is needed so if you don’t feel comfortable with it, best to avoid it.

As I said before, your particular error is based on the postgres error and having a healthy DB setup is 50% of the story here.

If you change your mind I can remote to your setup and help you with this configuration. Let me know in PM if you are interested
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

I run the official docker image myself. These are the variables that I use in combination with PostgresDB...
Replies
2
Views
3,604
DS1621+ I believe is the model number. I ended up getting it working by installing a swag container and...
Replies
4
Views
3,235
For starters, I would try this... devices: - /dev/dri:/dev/dri If the left path matches your NAS...
Replies
12
Views
5,487
Replies
5
Views
4,351
I have tried that interface, but still find calibre-web much better than Calibres own interface. Also, as...
Replies
6
Views
5,142
Well I have a cover on my Kindle so I only ever see the screensaver is when I have fallen asleep reading...
Replies
14
Views
5,661

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top