Missing devices from /dev/

Currently reading
Missing devices from /dev/

Hi,

I have a DS420+ (DSM 6.2.3) with harddisks installed in bays 1 and 2 which are combined into one SHR volume. The NAS configuration is almost default, I made only small adjustments via the GUI.
The NAS itself is located in a somewhat confined space, so I want to monitor the harddisks' temperature to see if I need to add some ventilation. When I started to write a monitoring script, I discovered that I have only one disk listed in /dev//dev/hda. There's no /dev/hdb even though I have two disks installed. There are also no /dev/sd* devices:
$ ls -1 /dev/{hd*,sd*}
ls: cannot access /dev/sd*: No such file or directory
/dev/hda
/dev/hda1
/dev/hda2
/dev/hda3
/dev/hda4
The /dev/hda device is the harddisk installed in bay 1 (I matched the serial number reported by smartctl).
There are two /dev/sata* devices which correspond to both harddisks (the serial numbers match), but smartctl can't see SMART support on these devices.
I've tried installing another disk in bay 3 — but still no /dev/hdb or /dev/hdc. It did get a matching /dev/sata3 device, just as the other two.

Does anybody have an idea why I don't have any /dev/hd* devices except for /dev/hda?
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top