Move a file or rename folder lost access to file(s)

Currently reading
Move a file or rename folder lost access to file(s)

Operating system
  1. macOS
Mobile operating system
  1. Android
Hello everyboby !
I come here because I can't fond an issue for a importante problem at my office.

We are 7 Mac Mini (OS Ventura) that access to files on the DS 1621xs / DSM 7.1.1, using SMB.

When we rename a folder, all the files within this renamed folder are "not found". (fortunately, files are not lost)
It is exactly the same issue if we move a file from a folder to another on the NAS.

What could it be ?

Many thanks for your answer.


I ve'tried just right now and it's same problem with AFP. It is not possible for me to use Wifi...
By the way, I'am almost sure that this problem comes with Apple and not with the NAS ...

Thanks for your answer.
@OZ&A I can confirm the same behavior on macOS Ventura 13.2 and DSM 7.1.1-42962 Update 4.
I tested Windows and it works as expected so no issues there.. But I don't use Windows so major issue on macOS.
The only way to get access back to these files from macOS is by cloning the folder/files which is not efficient and not always possible.
I filed an urgent support ticket with Synology and suggest you do the same. I also referenced this link in my ticket.

From macOS Ventura 13.2 renaming/moving folder via SMB looses access to the files in that folder.

Before macOS Ventura I used AFP and had no issues. Because there is an issue with macOS Ventura+Synology+AFP I updated my Synology to the latest version and also the SMB package, and instead of AFP, use SMB to access my shares.

When I rename a folder that exists on a Synology Shared Folder and try to access files/folders in it, I get an error message and loose access to my files. I can gain access to my files if I rename the containing folder to be exactly the previous names.

If I move folders around, it is very hard to impossible to restore the previous state and access is lost to the files.

[Steps to Reproduce]
1. Connect a Synology share to macOS Ventura 13.2 using SMB

2. Create a Folder in that Synology share

3. Create a Subfolder in that folder

4. Create a text file in that folder
5. Rename the root folder --> you will see an error trying to open the text file.

6. Rename the root folder back to the original name --> you will get access back to the file

7. Move the file from the subfolder to a different sub folder, then move it some more --> you will lose access to the file.

8. Only way to access the file is to copy it OR rename the folder from the WebUI to a new name.

[Error Messages and Screenshots]

Error message: "file.txt" can't be found.

Hi again, I can reproduce this issue with a Windows 10 VM acting as a SMB server --> so this seems not as a Synology issue but rather a macOS Ventura Finder issue.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Welcome to the forum. Have you tried to download using any other method besides Download Station? Just to...
I have shared a file which can be downloaded by friends. I was checking the Log Center to see if the file...
Ahah, it was the Sofware Decoding setting. I had it set to On. In the app it says If yhou have problems...
Agree with you, SMB will make the speed so much better and that is what I see when using Gs Richcopy 360...
Might be worth checking Windows's sharing/streaming options. It may also be the case that it is added to...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads