Moving Initial Snapshot via USB

Currently reading
Moving Initial Snapshot via USB

Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
  2. iOS
Our main office has 9.1TB snapshot that I used a 14TB USB drive to move the initial snapshot to our branch office Synology. From main to USB went fine. Took 3 days to get it on there, but all good.

Take the USB 3.0 and the 14TB to the branch office.
On the Replication section, it shows "Waiting to Import". So I plug it in. Nothing happens.
I then select "Import" on the Replication Task. The progress bar instantly jumps to 20% and stays there.
A full day later there is nothing showing in File Station. (#snapshot is set to Visible.)
Resource Monitor shows activity, but no write to volume.

r/synology - Importing Snapshot from USB
Says it is reading the Snapshot Replication, but no writing.
Is this normal activity for a 9.1 TB Import?
Am I missing something, or,
Should I let it run for 2 days and check it again?

Google searches all show how to start the Initial Replication via USB, but none show the part 2, which is how to put that on your Remote DSM.
Thanks in advance.
Personally, I haven't tried it that way. I would leave it. Did it create a shared folder on the destination side in the control panel > shared folders section?
Yes, it did create the shared folder (read only). I honestly expected to see some kind of activity beyond reading the USB Replication. I'll let it cook.
Personally, I haven't tried it that way. I would leave it. Did it create a shared folder on the destination side in the control panel > shared folders section?
The branch office only has 50Mb fiber. Replication over the wire said 22 days for the first one to complete. That's whack.
So, I tried the USB suggestion. (Replication wizard offers that as a choice for the first copy.) It was much quicker. It only took 3 days to populate the USB.
The branch office replicates to main in about an hour, same 50 Mb speed, about 4TB.
I copied the 9TB to a /TempShare/ on the DSM and am running Import from that source.
Now there is twice the activity over the USB3.1 drive. Now I let it cook.

I will report the final result here.
24 hours later. It is now Writing something somewhere. Unable to discern where it is writing.
Still going to let it cook.
OK. It took 2 days, but did accomplish the USB Snapshot transfer.
I did copy the USB store to the DSM and Imported from there at twice the speed.
Now the "Over the wire" Snapshot replication is going on its own.
Takes about 6 hours (starts after hours) to move 80-100GB daily snapshot.

Recap: the initial wire replication was going to take 21+ days.
@JohnAnderson so you were only able to get the usb to import by copying it to a shared folder first, and then import into snapshot replication? In other words, it wasn’t working/poor performance importing directly from the usb drive?
Last edited:
The USB import took 2 days of only reading, then began writing at ~30/40 MB/s. (USB 3.1) Way too slow for 9.1TB.
So, I gambled. I killed the Import and copied the Import file to a new share on the DSM, Imported it from there.
Once the Replication file was copied to the volume, I was able to import/write at ~300 MB/s. Way more better-er than USB 3.1 speeds.
By copying the USB Replication to a new share on the DSM, I was able to reduce the total import time to only 2 days.
Read 1 day and write 1 day - DONE.
Once completed, I did delete the share containing the Import file as it was no longer needed.
Also, the WAN replication recognized everything and is working nicely. Daily slices are only 80-100GB.

Extra: I was able to set Cisco Meraki Fire Wall Bandwidth policy to only use 30% of total during business hours, but have 100% bandwidth at night.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

No, it's not possible as the snapshot is on the shared folder as a whole. You could create a new shared...
I've enacted Snapshot on many of the folders I wish to provide insurance on, and I've just found that my...
  • Question
Is there a way to hide/show the #snapshot folder in SMB from certain users? Currently the only option I...
  • Question
Logs from Snapshot Replication don't end up at the local Log Center either. I just looked on my NAS which...
I now moved some Hyperbackup jobs about five minutes behind the snapshots. So far no further issues...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!