Solved Nextcloud desktop apps fail to authorise

Currently reading
Solved Nextcloud desktop apps fail to authorise

137
19
NAS
DS918+
Operating system
  1. macOS
Mobile operating system
  1. iOS
I think this is a Nextcloud problem but maybe I can bodge a fix on my install?

Nextcloud up and running via Docker. Does the business via its webpage. Now we want the client apps to sync document to/from/with macOS desktop and iOS iPad/iPhones. Easy, download and install the app. But the app wants authorisation and Nextclould wont play, won't 'grant access'. Here's a thread at the Nextcloud forums which describes the problem. There's something similar at the GitHub

The suggestion is that a Reverse Proxy puts a pox on the whole thing. We know from my difficult install here that my NC has a Reverse Proxy or two and that it appears to need them for my setup.

The Nextcloud forum users think adding
Code:
 overwriteprotocol => "https"
to the config file will help but other say it doesn't.

What are my options? I might try the overwriteprotocol => "https" fix but don't hold out much hope.

Meanwhile, how to fix. Use the ownCloud desktop app. It just asks for a username and password rather than a fancy token and works perfectly with Nextcloud. But that's not the point, I want the NC desktop app!
 
137
19
NAS
DS918+
Operating system
  1. macOS
Mobile operating system
  1. iOS
I could get into this command line business. Despite my doubts, it worked first time.

Screenshot 2020-06-16 at 10.51.44.png
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top