DSM 6.2 NFS permissions issue - write permissions denied

Currently reading
DSM 6.2 NFS permissions issue - write permissions denied

295
32
NAS
DS1019+ DSM6
Operating system
  1. Windows
Mobile operating system
  1. iOS
having a problem assigning the correct NFS permissions so that my Pi can write to a mounted share.

i've mounted the share and it can read it just fine
sudo mount -t nfs 192.168.50.2:/volume1/data /mnt/data

however i seem to have a write permissions issues as i get "permission denied" when tryint to write anything to it.
these are my NFS permissions settings. i've tried setting Squash to both "Map all users to guest" and "Map all users to admin", both result in "permission denied".

Screenshot 2022-07-22 102227.jpg


any ideas if there is another setting i need to change?
the SMB share i have for windows systems is working fine with no permissions issues.
 
worked out what the problem was - schoolboy error.
i hadn't created a user on the NAS with the same details as what the pi uses.
added the user and it can now write to the NAS.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Good morning as said in the title, the quickconnect sharing links generated on a Mac mini M2 from "file...
Replies
0
Views
397

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top