Info Optimize nas kernel,....

Currently reading
Info Optimize nas kernel,....

31
10
NAS
DS218+ DSM 6.2.2-24922-4
Router
RT2600ac
After reading many forum’s and posts.
At the moment sysctl -w var , don’t work on my nas.

sysctl -a => show all key’s

The tweaks i did

- create a boot-up rule at scheduler
- add
sleep 90
sysctl vm.swappiness=5
sysctl vm.dirty_background_ratio=5
sysctl vm.dirty_ratio=10
sysctl vm.overcommit_memory=0
sysctl vm.vfs_cache_pressure=50

- save
- reboot nas

Things that i see
- Better response
- Faster data transfer with rsync, at the moment 1 sec / GB

Watch out with ‘overcommit_memory’
Pl read the guide on www for each key you change
 
You can put the config in /etc/sysctl.conf.
And immediatly load and apply the changes with sysctl -p without a reboot.
 
Last edited:
61
8
NAS
DS918+, DS916+, DS214+, DS211j
So ist this proven to work as expected, I mean the tweaking tips above? Will those settings have some side effects?
 
31
10
NAS
DS218+ DSM 6.2.2-24922-4
Router
RT2600ac
So ist this proven to work as expected, I mean the tweaking tips above? Will those settings have some side effects?
No problem for me so far, with my packages,....
On my way there will not be writhing to any var so if it not do the job for you just delete the rule , and you have it back like before.
just watch out with setting the values to high or to low.
example

Never set swappines to 0 , never do that
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Top