• Hello Guest! SynoForum.com is celebrating its 5th anniversary! 🥳🎉 Read more...

Other options than QC+DDNS

Currently reading
Other options than QC+DDNS

39
5
NAS
Synology DS220+
Operating system
  1. Windows
Mobile operating system
  1. iOS
Hi all!
I have currently my NAS configured through both QuickConnect as well as DDNS (via a synology domain name). I have picked this setup as I want to utilize LAN-speed when I am home. I have DDNS enabled for quicker access outside my LAN and also for non-synology services (docker apps).

Can this be done in a better way? Note I do not want to use VPN, so that is not an option!
 
Can this be done in a better way? Note I do not want to use VPN, so that is not an option!
Consider setting up a Reverse Proxy for more secure remote access. see How to Use a Reverse Proxy on a Synology NAS for detailed setup instructions.

When on LAN, access your NAS with finds.synology.com. This method will resolve to your local IP.
Code:
https://finds.synology.com

As an alternative, you can also use SMB when on your LAN.
 
Thanks for your input. Seems my router doesn't allow port forwarding on port 80, which make me unavailable to use reverse proxy.
 
Right, but I got stuck on port 80 in the guide above and gave up at that point. This morning I checked port 443 and it was also blocked so I guess I am completely unable to use Reverse Proxy with my current router.

Thanks anyway guys!
 
1) I can’t get this far.
2) When I try to port forward port 80 (or 443) I get a message like this from my router:
”Port 80 is reserved for the router system”
Other port numbers are ok.
 
Last edited:
1) you can go to canyouseeme.org to test what’s opened or what’s blocked. So yes you can get that far. It will be blocked until you add the proper port forward rule on the router.

Earlier by you saying it’s blocked is inaccurate something is just not configured properly.

Can we see how your entering in the port forward 80 rule, but more importantly port 443, because sometimes yes port 80 is blocked by the isp but again reverse proxy runs over 443 and you don’t need to open 80 for this to work. The message you’re getting about being reserved is a router thing.

Enter a port forward rule as mentioned previously for 443 to your nas to get reverse proxy setup.
 
Hi Gerard,

I agree I was not very clear in my formulation. It looks like I can't open some specific ports on my router (a rather old and basic Mesh router). I can only reach the settings through an app on my phone and from the image below you can see that it will not let me forward port 80. The same goes for port 443, other ports work fine. The router settings can't be accessed from a PC or Mac, only through a phone.
IMAGE-1.jpg


Regards,
Roger
 
Last edited:
do you have remote management turned on for your router? Remote management will be over 80 and/or 443. Turn it off, (or if you can reconfigure this to a custom port) and use 443 to the nas. Once you get past that then you can setup a rp on the nas for xxx.domain which is then to your router (if you’re using remote management). Then add additional rp rules for your other services such as DSM, Vaultwarden, etc.

But first you need to find where 80 and 443 are turned on for the router, it is most likely remote management. You’ll need to do this locally. Once this is off you should be able to create the port forward rules.

What router is this?
 
Linksys Multi U
Google search, the issue is your router. There’s a slew of posts talking about same thing. Other than that this is easy, add a port forward rule for port 443 to the nas and the rest of rp setup is done on the nas.

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.

View: https://www.reddit.com/r/LinksysVelop/comments/10tk20l/port_forwarding_is_stopping_me_accessing_the/
 
Hmm Gerard, please excuse my ignorance. My router is a Zyxel Multy U not a Linksys. I feel ashamed to give such bad feedback when you are being so helpful.
 
Hmm Gerard, please excuse my ignorance. My router is a Zyxel Multy U not a Linksys. I feel ashamed to give such bad feedback when you are being so helpful.

All good, I’d suggest doing some searching on that router. There has to be a way to port forward 443. Once you get thru that hurdle you’ll be able to move on to your next steps
 
A quick search of the Zyxel and port forwarding 443 does seem to be a bit of impossible according to one thread I just viewed. With this appearing to be the case, maybe some others here will have recommendations, but this is definitely your struggle, it’s not the fact that it’s being blocked. At this time it appears to be a limitation of the router.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top