Periodic noise from harddrives in my DS918+

Currently reading
Periodic noise from harddrives in my DS918+

182
19
NAS
DS918+
Operating system
  1. Windows
This is driving me nuts. From time to time, all drives on my first volume starts reading/stopping/reading etc. I have no idea what it does.
Index-service doesn't seem to be working. Storage-application doesn't say anything about scrubbing etc. I can't see any activity that can cause this. I see the disks are working in the resource manager but not what it do.. I've stopped my Docker containers but noise remains.
Any hints how I can track this down?
1612626929262.png


1612626947991.png
 

Rusty

Moderator
NAS Support
5,214
1,529
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
This is driving me nuts. From time to time, all drives on my first volume starts reading/stopping/reading etc. I have no idea what it does.
Index-service doesn't seem to be working. Storage-application doesn't say anything about scrubbing etc. I can't see any activity that can cause this. I see the disks are working in the resource manager but not what it do.. I've stopped my Docker containers but noise remains.
Any hints how I can track this down?
View attachment 2992

View attachment 2993
Open up HTOP via ssh and monitor there. Anything that will start making some noise will surely jump in cpu utilization. So try and keep an eye on the htop monitor and see what starts to show on the top of the list
 
549
176
NAS
DS620slim, DS415+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
Pull the netwok cable, to see if is a trigger from your network, or even quickconnect if you have enabled that. Quickconnect tends to check if your system is still there.
 
182
19
NAS
DS918+
Operating system
  1. Windows
I think I've solved the problem. I disabled my NVMe r/w cache (!?), and I haven't had any noise problems for the last 24 hours.
 

fredbert

Moderator
NAS Support
Subscriber
3,589
1,431
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Meaning that like other housekeeping tasks done during quiet* times the NVMe cache is part of these activities.

*periods of low NAS usage rather than being quiet :)
 
Hello everyone! glad to see I m not the only one going crazy with the noise and sad to realize there is no standard solution for it..

As I wrote in the last days in other threads here, I replaced my DS718+ with 2x14TB EXOS drives (that i shucked just to realize they are noisy as hell) with a DS920+.

I kept the two EXOS and also added a 4TB SSD WD Red hoping that I can run docker (nextcloud, mariadb, bw), MailPlus and DSM apps on it and only use the volume on the EXOS HDDs to replicate snapshots every some days.

The noise of course went down from from the continuous rambling.. BUT I ended up with this periodic sound similar to the one in the video of this reddit. I have not been able to tell what is polling the drives and even tried to put some bubble wrap below the NAS in case it is multiplied by the desk but still in the night I can hear it...

Is there any recommendation on changes I can try on this SSD / HDD combo that i described so the heads of the HDDs are not used when it is not doing any backup or accessed on purpose? There is no NVME drive for caching installed on this system.

I hope I am not hijacking the thread but it seemed spot on the issue I am trying to solve. Please let me know and I will move it or open a new one if needed.
 

DataNAS

Subscriber
24
5
oRBIT, I am surprised to read that disabling the NVMe cache reduces hard disk drive noise? Intuitively, I would have expected noise to increase since, in the absence of the NVMe cache, all (rather than some) read operations generate disk activity. Thoughts?
 

jeyare

Subscriber
2,328
768
NAS
Synology, TrueNAS
Operating system
  1. Linux
  2. Windows
@gemic
Exos line from a basic point of view is a HDD range tailored for datacenter/server operation. There isn’t a silence kind of primary driver for an operation. The sound provided by the redit link is absolutely normal for such capacity. This is sound of the HDD Actuator (pivot and arms) for your read and write heads operation. When you will listen a noise something like Kalashnikov rapid fire, then it’s a time to make extensive test of the HDD (surface, smartctl, ...) or just open a consideration about data storage architecture (right volume sizes for right data).

1616479976797.png
 

jeyare

Subscriber
2,328
768
NAS
Synology, TrueNAS
Operating system
  1. Linux
  2. Windows
regarding a strange HDD noise operation when no activity is expected:
- all is about to find the process what is responsible for that

- then you need start with 100% what exact disk
Code:
iostat -dx 1
iostat will help you find exact activities by defined drives in your NAS (include parameters about (d) disk utilization (x) extended statistics (1) one second period

- after this step you need find an exact process responsible for the actual I/O activity
Code:
iotop -o
after that you can use
Code:
iotop -p TIDnumber
for a focusing in

... no one can help you better, than these tools (also htop mentioned). Because no one is connected to your NAS, except you.
 
Hello @jeyare and thanks for the insight! I did read for the EXOS enterprise use, but as i shucked them from consumer desktop external boxes i thought it would be bearable. My mistake.. At this point i am more curious to see why my plan od using the SSD failed partially so I read on how to install synogear and the tools you mention.

Running iostat, I get that in some intervals all three sata1, 2 and 3 are being written (see screenshot but as you say i cannot see who is writing on them) and in some occasions only sata3. As i am not sure which disk corresponds to each sata reading should i assume that sata3 is probably the SSD (installed on slot 1 of the NAS) and sata1,2 are the EXOS (installed on slots 3 and 4)?
iostat.png


Running iotop -o (and using the "a" shortcut) i get several processes but if i exclude the ones that mention docker or mysql i could say that jbd2/md0-8 and kworker should be a starting point to look at.. however its not clear which disk they are writing to..

iotop -o.png
 
182
19
NAS
DS918+
Operating system
  1. Windows
I switch to read-cache only instead of r/w-cache and there's no noise, so I guess there's something that's going on in r/w mode..
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Top