Permissions issues running Sonarr in docker

Currently reading
Permissions issues running Sonarr in docker

18
4
NAS
DS1019+, DS916+
Operating system
  1. Windows
Mobile operating system
  1. Android
  2. iOS
Last edited:
I am trying to move from running Sonarr, Radarr and SBnzd as separate community packages, to running them in docker. So far, I have radarr running in docker, and it's working fine. It is calling the SABnzd that is running as a package, and it's downloading movies, and moving them into Plex just fine. However, Sonarr is not able to do the same. I am getting this permissions issue:

2022-11-23 16:42:22.5|Error|DownloadedEpisodesImportService|Import failed, path does not exist or is not accessible by Sonarr: /volume1/downloads/complete/Wednesday.S01E01.1080p.HEVC.x265-MeGusta/. Ensure the path exists and the user running Sonarr has the correct permissions to access this file/folder


The odd thing is, the permissions for /volume1/downloads show that the docker-user has full control, as I set it. (that is the user running Sonarr, right?)
And I even have SABnzd set to make completed downloads permissions have a 777 permissions (just in case).


1669240923118.png


So I'm curious as to why radarr doesn't have an issue downloading using that SABnzd, yet Sonarr does. I have double checked, and I have the exact same settings for "Download client" on both radarr and sonarr.

So I'm missing something obvious, probably in my Sonarr config. But what? I don't want to change my SABnzd config, until I know that I have Sonarr and Radarr running fine, using the docker container. That way, if I have issues running SABnzd as a docker container, I can fall back to using the community package, until I resolve the issue, because I know that works.

I do have the "Remote Path Mappings" set to point to the existing structure.


1669241134678.png


1669241309057.png
 
I am running nzbget and sonarr as container.

From the perspective of the nzbget container the complete folder is mounted into the path /complete.
From the perspective of the sonarr container nzbget's complete folder is mounted into the path /complete.
In this scenario the path on the host is irrelevant.

Since both containers use the same path for the complete folder, it was not required configuring any remote path mappings at all.
 
Upvote 0
18
4
NAS
DS1019+, DS916+
Operating system
  1. Windows
Mobile operating system
  1. Android
  2. iOS
An update: I tried running SABnzbd as a container, following this guide

And after changing the Sonarr download client to point to this instance of SABnzbd (I told it to use a local port of 8088, so it wouldn't interfere with the working port 8080 of the community package version). And once I followed all the details (making a new path for SABnzbd to use, and now removing the "Remote Path Mappings" (which I won't need, if all the programs are running in containers in the same host, under the same structure).

And now it worked! (well, I had to create the folder for the show on my own, but I will work on that next)

2022-11-23 18:38:37.9|Info|SonarrBootstrapper|Starting Web Server
2022-11-23 18:39:44.7|Info|ReleaseSearchService|Searching indexers for [Wednesday : S01E01]. 3 active indexers
2022-11-23 18:39:47.6|Info|DownloadDecisionMaker|Processing 27 releases
2022-11-23 18:39:58.7|Info|Sabnzbd|Adding report [Wednesday.S01E01.1080p.HEVC.x265-MeGusta] to the queue.
2022-11-23 18:39:58.9|Info|DownloadService|Report sent to SABnzd. Wednesday.S01E01.1080p.HEVC.x265-MeGusta
2022-11-23 18:41:10.7|Info|RecycleBinProvider|Recycling Bin has not been configured, deleting permanently. /tv/Wednesday/Season 1/Wednesday - S01E01 - Wednesday’s Child is Full of Woe HDTV-1080p.mkv

So now I can change Radarr download client to be the same, and I can stop using the community packages all together, and not have to worry that upgrading one will break the others (such as when SABnzbd got upgraded last year, and had that certificates problem).

Progress!

Thanks
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Solved
Brilliant, thanks again (y) 1638624696 It's working fine now, thanks very much for your help (y)
Replies
4
Views
1,485
Yes I did... just a typo in the post Not sure what you are looking for... the container itself doesnt...
Replies
17
Views
12,045
@one-eyed-king , I have tried your first step: sudo synogroup --add docker and encounter the following...
Replies
11
Views
19,016
OK... That seemed to work when I changed the group from user to administrators (while using an...
Replies
6
Views
7,787
Configure the second reverse to run on a custom port, just so you can port forward from a custom port to...
Replies
3
Views
1,441
In the event your CalDAV syncing via DAVx⁵ has failed with DSM 7 RC, a workaround is to set the TLS/SSL...
Replies
0
Views
1,903
  • Question
Sure, thanks for the tip, apparently it can workaround the Web Station bug although I wonder how this...
Replies
6
Views
536

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top