Solved Photo Station: no image information

Currently reading
Solved Photo Station: no image information

Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
  2. iOS
After a couple of days summer vacation,
I uploaded about 300 images to 3 new folders in Photo Station
using Photo Station Uploader running on a Win 10 PC.

Unfortunately, all these images in Photostation show "null" in every image info except filename and resolution.
The result is that images from different cameras - mobiles cannot be sorted in time because their dates are unknown.

If I download any image from the Photo shared folder all these info exist in the images.

These are the first photos I uploaded to the 218+.
Thousands of previous photos that transferred from my previous Synology 116 through HyperBackup are shown correctly with their info.

I couldn't find a solution for this.
you know, it's a time, when your existence disappear from normal life also from this forum, until your hands reach out to the nearest smart devices, laptop, computer, ... or last beer :cool:
try to use some tools for batch XMP/EXIF/IPTC metadata check/rewriting

thanks for the suggestion, I'll try it, but I don't know if it will help

because these uploaded jpegs are from different sources,
some directly from a Fuji camera, other from an iPhone, other from an LG android phone,
and some have metadata added with the Daminion app.

Also all these jpegs, even if I download them from the Photo folder on the NAS,
their metadata are correctly read from both Windows and Linux file browses and other programs.
@kiriak just try to rewrite part of the data (sample), because there is obviously issue of the metadata write operation in Photo station side DB (PHP parser) like exif_read_data (possible NULL value reason). There is also known bug (or feature) in the for the exif parser:

Here is a little background on how ext/exif works and what went wrong:
Internally when we parse the exif data, it will read out the standard exif tags as provided by the spec, however certain formats, have certain custom tags. These are usually parsed too, however ext/exif is limited in the sense that we only (in stable branches including 7.1) support 6 formats with extended tags (the list for each format is baked into the extension). This is where the regression comes in. When parsing the EXIF data, it is done in the following order:

  • Standard EXIF data
  • Look for known formats for parsing custom tags, if a matching signature is found, then parse them
  • Parse additional data, like thumbnail, GPS etc

PS: not 100% sure if Syno uses this official PHP parser (but I see some symptoms there)
maybe check it by ticket in Syno support, hope you will find someone with attitude to find a reason from Dev team. Good luck.
Maybe the ticket is the best idea, I don't know what else to do.

In the mean time I uploaded a few files from older cameras and mobiles.
Again no exif data show up in the photo station.

The same photos were uploaded on the DS 116 I had previously and everything worked as expected.

Something is wrong either in the side of Photo Station Uploader or the Photo Station side.

Idea: I'll try to directly upload a few photos to Photo Station, to narrow it down.
the other day I was searching in the package center
and I noticed the "Run" button on the Photostation's tile.

Hitting it started re-indexing the whole library and this fixed the problem.

I feel a little dumb, but I have excuses.

I used Photostation many times, set preferences, set users, browsed the already uploaded pictures.
It worked fine, until I upload photos for the first time ( previosly about 14.000 photos were restored from HyperBackup of my previous Synology).

After the reboot, the "Run" button was again there (instead of Open).
I haven't noticed this in my previous DS 116.

Anyway I'm happy that this is solved now.
It is an old thread but after some time I discovered the reason for this.

My NAS is on a daily ON/OFF power schedule.
The Photos share is encrypted (and auto-unlocked after boot with a hidden USB stick).

When the NAS boots ,
it tries to start the Photostation just before the Photo share is unlocked,
and it fails to start it.
So, Photostation is not running.

The browsing of the photos works just fine (probably through the WEB Server, I don't know),
but when trying to add new photos via windows uploader application,
it adds the photos to the specific folder but doesn't index them.

When I had this problem back in August, PhotoStation wouldn't start running in the 12 hours that the NAS was ON.
Recently this changed and some time after boot (like less than 1 hour) Photostation is up and running.
a magic, good luck
magic? I don't understand.

Anyway, the problem is now solved,
but the encrypted share could be again the root of a similar problem in the future,
so it is good to be aware of this possibility
1. When you have setup of Automated decryption, it will be done after reboot. Then you can’t start the photo station first = you need wait for the boot finish.
Q: are you really wrote about auto or manual unlocking process?
Because when you have manual process, or postponed auto process, you can’t see encrypted content in locked Share.

for running of the photo station in browser you need entire package ON (incl. PHP)
- there isn’t way to show the content just with webserver w/o the package ... it would be the magic when yes
- then your photo station is running. Check pls Resource manager.

2. process called “synoindexd” is running?

3. What did you see in Control panel/ Media Indexing? ... I mean the indication of indexing

4. try to upload directly to the Shared folder w/o the Windows uploader. Is it correct? I never used the uploader, for me it’s ...

5. Re auto Encryption: what about setup a scheduled task:
- run the photo station from boot (postponed start)
the unlock is auto

but after boot, Photostation is not running.
In the package center the Photostation is Stopped and it is not in the Services list.

Even in this case, I can normally browse my albums and photos opening Photostation in a browser.
I can even upload photos and they show up.
But it doesn't convert/index etc. the photos, either uploading them with windows uploader or directly.

For the NAS to be able to read and index the photos, I have to go and start Photostation first. It makes sense, but everything else is working fine, even if Photostation seems to be Stopped. Obviously some (sub)processes of the package are running in the background.

Anyway, now I know what was causing the initial problem with the missing image information.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Thanks Rusty, lack of main task! 1623374757 Let's me try. thanks @Telos
  • Question
Bump! No one else had this problem?
  • Question
Guessing to just wait for Syno Photos on DSM 7. I doubt submitting ds photo as a bug will gain much...
Considering that I don't use PS or Moments, but have been testing Synology Photos with DSM7, wanted to...
thanks guys! I had the same issue today - nothing was showing up in the Photo Station after moving some...
If I'm remembering right, as of DSM 7 there are three (3!!) of their mobile apps that support iOS [+...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!