photos sharing link not working since DSM update

Currently reading
photos sharing link not working since DSM update

334
67
NAS
Synology DS920+
Operating system
  1. Windows
Mobile operating system
  1. Android
Has anyone experienced a problem sharing photos since the latest update. Usually I just check the photo, click on the share button, copy the link and hit save. I then go to the link myself and it opens just to check. However, it now says refuses to connect. Did synology change something? TIA
 
Hey guys, I got it working. However, I appreciate it if someone could look over my settings. Turned out that a week ago we had a major power outtage. For some reason my router lost it's setting and I had to try to remember what was there. I'll add the images of both the router and my synology firewall. Appreciate it. TIA

fix.JPG
fire.JPG
 
Good catch. It's a good policy to backup the router if you can, or screenshot the important screens :)

BTW your port forward for DDNS 6690 is actually Synology Drive Server's TCP port for desktop/server sync. It's only the description so not an issue but may help you later. Though it looks like you are also using the public IP subnet 162.168.1.0/24 for your LAN (is that a typo for 192.168.1.0?).
 
Lol, I thought I did a screen save before I rebooted the pc, but I guess in my frustration I never saved it. I removed the 6690 as I'm not sure it's necessary and I can still access using the apps on my cell network.

Your statement: "Though it looks like you are also using the public IP subnet 162.168.1.0/24 for your LAN," explains why the firewall insisted I add the management ui in. DUH, should be 192.168.1.0, which it is now. Also just backed up the router🙃
 
@fredbert. DSM just updated SMB and alerted me about updating my firewall. However, I can still access the nas with windows explorer. A bit confused over the alert. here's a screen grab:
firewall.JPG
Don't want to mess up your work.
 
The alerts are because you have the notifications enabled, unlike me.
1689177277362.png


If you have already allowed your LAN to access the NAS for any service then you don't have to add a new rule for local access. Also if SMB was working for you before updating SMB Service then it will still work without modifying the firewall policy.

Just check what it is notifying and see if you already have a rule covering it for the source IPs from where you want to have access. Unless you are installing a new package/service then it's quite unlikely that you need to add rules.
 
When you create the shared link for photos does it just have your ddns name in it or does it append your dsm port number to it? If there’s no port number appended to the ddns name that could be why. You could test by copying the shared link and add the port number after the ddns name like this :xxxx then there should be a / to continue the rest of the link.

I can’t recall if we had setup reverse proxy for you, I don’t think we did. If you had reverse proxy the benefit there is you don’t need a port number in the shared links when sharing. Considering your port forward options I’m thinking you don’t have reverse proxy and you probably need to include your dsm https port after the dns name in the shared link.

Post/dm me a test shared link and I can tell ya if it looks right. If you had reverse proxy than port 443 would be the external port forwarded to your internal dsm https port. Since all web requests are a default of port 443 you don’t have to include a port number in the ddns name that way. If you don’t have reverse proxy you’ll have to include the dsm https port number into the shared link.
 
Not to worry as I got it straightened out. Fror some reason while I was fixing the remote access glitch I looked at my firewall and the one we set up was gone. So, instead of freaking out I searched youtube for Synology firewalls and found a new one from SpaceRex. Followed his plan and got everything back to working access. When I did that, Synology photos was working again. I figure you might be curious so I'll attach it.

Capture.JPG
 
Not to worry as I got it straightened out. Fror some reason while I was fixing the remote access glitch I looked at my firewall and the one we set up was gone. So, instead of freaking out I searched youtube for Synology firewalls and found a new one from SpaceRex. Followed his plan and got everything back to working access. When I did that, Synology photos was working again. I figure you might be curious so I'll attach it.

View attachment 13311
Awesome
 
Not to worry as I got it straightened out. Fror some reason while I was fixing the remote access glitch I looked at my firewall and the one we set up was gone. So, instead of freaking out I searched youtube for Synology firewalls and found a new one from SpaceRex. Followed his plan and got everything back to working access. When I did that, Synology photos was working again. I figure you might be curious so I'll attach it.

View attachment 13311
To be clear, these rules allow all traffic to any port/service on your router, from any US IP address.
...and they allow access to DSM, File Station (and any other services you've added to the list) from any IP address in the world...

Is this what you intended? I've not seen any other details of your setup, but am presuming you're doing some other 'real' firewalling and port forwarding on your router, before traffic from the internet hits your Synology? Or are only allowing access via a VPN?

If not, I'd suggest that the rules above are far too open to adequately protect your Synology.
 
To be clear, these rules allow all traffic to any port/service on your router, from any US IP address.
Agreed the us allow rule should be restricted to only the services that you need to access outside of your LAN; aka when your away from home

In reality rules 4 & 5 could also be merged together.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

https://www.reddit.com/r/synology/comments/1b5mjm2/problem_adding_new_user_permissions_to_synology/
Replies
1
Views
308
If it solves your problem and the files appear to be recognized and work properly, I would indeed rename...
Replies
1
Views
350
  • Question
Hello, I am using Photo's (and its predecessor) for many years and am happy with it (however I miss manual...
Replies
0
Views
436
  • Question
Context here is: Synology Photos, browsing fotos with the quick filter enabled and more specifically what...
Replies
0
Views
391
  • Question
Having Problem with External User Access to Synology Photos: - I have set Shared Permission to...
Replies
0
Views
605
  • Question
Thanks Rusty… so it’s basically a storage/organization app and really isn’t equal to Apple’s Photo/iPhoto...
Replies
9
Views
1,031
Hi all, I've got a sort of large photo collection, and I do a lot of Google Maps style photography. This...
Replies
0
Views
615

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top