PHP Versions

Currently reading
PHP Versions

229
84
NAS
DS918+
Operating system
  1. macOS
Mobile operating system
  1. iOS
On my Web Station I have it working fine with PHP 7.4, but I also have older PHP packages installed: 5.6, 7.2 and 7.3.....

The question is am I safe in removing the older packages? I 'know' the answer is yes, but I'm playing safe and looking to double check with you guys, just in case.....
 

Telos

Subscriber
1,578
523
NAS
DS418play, DS213j, DS3622+, DSM 7.1.4-11091
That's what I did. Started with the oldest. If it was a dependency for another package, a pop-up message appeared telling me that I must first uninstall the dependent package. Otherwise, I uninstalled the package and made a note of what I uninstalled, just in case. I've seen no issues.
 
229
84
NAS
DS918+
Operating system
  1. macOS
Mobile operating system
  1. iOS
Last edited:
Thanks, I've managed to uninstall 5.6, 7.2, but when looking to remove 7.3 I get:
Screenshot 2021-05-08 at 17.14.14.jpg


I've looked in phpMyAdmin and can't see any way to change it to use 7.4 instead of 7.3.....
-- post merged: --

It seems that it s hard coded in phpMyAdmin to use v7.3 so I'll hold off looking to remove it. I did manage to get rid of Apache 2.2 as well as I had that and 2.4 installed.
The removals have significantly speeded up the the web site which is good news!
 

Telos

Subscriber
1,578
523
NAS
DS418play, DS213j, DS3622+, DSM 7.1.4-11091
Synology often hard codes dependencies version, presumably to avoid breakage. It's possible that at some future revision the hard code version embedded in phpMyAdmin will be updated. Until then, you're stuck.

FWIW I have a similar situ w/Photo Station and PHP7.0.
 
229
84
NAS
DS918+
Operating system
  1. macOS
Mobile operating system
  1. iOS
Yep it looks that way, it's not a problem now that I know about it.
 

Rusty

Moderator
NAS Support
3,761
1,083
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
There was a similar situation with php version for the new calendar package a while back. It turned out that it also needed a specific version of php in order to run even though it had an upgrade version already installed.
 
229
84
NAS
DS918+
Operating system
  1. macOS
Mobile operating system
  1. iOS
If it's common for Synology to do this then I'll not worry.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top