Please help me, slow transfer speed

Currently reading
Please help me, slow transfer speed

920+ and 218play
Operating system
  1. macOS
Mobile operating system
  1. iOS
I've read a lot of solutions online with no luck. I've talked to Synology Support. And tested all the solutions they had. With no luck.

Transfer speeds are ridiculous slow. Both on my 218play and 920+

I tried to install openspeedtest in docker, but when I hit start test it says network error.

Right now I transfer one file which is 77GB, and it says the transfer will take 3 hours....

Both are connected with a ethernet cable, so no wifi. I've tried clear smb cache and every other solution I could find. Nothing seems to work.
As there are so many factors to look at, you will not get a good answer to this question.
The answer will be as good as the question.

So to help you, we need a lot of extra information.
starting with the hardware, cables, switches, and other hardware.
Did you already swap any of these?

then software, which pc/ mac, os, linux?
did you run nasspeedtester on Windows or blackmagic for Mac, what did it tell you?
did you do a 3seconds reset on both nas to reset network settings to default?
Do the nasses tell you if they are connected with 1000mbps in info screen?

how did you copy? via pc of directly nas to nas ?
Last edited:
A year or so ago I had issues, Sometimes speed good, mostly bad, GB devices reporting as 100Mb, etc.... and it ended up being traced to cables I bought off ebay... They passed LED Ethernet Tester, but were bad in other ways....
Of course I didn't have any other tester to compare them against, and a $800 or so professional tester was out of our budget. Was turned onto a 5 port GB Netgear Managed switch, (GS105Ev2) that had a cable test routine in it... Bought new cheaply (~$20)... It flagged 100% of the Ebay Cat 6 cables as being an Impedance Mismatch... and one other that had been in use for years... EVERY ONE of the cables that tested bad -- Tested Good with LED Tester!!!
Pitched all cables that failed... LED Tester never used any more. New cables tested before install, also! Haven't had a issue since !!
there are so many factors to look at, you will not get a good answer to this question.
The answer will be as good as the question.
As we can only guess, I have read anecdotally that disabling IPv6, may increase transfer rates. I cannot say personally if this is true, however I have disabled that capability on all my NAS.
As others have mentioned, definitely need some more information. One thing that doesn't sit right with me is that both your newer and older unit are having the problem, which to me indicates the root issue is somewhere in the network.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

For failure rate, the backblaze article on the topic is interesting...
  • Question
Well that is a relief thank you Rusty, I've submitted a support ticket with Synology. Like you say, I...
Glad you got your answers, I was going to suggest the same thing, replace 1 drive at a time, rebuild pool...
  • Question
Or when using Plex migrate the DVD files to mkv
920+ According to this, x13 models should be covered with ARM7 version of Plex. Keep in mind that...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads