Plex no longer allows me to add path to Synology

Currently reading
Plex no longer allows me to add path to Synology

24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
I'm on the current build of synology 6.2.4.x and I've just moved house. As I was setting things back up, I got the Synology up and running and launched Plex. My local Synology libraries are all gone. I figured something hiccuped so I went to add them anew. I followed the normal path of clicking the three dots next to Movies and looked for the Add Library action, but it wasn't there. Plex on the Synology is on version 1.24.5.x

This made me think that something really borked so I checked permissions and they seem to be correct (I re-watched tutorial videos to confirm I wasn't confused).

I'm sure this is user error (because it usually is) but I'm stymied. It's like my version of Plex doesn't support connecting to the Synology and I can't understand why.

Any thoughts are incredibly appreciated. Thank you.
 

Rusty

Moderator
NAS Support
4,642
1,338
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
If you moved house and didn't update Plex and/or DSM there doesn't seem to be a reason for your problem. Plex system account has permission on your libs? You can confirm this? What does the Plex log say?
 
24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
Well, I didn't upgrade prior to moving, nor since. Attaching screen shots of the plex user's permissions + the shared folder permissions
Screen Shot 2021-11-23 at 8.46.34 AM.png
Screen Shot 2021-11-23 at 8.47.02 AM.png


Is there some other screen shot that would be helpful? Where do I find the Plex log? (forgive my ignorance, please)
 

Rusty

Moderator
NAS Support
4,642
1,338
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Well in your second image, your plex account does not have permission to your media folders.
 
24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
Well in your second image, your plex account does not have permission to your media folders.
Yes, but all of my media is in the Plex folder...? This has not changed.
 

Rusty

Moderator
NAS Support
4,642
1,338
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Uuuuu, thats a MAJOR DO NOT DO suggestion from Plex team. Register your question on the plex forum for assistance on the matter. Maybe Chuck will be able to resolve this for you. Start with the fact that you have media content inside the Plex configuration folder as well.
 
24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
Okay, thanks. Will do. However, this has been my configuration forever and it worked perfectly. I don't have the media in the configuration folder itself, but in the Library sub-folder.

Screen Shot 2021-11-23 at 8.58.50 AM.png
 

Rusty

Moderator
NAS Support
4,642
1,338
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
I hear you, but anything inside the root of Plex system folder should be avoided. If you check the root of Plex folder you will see the warnings, not to place media there. This includes subfolders.

1637673022976.png
 
24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
I hear you, but anything inside the root of Plex system folder should be avoided. If you check the root of Plex folder you will see the warnings, not to place media there. This includes subfolders.

View attachment 4879
Okay, I get it. For the sake of trying, I put a movie into the Media folder to see if that changes anything. I also gave my Plex user access to that folder. I still get bupkis from Plex for being able to map a library:

Screen Shot 2021-11-23 at 9.14.44 AM.png
 

Rusty

Moderator
NAS Support
4,642
1,338
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Because you are not using your Plex server. That Movies and Shows is the official Plex lib (cloud one). click the More section and find your local server.
 
24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
Because you are not using your Plex server. That Movies and Shows is the official Plex lib (cloud one). click the More section and find your local server.
Tried that. It creates circular logic, claiming I don't have Plex Media server (which is what is open and is what the screen shot is from ... this app was opened from my Synology Package Center, where PMS is installed). I swear I'm not trying to be stupid; I really am entirely confused, because I've never been in this circular loop before.

Screen Shot 2021-11-23 at 9.18.41 AM.png
 

Rusty

Moderator
NAS Support
4,642
1,338
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Looks like something happened with your install of Plex. Like I said, focus on the plex forum and ask them for suggestion or restore your plex configuration from backup if you have it.
 
24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
Looks like something happened with your install of Plex. Like I said, focus on the plex forum and ask them for suggestion or restore your plex configuration from backup if you have it.
I've posted there. Your suggestions and patience are greatly appreciated. Thank you.
 

fredbert

Moderator
NAS Support
Subscriber
3,142
1,249
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
It looks like you are logged into the Plex web interface and there is no PMS associated yet. Go into the Settings and see if your server is available (half-way down the list on the right side).

Is PMS running on the NAS?
 
24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
It looks like you are logged into the Plex web interface and there is no PMS associated yet. Go into the Settings and see if your server is available (half-way down the list on the right side).

Is PMS running on the NAS?
No joy. Yes, PMS is running:

Screen Shot 2021-11-23 at 9.30.22 AM.png
Screen Shot 2021-11-23 at 9.31.02 AM.png
 

fredbert

Moderator
NAS Support
Subscriber
3,142
1,249
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Try browsing to https://nas_ip:32400/web to be sure you are connecting to the NAS's PMS.
 

Rusty

Moderator
NAS Support
4,642
1,338
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
From this it looks like the server is not claimed any longer on your account. You will have to edit the plex preference config file to get it going and get a new claim code from the plex web site.
 
24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
Try browsing to https://nas_ip:32400/web to be sure you are connecting to the NAS's PMS.
"This site can't be reached"

This is now making me wonder if my new ISP is causing the issue and Synology can no longer talk with Plex. Bother. I'm anything but a network guru.
-- post merged: --

Interestingly, my NAS is among the authorized devices list...

Screen Shot 2021-11-23 at 9.46.30 AM.png


Somehow, they've lost their ability to speak to one another.
 

fredbert

Moderator
NAS Support
Subscriber
3,142
1,249
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
That Settings page is from plex.tv (not from your NAS's PMS) and it is just telling you the NAS was last connected three days ago.

You should be able to browse to the local IP address of the NAS, on TCP 32400, and access the PMS it is running. There should be a link to the local PMS from its page in Package Center.

At the new house have you got a different ISP and the LAN subnets are different? Basically: what's different between your old house's local and Internet configuration and the new house?
 
24
2
NAS
DS718+, DS920+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
That Settings page is from plex.tv (not from your NAS's PMS) and it is just telling you the NAS was last connected three days ago.

You should be able to browse to the local IP address of the NAS, on TCP 32400, and access the PMS it is running. There should be a link to the local PMS from its page in Package Center.

At the new house have you got a different ISP and the LAN subnets are different? Basically: what's different between your old house's local and Internet configuration and the new house?
So that instance of Plex from which I took the screenshot is the instance I opened from within Package Center.

My new ISP is Starlink. But I am using my old Asus router (running merlin), and have made sure that the static IP I set up for the synology has stayed the same. This is NOT my strong suit and I generally figure things out as I need them, which may well lead to me making dumb mistakes that I don't realize are dumb.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

While this may be an irritation, and I read in the article linked by @itsjasper that some have had issues...
Replies
4
Views
5,606
Not heard of TVHeadend before. Unless someone comes along that does use it it may help if you add more...
Replies
1
Views
171
It seems my Plex is not playing nicely with my Firestick. Upgraded to the Firestick 4K MAX and still...
Replies
23
Views
633
Upon reinstalling plex, there was this helpful message, which I had previously dismissed. This fixed the...
Replies
4
Views
336
Have Plex server running on the Synology DS7.0+ - all seems fine except not able to access while remote...
Replies
0
Views
340

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top