Push notifications via Pushover app partially working

Currently reading
Push notifications via Pushover app partially working

SynoMan

Administrator
Moderator
Founder
1,435
818
www.synoforum.com
NAS
DS720+, DS418play
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Hi guys,

I have a problem with push notifications on my two NAS devices and one VMM. I set push notification to work over Pushover like this:

Screenshot 2021-03-28 at 15.48.56.png


When I click on the button to get the test message I get it normally. But when there are any other notifications from NAS, I don't get them to Pushover. And yes, I have checked the notifications under Advanced tab and in settings for notifications:

Screenshot 2021-03-28 at 15.55.57.png
Screenshot 2021-03-28 at 15.55.45.png



I would really like to use Pushover and I know it should be working because it works for the test message. So, I don't get notifications from Hyper Backup, or system events, notifications from the package center for new package update,s etc.

Any thoughts appreciated.
 
I've found an interesting workaround, but it works over SMS:

I would still like to know why it does not work with a mail gateway.
 
Upvote 0
Last edited:
What’s the advantage of using pushover over mobile device notifications?
I don't have to use the DS Finder app in that case and Pushover can be used for many other services too. Also, your push notifications stay in your Pushover app, if you'd like to read them later or just dismiss them. You can also separate notifications in Pushover by service or applications. That way it is clear for instance from which NAS you get a notification. You can also add a NAS icon if you want:

IMG_1071.PNG
 
Upvote 0
Last edited:
@Telos Yes, with this workaround and it still works on DSM 7:

I've found an interesting workaround, but it works over SMS:

I would still like to know why it does not work with a mail gateway.
I think I've never managed it to work over the Push option in DSM. Also, Push in DSM 7 is a bit different:

Screenshot 2022-07-21 at 21.54.58.png


-------
There is no option to add Pushover email, but as said, it works with SMS workaround.

Have you tried it yourself?

If you're using RocketChat you can also use Webhooks:

Works perfectly.
 
Upvote 0
Well... This is weird. I created a new Shared Folder Sync task and a new Hyper Backup task. Both gave notifications on completion. So now to see if that "fixed" things overall, or only for recently created tasks.

I'm curious about how you set NAS icons with a pushover email address. I only see that via application API creation. However, I did notice that it appears you can "send as" an email address as an application (whatever that means).
 
Upvote 0
Well... This is weird. I created a new Shared Folder Sync task and a new Hyper Backup task. Both gave notifications on completion. So now to see if that "fixed" things overall, or only for recently created tasks.
🤞


I'm curious about how you set NAS icons with a pushover email address. I only see that via application API creation. However, I did notice that it appears you can "send as" an email address as an application (whatever that means).
I don't see any settings for that. Maybe if you set it to Send As < application > (and you set an icon for that one) the image will show for email. Haven't tried though.
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top