Python3 (for sabnzbd) on Beta 7

Currently reading
Python3 (for sabnzbd) on Beta 7

5
1
NAS
DS220J Beta 7
Operating system
  1. Windows
Mobile operating system
  1. Android
Currently Python3 is not supported and cannot be installed. So I cannot use sabnzbd.

Is there any way to get this still installed or any information on when Python3 is supported? Python2 is not enough :)

Thanks!
 

Rusty

Moderator
NAS Support
2,845
870
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Currently Python3 is not supported and cannot be installed. So I cannot use sabnzbd.

Is there any way to get this still installed or any information on when Python3 is supported? Python2 is not enough :)

Thanks!
Docker an option for you on your nas? If so I would recommend pushing sab via docker.
 

jeyare

Subscriber
1,756
577
don’t wait for Syno and Py upgrade ability. Reason is simple- there is heavy incompatibility gap between Py 2.x and 3.x.
Then you can’t simple change major core versions.
Reason why I use Jupyter DataScience notebook with Py3.x and Julia/r in Docker container. Simple and independent from Syno.
 
5
1
NAS
DS220J Beta 7
Operating system
  1. Windows
Mobile operating system
  1. Android
Thank you guys! Docker is not supported by DS220J. So I continue to use download station and hope to control its wakeups even with no jobs running.

I'm sure sabnzbd will run/be updated once DSM 7 is final and not beta. Let's pray ;)
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Similar threads

Top