Question about Photo Station folders

Currently reading
Question about Photo Station folders

19
2
NAS
DS918+
Operating system
  1. Windows
Mobile operating system
  1. Android
Just tried DS Photo and Photostation and it looks good. Problem is it only wants to save to a specific folder called "Photo" on the NAS. I am using Synology drive to sync all my photos from my pc but it wont let me store those photos in the same folder that photo station uses. How can i link these two?
Thanks
 

fredbert

Moderator
NAS Support
Subscriber
1,619
674
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Moments package and mobile apps? There'll be a harmonisation of Photo Station and Moments in DSM 7: Synology Photos [see release notes]. No idea what that will do for photo locations.

Moments stores user photo/video files in /home/Drive/Moments/. If you backup from mobile Moments (happens when the app is opened) then it's to /home/Drive/Moments/Mobile/<device name>/. For my Android phone there's then a DCIM folder. Then all my phones have folders by date.

The Moments shared album uses Photo Station's shared location, /photo. But the personal albums are different: /home/Drive/Moments and /home/photo, respectively, and never the two shall meet.

The photo packages are prescriptive for their folder locations.
 
19
2
NAS
DS918+
Operating system
  1. Windows
Mobile operating system
  1. Android
Last edited:
I found that I had to go into Synology Drive admin console and enable that "photos" folder under Team folder. So now I see the folder in photo station but cant see all the sub folders and cant see any pictures but in the top right there is a "conversion progress" thats been running all night and says total images 30105 and counting down. Do I have to wait for this to finish to see the pictures? Seems to be converting 180 pictures every 10 min.
 
19
2
NAS
DS918+
Operating system
  1. Windows
Mobile operating system
  1. Android
I wasted 3 days waiting for the conversion to finish and I still cant see my pictures!!!!!!!!!
 
1,071
356
NAS
DS418play, DS213j, DS3621+, DSM 7.0.4-11091
Too late now... but for future reference... dumping 30000 photos on a package you're unfamiliar with is unadvised. Ten would suffice, and you could easily see how sharing/thumbnailing/facial recognition/albums/etc/etc work.

IMO you would be better off moving those photos to a temporary storage folder and beginning again in a more conservative approach.

I found that I had to go into Synology Drive admin console and enable that "photos" folder under Team folder.
That has nothing to do with how Photo Station works.
 
19
2
NAS
DS918+
Operating system
  1. Windows
Mobile operating system
  1. Android
After almost 4 days the conversion finished but i still cant see the albums. See how "ALL PHOTOS" is hashed out, that is whats going on. If I create a new folder in "J" directory, I am able to move "Cars", "Work" and "Wallpaper" into it and it shows up fine, but all other folders are hashed out.

photo station issue.jpg
 

fredbert

Moderator
NAS Support
Subscriber
1,619
674
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Is there a permissions conflict either in Photo Station or File Station? Can't see why there would be if you used the same NAS account to upload the files and log into PS.

Old eyes here, but looks like you have a folder with a ':' in its name. Have you tried removing that?
 
19
2
NAS
DS918+
Operating system
  1. Windows
Mobile operating system
  1. Android
I got a reply back from Synology and they had me send them my log file. What they found was an error on 4 files. I deleted those files then did a reindex and everything showed up fine. They were very helpful.
Thanks guys for the replies
 

fredbert

Moderator
NAS Support
Subscriber
1,619
674
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Hmm, that sort of information should be published so that owners can debug this rather that going bald pulling out hair.

Any idea how they worked out which files and what the errors look like?
 
19
2
NAS
DS918+
Operating system
  1. Windows
Mobile operating system
  1. Android
It showed up in the log. This is what they taught me.

You can open the debug.dat file with 7zip. Navigate to /var/log/messages, and see if it gets caught on files in the future. Messages such as "Failed to get misc info from file" or "Cannot open the file" likely indicate it getting caught on that file. Oftentimes it can proceed, but occasionally it will get stuck.
 

fredbert

Moderator
NAS Support
Subscriber
1,619
674
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Thanks.

Since /var isn't easily accessed using file sharing I thought it would be useful to have a scheduled task to copy the latest /var/log/messages to somewhere that is. The task can be disabled and run as and when required. As 'root' user the script I added directly to the task's script box is
Bash:
#!/bin/bash
cp /var/log/messages /volume1/<shared folder/subfolder>/messages.log
chown <adminuser>:users /volume1/<shared folder/subfolder>/messages.log

I added '.log' since it's recognised as a text file but '.txt' could be used.

Using BBEdit on Mac I can SFTP directly to this file.

** That we can create tasks that run as 'root' without having to authorise them makes me uneasy. On the SSH command line an admin user still has to enter their password when using 'sudo' and these tasks should be the same. Some NAS will be managed by multiple admin users and there should be some log (e.g. out to external syslog server) that records when changes to tasks are made, by whom, and that they authorised it. It would be better to have a roles based admin setup so that some admins have limited powers and they can be permitted to do some activities when authorised by a suitably empowered admin user.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Similar threads

Trending threads

Top