RAIdrive doesn't work anymore-Port forwarding problem?

Currently reading
RAIdrive doesn't work anymore-Port forwarding problem?

Operating system
  1. Windows
Mobile operating system
  1. iOS
I am using a Palo Alto Networks firewall, PA440 at home, and a PA460 at work.
Using RAI drive at work and trying to connect to my DS218 at home.
My synology client drive works fine. Using, user and pass and it connects and syncs my files.
What doesn't work is the RAIdrive. not sure why, I tried everything:
1. tried the external static IP of my home IP
2. tried
3. tried

None worked, not sure what else to do.
I went to Open Port Check Tool - Test Port Forwarding on Your Router and checked my IP and port 5006 and it's open.

Any idea's what could be wrong?
if you can access services on TCP 5006 (the default for secure WebDAV) using one client but not another then I’d ask the support team of the non-working client.

Does the client expect a signed SSL certificate, and do you use one?
I am using synology drive, not sure what port that uses, but I think it uses but not sure the port.
I think it's my firewall because it worked fine before replacing my firewall.
-- post merged: --

I think the other problem is, I turned on 2fa on my NAS, so perhaps it can't authenticate using 2fa as it doesn't prompt for the 2nd form of authentication.
The Synology Drive mobile app uses Web ports, but the Synology Drive desktop client uses a non-Web service (TCP 6690). This is a proprietary connection between Synology clients/apps and server.

I've not heard of RAIdrive, does it claim to support Synology Drive? Or are you trying to access the NAS data using WebDAV, SFTP, or some other file sharing service?

On the PAN NG FW have you got some application aware rules that could be stopping the access?

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Hi! I have a DS916+ NAS that I would like to use as shared files server for our firm. I have setup a...
  • Question
Thank you both for looking into this, I'm happy to say that this is now resolved. It turn out I had...
And disabelong the firewall is like asking “please hack me “. There is no reason I can think of to use...
I'm running solidworks engineering simulations on my PC. For 6 months, I'd been saving the results to a...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!