Reinstall NAS, from DSM7 to DSM6, can it be done?

Currently reading
Reinstall NAS, from DSM7 to DSM6, can it be done?

309
56
NAS
DS923+ (16GB)
Router
  1. RT6600ax
Operating system
  1. Windows
I've been playing with the idea of downgrading to DSM6 from DSM7 (I miss PhotoStation too much!). There are unofficial guides on how to do this and I've done that before on older DSM-versions..
But is it possible to reinstall the entire thing to DSM6? Which means, no downgrade, wipe the entire thing clean?
 
yes it can


This process is downgrade, but you can actually choose at one point what to do, start fresh or keep the config.
 
I used that tutorial and went back to latest 6.x from dsm7.x. PhotoStation was the reason as well. Make sure you follow the exact steps and it will work.
 
Ok. Is there anything that will stop working in the downgrade process? What will happen to my Plex? Docker? Websites for example?
It depends on the final process. If you "wipe" and tell it to install fresh then you will have to reinstall the apps. If you leave the configuration it will leave it as is (still make sure to backup everything that you need!). Further, your data volume will not be touched in that case, but it will be wiped if you select the "wipe" method.

So backup, then proceed with everything.
 
So jobs defined in HB under DSM7? My guess is that should work just fine considering that in case you have dsm 6 and dsm 7 nas and making backup from one to the other it works just fine DSM7>6).

Haven’t tested HB in this “downgrade” method so can’t say 100%
 
Just downgraded. My C2 Hyperbackups are gone ("not compatible" with my Hyperbackup version) so I have to start that all over.
Noticed I lost all external access-settings aswell (thought they were a part of the configurationsettings, but nope). :/
 
Trying to configure my websites again but keeps getting "500"-errors. I've activated "display errors" but I get no errormessages. :(
Seems something happened to my MariaDB-instance aswell. Suspect I got an older version of the database or something.. :/
 
Perhaps the tutorial needs some fine tuning?
Perhaps but the field is large to cover all the possible scenarios. Considering it is an unofficial way to get back, expecting everything to work as before is optimistic and in some cases in might, but still people have to be prepared to fix whatever is broken in the process.
 
WebStation is way crazy. I reinstalled DSM7 again but webstation behaves strange. I can't get PHP running at all now at the moment.. :/ Seems to work when I'm using a www.<xxxx>.com that's redirected to my NAS, but when using an url like mynas.com/<xxx> (=same website as the www.-one) PHP doesn't work.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Just to square this, final report that I ordered a new 4GB SODIMM just in case it was RAM causing the...
Replies
12
Views
1,349
Have you thought of using the DS918+ as a Hyper backup target? You can then restore any file or the whole...
Replies
3
Views
775
Thanks PunchCardBoss, Changing the subnet on the Deco to the default Netgear, basically worked. I was...
Replies
2
Views
954
Considering the current state, just connect to that IP address and continue with dsm installation. The...
Replies
4
Views
1,012
Does browsing for Synology Web Assistant find your NAS? That’s one way to try to find it on the LAN. Other...
Replies
3
Views
1,071
The 1621+ would be a logical replacement, I chose the DS1522+ as it is slightly newer. Answers: A)...
Replies
1
Views
1,153
We managed to update the CMS HA cluster and all underlying VMS recording servers. Probably an error on...
Replies
9
Views
1,597

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top