Reinstalled NAS, can't get Webstation to work properly

Currently reading
Reinstalled NAS, can't get Webstation to work properly

DS923+ (16GB)
  1. RT6600ax
Operating system
  1. Windows
My virtual hosts gives me 403 errors all the time, it worked fine on my previous installation so perhaps I've forgotten something but what? :)
I've tried lots of stuff now for hours but I'm not sure what to do now. :/
I am no expert in these things, so , just sayin.. :) I'm trying to access my websites via IP or dyndns (, they all give 403's, via http or https. I also have a domainname pointing to my address but it gives 403's aswell.
Looking at my /web and I see both http user *and* group and both have full read (no other) permissions. These are inherited [Apply to] by subfolder and files... regardless of the actual file/folder owner in File Station.

However, a folder in /music I used as a virtual host only has http group full read and downward inheritance.

Which user are you using to put content into the document root? Is it a member of http group?

Is the group ID the same as it was for http group in the previous install?
Last edited:
I don't have a http-user, only http-group and it has accessrights to every folder in my web-folder. My old installation didn't have a http-user either btw.
"group Id"?
The Http-group doesn't have any members.. Isn't that strange.?
EDIT: Experimenting a bit with Webstation, changing server to Nginx throws 404's instead, switching to Apache returns 403's..
EDIT 2: Fixed it! Restored a HyperBackup of web-folder + webstation and it works! Something must have happened to the webfolder but I can't see any obvious difference between this one and my "corrupt" one.
Good that you've got it working.

Group ID, like User ID, is a number that is associated at OS level with the group name. When you recreate a group with the same name it may not get the same ID and then the permissions (which resolve to ID) won't work. There should be some consistency for OS level groups but additional groups will be numbered differently.

On the SSH command line run the command id and you'll see (along with uid info) something like this:

gid=100(users) groups=100(users),101(administrators),1023(http)

For users, when I build a new Mac I always create the admin user first. That ID will be the same on all the Macs then. Now I want to create users fred and bert: on Mac1 I create fred then bert; on Mac2 I create bert then fred.

The user ID for fred on Mac1 will be user ID for bert on Mac2, and vice versa. So I don't do this, I always create fred, bert, tom, dick, and then harry if there's a chance of moving stuff between machines at a Unix level.

I've experienced unpacking archives from one machine to another where this has happened. And where there's no user on the target machine with the user ID then files are owned by the User ID only.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Hello sorry about that, but I wrote it on the environment variables, don't know why it wasn't there. I...
Well you can try and post back if you got any questions.
Hi, It's a website developer. All you need is to run webstation and choose a backend web server (from web...
I answer to my own question just in case someone would be interested : I noticied that the nginx config...
I am indeed retired, but when I run out of things to do I may look at getting into Docker and then Linux...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!