Rocket.Chat - SLACK alternative (with MongoDB as backend)

Docker Rocket.Chat - SLACK alternative (with MongoDB as backend)

Currently reading
Docker Rocket.Chat - SLACK alternative (with MongoDB as backend)

6
1
NAS
918+
Operating system
  1. Windows
Mobile operating system
  1. Android
Well done!

Regarding accessing it you need to use the URL that you have defined in your ROOT_URL variable in Docker.

If you haven't changed the parameter then it will expect access on localhost:3000 as the image presents. But ofc that will not work as localhost will in your case mean the device you are accessing it from, and there is no RC instance there.

What did you configure your ROOT_URL to?
Now, I not change ROOT_URL with default value --> I need change it to my nas IP?
 
6
1
NAS
918+
Operating system
  1. Windows
Mobile operating system
  1. Android
Unless you want to have it accessible from the outside of your LAN
It still can not access on my LAN, I check the log don't see any issue
My NAS IP in LAN is 192.168.0.254 --> I access on chrome browser http://192.168.0.254:3000 it still not work.
==> http://192.168.0.254:5000 is work
I changed the URL_ROOT to http://192.168.0.254:3000
Please help me check the log and my container config.
1626964116625.png


1626964225836.png

1626964309367.png

and final, the log of Mongo
1626964633451.png
 

Rusty

Moderator
NAS Support
4,378
1,269
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
It still can not access on my LAN, I check the log don't see any issue
My NAS IP in LAN is 192.168.0.254 --> I access on chrome browser http://192.168.0.254:3000 it still not work.
==> http://192.168.0.254:5000 is work
I changed the URL_ROOT to http://192.168.0.254:3000
Please help me check the log and my container config.
View attachment 4038

View attachment 4039
View attachment 4040
and final, the log of Mongo
View attachment 4043
The only problem I see is the MONGO_OPLOG_URL value of the Db. It should point to the local db value. Double check it. Still not sure how it is still working and starting the server that way.

Not sure if your container is actually working as it should or is this the problem. Try and alter it and let’s see if you are still unable to connect.

Also, do you have any other container running so far?
 
6
1
NAS
918+
Operating system
  1. Windows
Mobile operating system
  1. Android
The only problem I see is the MONGO_OPLOG_URL value of the Db. It should point to the local db value. Double check it. Still not sure how it is still working and starting the server that way.

Not sure if your container is actually working as it should or is this the problem. Try and alter it and let’s see if you are still unable to connect.

Also, do you have any other container running so far?
Thanks for your support, I change the value of MONGO_OPLOG_URL it work now.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top