RT6600AX Checkip/v6 DNS Lookups every 20 secs

Currently reading
RT6600AX Checkip/v6 DNS Lookups every 20 secs

3
0
Router
  1. RT6600ax
Operating system
  1. Linux
  2. macOS
Mobile operating system
  1. Android
  2. iOS
Have DNS on my LAN through PIHOLE with Unbound. Router DNS point to the pihole.

All LAN clients work perfectly, have noticed that the router is making requests to :
  • checkip.synology.com
  • checkipv6.synology.com
In a 24 hour period 7250 requests across the the 2 addresses, approx requests every 20 seconds.

I dont have quickconnect, ddns setup or do not allow acces to SRM from WAN.

I have carried a factory reset, makes no differnce, the router keeps checking the checkip addresses

I have no why they router is request so frequently.

Is there a setting or something I have missed?


Wondering if anyone else has noticed this?

Thanks.
 
After some email tag with Synology Support, received a response, basically its the design the connectivity check in SRM.


I added 9.9.9.9 checkip.synology.com

to the /etc/ssh filenon the router

and no more checkip requests hitting the Pihole.



Our HQ team has come back and said the following in regard to this:

In the current design, SRM will ping checkip.synology.com. The purpose of this is to make sure the router could connect to the Internet. If the router cannot ping checkip.synology.com, you will see a limited connection warning in the network center.

This is why you will see a lot of DNS queries. If you would like to reduce the number of DNS queries, we can add a record in /etc/hosts.

8.8.8.8 checkip.synology.com

The checkip.synology.com will be resolved as 8.8.8.8 so the number of DNS queries will be reduced. But, this has 2 impacts:

1. The service checkip.synology.com will not work anymore.

If you would like to use DDNS, or QuickConnect afterward, you will need to remove this record from /etc/hosts.

2. It will generate the ping traffic to 8.8.8.8.
 
Upvote 0
checkip.synology.com is forever present on the NAS as well where it runs every 3 minutes. I disabled QC thinking I could get rid of it, but that had little impact... Nothing in the hosts file seemed relevant on the NAS.
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Just sharing my experience here. I was getting a little jumpy after having my 2nd Synology router the...
Replies
0
Views
546
I have a UPS so power out isn't and issue. I dont reboot my router that much so not much of an issue...
Replies
5
Views
956
How are you testing? The best way is via ethernet cable, if you are testing using wifi, you introduce lots...
Replies
2
Views
1,161
I just added two DNS A with both public IPs, main ip TTL - Auto, second DNS TTL-1 min and it works well...
Replies
2
Views
515

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top