• Hello Guest! SynoForum.com is celebrating its 5th anniversary! 🥳🎉 Read more...

DSM 6.2 running containers thru a VPN

Currently reading
DSM 6.2 running containers thru a VPN

I would love to use this container as gateway for other containers, but first of all I prepared the container and wanted to make sure, that VPN is connecting and VPN-Public-IP working for the connection.
But can't check if no internet after VPN connection is established :/
bridge_vpn network docker subnet has communication with your host LAN network? Do you have any firewall rules on DSM running that blocks the subnet that this container is running in?
 
bridge_vpn network docker subnet has communication with your host LAN network? Do you have any firewall rules on DSM running that blocks the subnet that this container is running in?
bridge_vpn has been deployed as bridge_network as shown in my screenshot only for this container and maybe more to come. The subnet has connection to the internet but no direct connection to my Host / LAN-network.
 
So VPN is established but after that you can't access the web content. That would be be still a potential DNS or routing issue. Can you test the connection from containers terminal? ping some IP address and hostname just to see if you get any response. If not, then its a routing issue.

but no direct connection to my Host / LAN-network
Can we consider this as something that you have blocked in some way? Are you sure that it is not the reason for the issue you have atm?
 
Use the container's command line...
curl ipconfig.io should return it's connected IP.
can't curl anything since there is no connection to internet in the container after starting vpn connection :(
-- post merged: --

So VPN is established but after that you can't access the web content. That would be be still a potential DNS or routing issue. Can you test the connection from containers terminal? ping some IP address and hostname just to see if you get any response. If not, then its a routing issue.


Can we consider this as something that you have blocked in some way? Are you sure that it is not the reason for the issue you have atm?
firewall on synology is off, am I missing smth?
 
Considering that the net is working for the container before the tunnel is open, I would say this is still some sort of routing issue once the tunnel is initiated.
ye, feels like routing issue.
Internet connection is working until tunnel is up. After that tunnel seems OK, but connection via tunnel to internet is not.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

How did you create the Portainer container in first place? As in exact docker run commands or in case...
Replies
7
Views
1,341
Thank you for this - I'll give it a go and see where I get - worst case I learn something as I go!
Replies
6
Views
1,580
  • Question
1707646023 Old post!! But I have the same isue. To enable the portal, I go into Container Management...
Replies
7
Views
10,240
I have published result of my research as a blog at SVN для NAS под Synology DSM 7.2. Записки Linux...
Replies
48
Views
15,251
Have you tried to setup a rule for specific docker network subnet for that container and test internet access?
Replies
24
Views
9,354
@DeltaGolf Here’s my approach: Docker - NextCloud on Synology NAS using Docker compose (with Portainer)
Replies
18
Views
4,694

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top