Question SABnzbd - cannot create final folder

Currently reading
Question SABnzbd - cannot create final folder

I have the package for SABnzbd installed from SynoCommunity. This has always worked nicely.

However, after the last update (2.3.9-41), after the download it fails with a "cannot create final folder" error.

I have read and understand the new system with the sc-download group. This group has full admin permissions on the folder where SABnzbd is trying to create the final folder/file. I even tried giving sc-sabnzbd full permissions as well, to no avail.

Who can point me in the right direction? :)
 

Rusty

Moderator
NAS Support
2,353
701
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Haven't used SynoCommunity in a long time. Are you sure that the sc-download group has permissions on the destination folder in terms that it propagates permissions correctly?
 
Last edited:
Using the GUI I see that the group "sc-download" has full permissions and that they are propagated correctly. Don't know how I can check this at the *nix prompt?

1597756589983.png


I also checked that the right users are in the group and this also seems to be the case:
:~$ sudo synogroup --get sc-download
Group Name: [sc-download]
Group Type: [AUTH_LOCAL]
Group ID: [65536]
Group Members:
0:[sc-nzbdrone]
1:[sc-radarr]
2:[sc-sabnzbd]
3:[sc-transmission]
4:[sc-bazarr]
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Top