Simple file transfer

Currently reading
Simple file transfer

Is the PC wired, or wireless?
When I copy from NAS to PC, a local drive, the speed is 90-150MB/s., but the same file if I want to write it back the speed of write to NAS /RAID1 is 5-15MB/s.
That could still be a cable issue. Can the PC upload elsewhere at a higher rate?

See here too.
The PC<==> It has is wired
I might agree with your cable suggestion, but in this case, must be an equal speed for reading and writing. But the same cable has a high speed for reading and a low speed for write. In my engineering brain, does not make sense. I am an electronic engineer since 1971, so I had some years of experience in all kinds of hardware issues.
I go now to buy a new high-speed cable from a computer store next to my house.
Generally I swap cables with a working device. But get a good cable... Not some cheap generic thingy. Cat6 or 6A.
@Telos PC uploads very fast on USB3.
Update. got CAT7. Upload regardless of the size of the file is 100-125, BUT... reading is 50 or so/ half of the upload speed.


  • read.png
    4.2 KB · Views: 1
  • write.png
    2.4 KB · Views: 2
Well... that is nearly 10x progress.
PC uploads very fast on USB3.
Not the same. Try uploading to another network device (phone, pc) with a LAN connection.

The link I posted earlier showed speed improvement if using \\LAN_IP, vs \\NAS_NAME. You might try that.
How to use that ?
"It wasn't a NIC speed issue. On the same machine, if I used "\\host\share", I got 5MB/sec; if I used "\\192.168.x.y\share", I got 100MB/Sec. Ergo, not the NIC on either end. Somewhere in the IPv6 stack on the Windows or NAS end, something is hinky."
At the moment, I have a drive Z,

I double-click on it and open a new windows with the content and subfolders, where I can transfer my old tapes.


Where to put the IP address?

Of course, I have to convert DHCP to a Static address.
Hello Telos,
I will give up soon. I changed the name to the IP address, and the speed DROP down to 3-5 MB/s

I got mad, deleted that shared folder, and made a new one. New name and new mapping letter. Speed is still the same.
I have a ticket to support, but no luck or guidance to solve the problem. I was not prepared to enroll in university again just to use a NAS.
Sorry for all your hard work to help me, but I had no luck. I went so many times back and forth, so I do not remember what setting I had for that 120MB/s speed.
Will see what the support will reply and if not, bu January will go back to the seller.

Thanks again
I had a similar issue a few years ago, updated the drivers for my NIC in W10 and the issue was gone.
  1. Find "Command line". in any way, such as through the menu "Start"..
  2. Make sure to run it as administrator so you don't get notification of insufficient permissions when executing commands.
  3. Enter the command netsh winsock reset and confirm it by pressing the key I went into.

  4. A message will appear stating that the directory reset was successful, and then it will send the computer to restart, thus applying the changes after the reset.
  5. If this is not enough, you will have to enter the command netsh int ip reset c:resetlog.txtwhich is responsible for resetting the global IP and the IP interface.
  6. The status of both parameters should be displayed «OK» - you must now restart your computer again.
  7. The commands just described affect all zones on the network except DNS, so you will have to type another command - ipconfig /flushdnsto reset these settings as well.
@EAZ1964 Thank you for your suggestions and guidance. Unfortunately did not help. Now the speed, on the same 6GB file jump from 4 to 100 and then back to 5 or 8 or somewhere around 10.
All the commands were done successfully as you can see in the pictures.
I wonder if the RAID1 makes the writing so slow. I will try to remove a drive and redo the whole startup process again but only with one hard drive, no RAID. I will see the speed and compare.
I will let you know. It is ridiculous because NAS in general use RAID, so NAS without RAID, does not make any sense.


  • speed after changes.png
    speed after changes.png
    55.6 KB · Views: 4
  • reset3.png
    12.8 KB · Views: 4
  • reset2.png
    12.6 KB · Views: 2
  • speed3.png
    5.1 KB · Views: 2
  • speed2.png
    6 KB · Views: 2
  • reset.png
    15.4 KB · Views: 4
Changing raid will not make a difference, 80-100MB/s should be possible on any raid type. Unless you have a hardware issue.
The significant hits on performance I know are compression/encryption, bad cable/connection, antivirus, and many windows issues.
In my NAS life I hardly saw write speed issues on the NAS side of the cable, the linux is really robust. Did you try another PC?
also you can use the nas speedtest and check up/download speeds at different file sizes. It will give you better data than the windows copy from explorer.
Also important: what does the system resource monitor tell you while your are copying?
Anything suspicious on memory, cpu or disk IO?
Last edited:
To whom it might read.
I did all the suggestions on this thread, but no luck.
I went even further, remove the HD, put in a new one, and restart. I made just one drive, no RAID. The speed is the same. Jump from 5 to 100 and back in general in the same limits. regardless of the size of the file. The DS220+ is mapped to a drive on the system, and I use "copy" from windows, or TerraCopy to copy a file from my internal HD to the DS.
The product might be good for others, but not for me.
I will read more and try some new tests, and if no luck, it will go back to Amazon.
Wired connection with CAT7 cable
The product might be good for others, but not for me.
FWIW, I have a 213j used for backup, that gave up its Ethernet card... I replaced it with a WD Easystore and connected to my primary NAS via USB3. Transfers are unbelievably quick (vs Ethernet).

Synology in general has substandard bandwidth performance (although SMB is generally OK). Packages like Hyper Backup and Cloud Sync are simply abysmal. Good luck.
I am gone miss you guys.
It is gone back to Amazon and replaced with SABRENT USB Type-C to Dual 3.5” SATA and RAID Docking Station with CFast/SD Card Readers and USB Type-A Port (DS-2BCR).
Thank you to everybody who tried to help me.
I am gone miss you guys.
It is gone back to Amazon and replaced with SABRENT USB Type-C to Dual 3.5” SATA and RAID Docking Station with CFast/SD Card Readers and USB Type-A Port (DS-2BCR).
Thank you to everybody who tried to help me.
Im using one of these Sabrent USB/SATA docking stations. Mine has a WD Red Plus 8TB HD great for using as a Backup for my NAS. Works great.
@bigkenny I trust Sabrent. I have also from them Sabrent USB 3.0 to SATA I/II/III Dual Bay External Hard Drive Docking Station for 2.5 or 3.5in HDD, SSD with Hard Drive Duplicator/Cloner Function [10TB Support] (EC-HD2B).
It is a great docking station. And more, it does off line clone of a drive to another. Very fast as it did not involve windows.
When I do a clone, I remove the USB cable. Read about it at Amazon.
I found my happiness.
190 to 245 MB/s.
I believe that the network raid I had might be great, filled with 1000 of useful applications, but it did not fulfill my basic request - speed.
From my internet provider, they will change my cable/modem router with a new model, Ignite 500.
It is supposed to have a 500MB/s download speed, but you know, the speed is EQUAL with the speed of the slowest link in the chain.
What is good, it has a USB 3.2 gen2 port in the back and I can attach my raid there.
Rogers (the internet provider) will do some setup so I can see that drive-through internet. I know, security, must be addressed but I will see what I can do to protect it.
Plus, when I am home, it is no need to be on the internet.
Here is the new speed
New Speed.png

Have a great day all of you and enjoy computing
My experience with using a server over SMB (windows file sharing) is that you get much better speeds when you map the drive than if you just use the drive in file explorer as \\mydrive. My suggestion is to map the drive to a drive letter on your PC and try it all again. I bet your speeds will improve.
Agree with you, SMB will make the speed so much better and that is what I see when using Gs Richcopy 360 to handle all my backup transfers, it integrates with SMB and really improves the speed too much.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Welcome to the forum. Have you tried to download using any other method besides Download Station? Just to...
I have shared a file which can be downloaded by friends. I was checking the Log Center to see if the file...
Ahah, it was the Sofware Decoding setting. I had it set to On. In the app it says If yhou have problems...
Might be worth checking Windows's sharing/streaming options. It may also be the case that it is added to...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!