Solved SMB share disconnects

Currently reading
Solved SMB share disconnects

137
19
NAS
DS918+
Operating system
macOS
Mobile operating system
iOS
On a Mac I'm connecting to my shared folders in the usual command-K way. I get the list of folders and access one. It mounts and - as usual - the server appears in my Finder window under 'Locations'. Then I remember I need to access that other folder so, as I'm already connected, I click on the SynoNAS in Locations. I'm expecting to see the list of folders on the NAS, just like when I connect to any other Mac running SMB shares.

But no, I get 'not connected', despite there already being a shared folder mounted on my Desktop. OK, let's click 'Connect As...' and the server disappears from the Locations list along with the mounted share.

This doesn't happen when I connect to a Mac SMB...

There must be a setting I'm missing?
 

fredbert

Moderator
NAS Support
Subscriber
1,484
629
NAS
DS1520+, DS218+, DS215j
Router
RT2600ac, MR2200ac
Operating system
macOS
Mobile operating system
iOS
Mac Catalina has had (still has) issues with SMB connections. AFP still works.

You can try adjusting the SMB advanced settings in DSM Control Panel -> File Services. I have min SMB v2 and max SMB v3, and auto encryption.
 
137
19
NAS
DS918+
Operating system
macOS
Mobile operating system
iOS
Using what protocol exactly?
SMB, the command-K shortcut brings up the 'Connect To Server' dialog, from there I'm asking for either smb://MySynoNAS or smb://192.168.1.2
Mac Catalina has had (still has) issues with SMB connections. AFP still works.
I hadn't noticed to be honest. Happily connecting a Catalina Mac to another Mac acting as a SMB server. Solid as a rock. I'm sure there was a reason for not using AFP. Apple have given up on it for sure. I haven't used it in years.
You can try adjusting the SMB advanced settings in DSM Control Panel -> File Services. I have min SMB v2 and max SMB v3, and auto encryption.
I have that other than the encryption which I switched off in the vain hope to speed up some large transfers.

There are lots of 'advanced' SMB settings which I mostly don't understand. Though there might be something there.

It may just be Catalina then as it seems to 'forget' it has a connection.
 

fredbert

Moderator
NAS Support
Subscriber
1,484
629
NAS
DS1520+, DS218+, DS215j
Router
RT2600ac, MR2200ac
Operating system
macOS
Mobile operating system
iOS
OK, so didn't read it since first applying and then doing for new Macs/installs. Force of habit :)
 
137
19
NAS
DS918+
Operating system
macOS
Mobile operating system
iOS
AFP still works.
OK lets give up on SMB for the minute. Its now off and AFP is on.

And guess what. I get the exact same result. Read my original post, substitute "SMB" for "AFP".
 
137
19
NAS
DS918+
Operating system
macOS
Mobile operating system
iOS
Another wee update. Switched SMB back on. Went to another Mac. Other Mac is running 10.13.6. File sharing via SMB works perfectly as expected.

So its a Catalina 10.15.5 problem?

Mac users, what are you running?
 
137
19
NAS
DS918+
Operating system
macOS
Mobile operating system
iOS
"Hello, IT, have you tried turning it off and on again?"

Restarted the Mac. I'll mark this as solved then....

:rolleyes:
 

fredbert

Moderator
NAS Support
Subscriber
1,484
629
NAS
DS1520+, DS218+, DS215j
Router
RT2600ac, MR2200ac
Operating system
macOS
Mobile operating system
iOS
It may have been just a Finder quirk. You can restart Finder without rebooting the Mac...

Apple menubar item -> Force Quit... -> select Finder​

Hoover over Finder icon in the Dock then either of...

Shift + Right Click​
Shift + Ctrl +Click​

Select Relaunch from the pop-up menu.​

If Finder doesn't look like it has restarted you can just click on its Dock icon.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Trending threads

Top