Some packages got broken and are not installable anymore - pgsql issue

Currently reading
Some packages got broken and are not installable anymore - pgsql issue

Operating system
  1. Windows
Mobile operating system
  1. Android
  2. iOS
Linux / syno noob here :)

It seems I had a crash with my DS920 and may have lost some files during it
When I restarted, DSM 7 showed lots of errors regarding my packages (all of them used to work properly prior to it)
I managed to repair some of them but some others did not work, and when I try to reinstall them, they show an error "you need to enable pgsql adapter service". It happens, to name a few, with
- Download Station
- Media server
- Some docker containers, it seems ?

I SSH'ed in my syno and indeed the service is not started, and I was not able to restart pgsql
Also found a similar issue on reddit which I tried the tutorial with, and it did not work :
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.

I tried a DSM7 mode 2 reset, managed to get back into the interface, tried reinstalling, to no avail.
I would have expected a mode 2 reset to solve the issue but it seems not everything was reinstalled on my volume.

Any help would be more than welcome !

Cheers !

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!