SRM Update SRM version 1.2.3-8017-4

Currently reading
SRM Update SRM version 1.2.3-8017-4

SynoMan

Administrator
Moderator
Founder
692
359
www.synoforum.com
NAS
418play
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Version: 1.2.3-8017-4
(2019-10-15)
Important Note

  1. The update will be available for all regions within the next few days, although the release time in each region may vary slightly.
  2. For users currently on SRM 1.2.3 8017 Update 3: Due to issues introduced in Update 3, certain scheduled tasks no longer function as expected. If you have set up and used the following features, manual actions will be required to restore functionality.
    • Checking for Updates & Installing Updates
      • SRM automatically checks for updates in the background and sends notifications to devices you have set up, such as DS router on your mobile device. These features may not work properly if you are on Update 3. Please log in to SRM, then go to Control Panel > System > Update & Restore to initiate the update process.
      • If you have configured SRM only to download updates or to download and install updates, this option will be reset and disabled. You will have to manually go to the Update & Restorepage to select the option and set up the schedule again.
    • Security Advisor’s Scan Schedule
      • If previously enabled, scan schedules will be reset and replaced with a random day and time (this is the default behavior when setting up Security Advisor). Please go to Security Advisor > Advanced and set up a customized schedule.
    • Domain User/Group Update Schedule
      • If your Synology Router has joined a domain, you will need to reconfigure the automatic update interval at Control Panel > User > Domain.
    • Router Scheduled Reboot
      • If your Synology Router is set up to reboot on a schedule, this option will become disabled and you will need to reconfigure the date and/or interval settings at Control Panel > Device > Reboot Schedule.
  3. The following scheduled functions do not require additional user actions to restore to full functionality after updating to Update 4:
    • Traffic reports
    • Wi-Fi guest network’s password rotation
    • Support Center’s remote access
    • Certificate renewal (not user configurable)
Fixed Issues

  1. Fixed SRM being unable to save and perform certain scheduled tasks: automatic updates, rebooting, Wi-Fi password rotation, Security Advisor’s scans, Support Center’s remote access, domain user/group update, and sending traffic reports.
  2. Fixed display issues with update notification emails sent by SRM.
  3. Fixed the issue where SRM might fail to save the IP addresses of gateways and DNS servers after the reboot of Synology Router.
  4. Fixed the issue where PPPoE Relay might fail to work normally after the reboot of Synology Router.
  5. Fixed the issue where SRM might display the item "40MHz only" in the 5GHz band.
  6. Fixed the issue where IPv6 on LAN might fail to be disabled when the interface of WAN is set up by Auto WAN.
  7. Fixed the issue where SRM cannot display Channels 120-128 of the 5GHz band in Japan.
  8. Fixed the issue where Wi-Fi might be forced to restart when password rotation is enabled but the guest network is disabled.
  9. Fixed an issue where SRM might fail to renew the Let's Encrypt certificate after the reboot of Synology Router.

-----

Source: RT2600ac Release Notes | Synology Inc.
 

fredbert

Moderator
NAS Support
Subscriber
1,837
750
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Last edited:
Other links for you in my post here Info - SRM version 1.2.3-8017-3

Saw at 'the other place' ;) there are people having issues with Threat Prevention not being able to succeed in updating the signatures. Check Settings / Status Update and if it's a red warning text then that's the issue.

They worked out a fix (kudos to them) by deleting the TP logs then uninstalling and re-installing the package. First making a backup .dss of the configuration and restoring from it. This worked for me but some also said that the restore didn't work. In case this happened I also did some screen-grabs and saved them in open windows of a graphics editor ... other methods are available. Was then able to do a quick check of the restored config.
 
115
48
NAS
2x DS920+
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. Linux
  2. macOS
  3. Windows
  4. other
Mobile operating system
  1. iOS
Am I brave / foolhardy enough to install it? well of course... lets see how things go. :D
 

fredbert

Moderator
NAS Support
Subscriber
1,837
750
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Am I brave / foolhardy enough to install it? well of course... lets see how things go. :D
Been there; Done that; Wearing the T-shirt :LOL:

Seems to have gone alright for me, but then I didn't notice any issues with update 3.
 
1
0
Router
  1. RT2600ac
Operating system
  1. Windows
Mobile operating system
  1. Android
Hi, I don't know about the others, but in my case, a few days after upgrading to this version, two routers hung and got stuck on the "Starting services" procedure. I was able to restore one to work (although I still struggle with strange deficiencies reported to synology) with the other, unfortunately I still have problems and despite reporting this situation to synology, unfortunately they stated "the router needs to be replaced"and so on in the help topic... Of course, the device is no longer covered by warranty so I have to deal with it myself. Does anyone know the procedure of forcing manual re-upload of SRM_RT2600ac_8017 software and then manually updating criticalupdate ? I have been struggling with this problem for over a month (exciting synology tickets without solution).
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Top