SSL Certificate untrusted - workaround issues

Currently reading
SSL Certificate untrusted - workaround issues

Last edited:
Hey guys,

I've got an issue using Synology Drive. Two or three days ago I've received the message that the used SSL certificate was untrusted. Before that, I was unable to sync my data with the Synology Drive client (installed on a device running Windows 10).

Reading the help reports regarding the issue, I created a "*"-DDNS to create a new, trusted certificate using "Let's Encrypt". Everything worked well so far.

Usually I set a firewall rule to "Lan Only" to make sure that no connection from the internet can be established due to security issues. But due to this issue, I don't have a choice to adapt the setting to use the certificate which was created recently.
The problem is that I am unable to establish a connection via the Synology Drive client by using the DNS. Returning to the local IP-address, I would be able to establish a connection, but I do receive the message regarding the untrusted certificate.

I did edit the firewall rule that was blocking any traffic from outside the local network. Still, I am unable to connect in my Drive client using the DNS.
I've read the article at synology regarding the drive configuration "How can I connect to a Synology Drive Server" but I am not sure if the mentioned steps are helpful:

1. I don't want to set up a "Quick Connect" option - so this solution does not apply
2. I tried to customize the domain for the DMS - it did not solve my issue.
3. I did try customize the domain for the Synology Drive, although I don't want to use the function in the browser. Did not work in browser nor Drive Client.
4. I did not set up the Customize an alias and a port for Synology Drive - option, because of my use case.

So I don't think that any of the options does meet my requirements if I understood correctly.
I also tried to open the port 6690 of the NAS firewall to be able to connect - the option did not work either.

Is there any other necessary configuration to use the Synology Drive client with the "" - DDNS?

Even better: is there a way to create a valid ssl certificate for local conncetions only? If I understood correctly, based on my research, I can create a certificate like this myself, but I do run into the same problem of having an untrusted, self signed certificate which should be used for development tasks only.

I do appreciated any idea or help regarding the issue. :)
In case I forgot about some crucial information, please tell me so I can add it!

Edit 1 (22.11.2022, 20:47):

It seems that the connection problem is not limited to the Synology Drive server.
I am even unable to open the login page when entering the in my browser.
Even with firewall enabled or disabled.
This might be a problem with the port configuration in my router.

Thank you in advance for your support!

Best Regards,

It is me again - and I've got the solution. I am afraid that the problem was me. I did mistype the port for the Synology Drive Server in my router configuration. After changing the port, I am able to connect with the "*" DDNS without receiving the SSL error, since the certificate was created for the domain via Let's Encrypt.

As of most of the time, the error is in front of the screen. :)

Best Regards,

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
Hi Rusty, Thank's for your answer! Following your post I wanted to check some points before I answer to...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!