RT2600ac Strange issue with RT2600ac

Currently reading
RT2600ac Strange issue with RT2600ac

  1. RT2600ac
Operating system
  1. Windows
Mobile operating system
  1. Android
I have only owned the router for a few weeks and it has been working quite well.
The system is up to date, and it isn't really customized other than my kids having their own set safe zones, and their stuff is on the guest network.

Last night my son was trying to connect his Oculus to the Chromecast, which he had never done before with this new router. For reference, my wife told me yesterday that she was also unable to connect to the Chromecast (I don't believe she had connected to the Chromecast via the new router either, But I was able to connect to it a few days earlier).
I think her phone is on the primary network.

Anyway, in trying to get access for my son, I found the setting on the guest network to allow guests access to the internal network, thinking this would allow him to access the Chromecast.
I toggled it on, hit save, and the system went through its reset process.
When the internet returned, my Google pixel phone (5ghz, primary network) accessed the internet immediately but my son's devices lost their internet access: Chromebook, phone and Oculus.
Our Eufy RoboVac (2.4) also lost connection.
I believe his devices have 5 GHz radios, maybe dual band.
I think the router is on the stock setting regarding "smart connect."

I disabled the "allow guests to access internal network" setting but the issues persisted. I rebooted the router and that didn't fix the issue either.
He tried powering his devices off, re-entering passwords, etc. No luck.

This morning I spent 90 minutes trying to figure out why these devices were dumped. My son's devices are in a safe zone but nothing is restricted.
When I tried to connect the RoboVac it was apparently able to access the router because it stated it was connected but had no internet, despite trying both the guest and the regular networks and entering proper passwords.

I tried toggling the 2.4 network on and off because I thought that maybe that network was down but nothing changed.
Also my garage door opener is on the 2.4 network and it is functioning fine (I don't recall if it is on the guest or the primary network).

I tried clearing the cache of the router app and the robovac app But so far nothing has worked.
I love the router but I'm absolutely floored that toggling a single setting on and then back off broke the system.

There may be other devices that are affected but I'm not sure because they weren't powered on and connected actively to the network.
I'm hoping my wife can access the network because she needs it for work.

I will resume troubleshooting when I get home from work today.
It seems like there is an issue with the guest network or maybe something to do with the safe zone.
But it doesn't really seem like it is a safe zone issue because the robovac isn't a part of that zone, But I believe it was set up on a guest network.
Yes, I tried connecting it via the main network and it still wouldn't connect.
I'm trying to isolate the problem but I'm stumped.

Unless I get some concrete info on how to troubleshoot this thing I guess I'm going to have to do a full on factory reset...which kinda sucks.

Do any of you gurus have any advice?

Many thanks,
It's likely Chromecast is advertising itself using local subnet multicast/broadcast and this won't span between devices on different networks (main, guest).

There is the IGMP Snooping option in Network Center ->Local Network -> General. You could try enabling it.

Does safe zone mean Safe Access?
Oops, yes I meant safe access.

Enabling IGMP may help Chromecast... But could it address the broken internet access problem?

Again, many thanks,

I haven't enabled MAC filtering (unless I did by accident).

Not sure if the devices are using private MAC addresses.
How can I determine this?

Oh, that makes sense.
I don't think our devices have that feature.

My wife texted me...she can't access the internet with her laptop, despite reentering the password "network security key."
I have WPS disabled, so she can't try that. And, I disabled remote administration, so I can't help from work.

I'm barely intermediate regarding network knowledge (you folks are quite advanced), but from what little I know, this issue is truly bizarre.

It arose after toggling a single setting, and persists despite undoing it.
It affects some devices but not others.
It doesn't recognize proper passwords.

I can't think of a common thread linking the events (but my knowledge is relatively limited).

Oops, my router is the RT2600ac.

Not enough coffee....

My wife's phone and personal computer are connected...but not the work computer.

Given the selective nature of denied devices, I'm beginning to think this has something to do with the guest network.

I think the problem devices may have been originally connected to the guest network.
Knowing this, here is my wild guess:
Because they will not connect to the guest network, we've tried connecting to the main network.
I suspect that the router might be seeing the Mac address that was associated with the guest network, and is blocking it.

Fredbert provided a clue above.
I don't think all of those devices have private MAC addresses, but it makes sense that their addresses are being actively rejected. The common thread is the guest network (I need to figure out which devices were were on it).
Otherwise, why won't they connect when using the proper password? The router isn't getting along with something...

Maybe this is a Synology security thing that glitched.
Maybe when I granted guest access it triggered a security protocol...?

The DSRouter app shows nothing wrong, but I may see something when I get home and connect directly to the router via the more detailed web interface.

By the way, I shut down the guest network and turned it back on this morning, but the issue wasn't resolved.
Maybe I should do it again, but reboot the router before restarting the network...

I also killed the 2.4 radio and restarted, no change.

Maybe I should re-enable the setting to allow guests to access the internal network?
Sorry, thinking out loud here... But it would be nice to figure out what caused the problem so it doesn't happen again.

When Synology first supported WPA3 security there were many iOS devices that didn't like it, even when the router was set to WPA2/WPA3. WPS2 should be supported by all but decades old devices.

And some older devices don't like 802.1r.
Last edited:
When Synology first supported WPA3 security there were many iOS devices that didn't like it, even when the router was set to WPA2/WPA3. WPS2 should be supported by all but decades old devices.
Yes, I had this problem. And I'm still on WPA2.

EDIT: changed to WPA2/WPA3
We don't have any Apple stuff, only Android and Microsoft.

Hmm... I wonder if there is a log I can access to see what changed last night?

I couldn't find the root cause of the problem, despite checking all of the settings and inspecting the event logs.
There was one entry that stated I had disabled a guest DHCP setting (I forgot the exact language).
But, the settings showed that all networks were available.

I changed the primary and guest passwords and all is well... except, I still don't know what broke my system.

I have had numerous such experiences with the RT2600 where, after a simple configuration change, it essentially starts acting randomly, no rhyme or reason to what it's doing, with the only conceivable explanation being corruption of the configuration file.
The ONLY thing I've found that fixes this is: Always back up the configuration immediately prior to making any changes. If the "simple change" results in crazy issues, restore the backed up "known good" configuration, and try the exact same change again...and typically it'll work fine the second time you try.

I've concluded that the rewriting of the configuration file after changes are made simply is not reliable. The error is not programmatically repeatable; it just happens sometimes, and doesn't happen other times.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
Since the update I have noticed some strange behaviour of my system. Generally is it perfect. 1. I have...
Now that I know what happened, yes! Was exciting when Wife wanted to watch Netflix, though!
Update to this thread.. All still fine at neighbor's at 1.2.5-10.... (cat6 to Smart TV & Cable Box.. Wifi...
I have a question. So this is network speed issue on your NAS or on your PC? Not sure I picked up what...
ISP Burped today in a new and strange way: The Ping Traps to ISP server feeding me started failing Modem...
Welcome to the forum! What have you tried so far? Try and explain it in detail. Also, what's your ISP in...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!