Swap to new disk on DS220j

Currently reading
Swap to new disk on DS220j

Operating system
  1. macOS
Hello all,

I have a DS220j with a 3TB SATA drive (no RAID), currently running DSM7.0. Recently the system reported errors on the disk (bad sectors) and has flagged the disk as read-only. I purchased an 8TB disk and inserted it in the second slot, and created a new storage pool and volume on the new disk.
The next thing I wanted to do was to copy the data from my old disk to the new one. I tried to follow the procedure in this old topic, which recommended using the Shared Folders screen to change the location of the folders to the new disk. However, when I try to do this (using the "Edit" button - is there another way?) I get an error message stating that the volume of the destination is read-only, whereas I thought I was selecting the source not the destination. I tried other methods, such as these methods from the Synology Knowledge Centre, and using HyperBackup, but had similar problems. In fact my new storage pool and volume don't seem to be accessible.

Thanks for any help,

If you move a shared folder, it will copy the shared folder and delete the data from the first drive. This delete means a write on the read only disk and is no longer allowed.....

So you should create new shared folders on the new disk, and copy the data via file manager from the old shared folder to the new one.
For packages, probably the only way to transfer these is to restore the backup to the new drive (or backup first).
Thank for your reply.
What I did was to change the status of the damaged disk to read/write - I was able to do this even though it had been flagged as "read-only", although one gets a message about possible dangers.
Then from the shared folders listing I'm moving the folders from the old to the new disk using
Edit -> change Location to the new volume on the new disk.
This seems to be working, although it's rather slow.

I'm not sure I understand your remark about packages. Can't I just re-install them on the new disk?
Packages are installed on a volume but in a location that is outside the shared folders. When you have more than one volume on a NAS there will be a setting in Package Center that enables you to select which volume to install packages. But there's no easy way to move an installed package from volume to another. The most official way to move packages is to do a Hyper Backup, uninstall the packages, then restore the backup to the new volume.
Fredbert and my remarks are useful if you have packages the contain data, like webstation, mariadb etc.
If there is no data with your packages, you can simply re-install them from package manager as you indicated.
Never. Only edit the Location property of each shared folder, otherwise internal links and references will be lost to the OS and packages.
Dear telos,
That exaclty was not possible as the disk was in read only status. Now that is solved fortunately, as the R/W is back to W.

Since it is not possible to make duplicate names for shared folders, the reference and packages issue is a non-issue.
At a disk failure moment, the data is most important anyway.
Never. Only edit the Location property of each shared folder, otherwise internal links and references will be lost to the OS and packages.
The situation being discussed was when the original volume was degraded and in read-only mode. How is is possible to move a share folder from a read-only volume?
Thanks for all the useful advice.
Moving the shared folders to the new disk is working fine, once I changed the status of the old disk to read/write. I am using the method recommended above of changing the Location of the folders to the volume on the new disk, which moves the contents rather than copying them.

I'm still not sure I understand how to use Hyper Backup to move the packages to the new disk. Thanks to EAZ1964 for his comment on this subject. I don't believe the packages I use have data associated with them - I certainly don't use webstation or mariadb. I do use Synology Drive (for backup of my Mac) but I don't believe this has associated data.
Synology Drive does have data and configurations associated with it. Along with configuration data there is also Drive's database. Any package from Package Center will be installed on a volume, so if you want to keep using them then you'll have to back them up and reinstall to the new target volume.

The 'move' using Hyper Backup isn't really a move. What the process is this:
  1. Backup the selected packages to a Hyper Backup vault
  2. Uninstall the packages from DSM
  3. Whether it asks which volume to use to restore packages... I don't know. It may be safer to go into Package Center and set it to install packages to the new volume.
  4. Reinstall the packages on the new volume
So when I launch Hyper Backup I have the choice of "Data backup task" or "LUN backup task". I assume I should choose the first option. Then I get a choice of destination, and I suppose I should choose "Local Folder & USB". This leads to a menu of "Backup Destination Settings" with a pop-up menu to choose the folder from all the shared folders (previously on my old disk, now on the new one). However, I don't see any option for backup of packages.
It's the next page after selecting which shared folders to backup.
Thanks for the information and the pointer. I've now launched the Hyper Backup, but it seems that it's backing up the shared folders as well as the packages. Is there a way of backing up just the packages?
Is there a way of backing up just the packages?
Yes, don't select the shared folders... some packages will add any shared folders that they require to be backed up (e.g. Synology Drive requires the homes and other team folder shares to be backed up in the task too).
Don't forget to pickup another drive so you are running at least two an have a fail-over, in your case probably SHR-1 (assuming it's not too late). It alleviates a lot of these issues.
Thanks again for all the help and advice.
The status is now as follows:
  • I copied the packages to the new disk using Hyper Backup. Everything seemed to go smoothly except for one package, Synology Application Service, which reported an error on extraction.
  • There was one very big folder (400GB, my TimeMachine backup for my Mac) that I wasn't able to move to the new disk, so I tried copying it using Hyper Backup, but even this failed, and the old disk went back to read-only mode. I'll have to start my Mac backups from scratch and hope I don't need any of the old backups.
The problem I have now is that some of the packages (Synology Drive and Admin Center, Hyper Backup Vault, ...) are flagged as having problems. I'm wondering whether this is because the system is configured to use the copies on the old disk. How do I tell the system to use the copies on the new disk?

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Hopefully you pulled the 14 TB drives when powered off, otherwise they will be unsynced/degraded...
It is possible, with some trade-offs/package reinstalls ... but first... I understand this comment in...
Indeed. But if the Drive database can be excluded then it might, just might, drop the used space below 6TB...
Spent some time tonight. Worked fine for HiKvision, not no-name Chinese. (Pointing at same directory as...
  • Solved
Went ahead and swapped the first 10 TB drive out and put in the (minimum RAID size) 8 TB drive. It works...
The usbshare1 is not a folder, it is the operation system name for the usb disk itself. If you...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads