Synology drive iOS client can't connect

Currently reading
Synology drive iOS client can't connect

3
1
Hi all,

First post on the forum, so hi all! Hope you can help me with this problem.
I just bought a DS920+ and finding my way a bit. I succeeded in setting up docker and running AdGuard Home and Bitwarden. I also successfully installed Wireguard vpn on a raspberry pi and I am able to login to DSM using the local IP address through Wireguard when I am not at home.

Now I am trying to get synology drive to work, but the iOS synology drive client is giving me trouble. The drive client on my MacBook Pro using local IP address works. On my iPhone I can login using safari, but the iOS drive client does not connect. Not even when I am at my home network and not using my vpn.

my current setup:
- quickconnect is disabled
- synology firewall is enabled
- custom ddns with let's encrypt certificate is configured
- on my iPhone: the drive app does have acces to local network
- I only use local IP address to login to DSM (using Wireguard VPN when I am not at home)

what happens when I try to login using https: it recognises my let's encrypt certificate which I have to accept, then tries to login and then shows me this error message: "can't connect to the server. Please check: - the IP address is correct; - the network connection. We recommend using quickconnect for easier connection to your server."

I have tried disabling synology firewall, disabling ip account blok but with no effect. Any suggestions why the app is giving me troubles?
 
1,671
711
NAS
DS220+ : DS1019+ : DS216+II : DS118 : DS120j : APC Back UPS ES 700 — Mac/iOS user
Hello and welcome.

What happens when you try Drive on your phone while on WiFi at home (LAN), using IP address:port?
 
3
1
I think I need to use port 6690 then, right?
It says “Safari cannot open the page because the network connection was lost”
Using my DSM https port brings me to the dsm login page

btw, forgot to mention that my NAS has a static IP through my router
 
1,671
711
NAS
DS220+ : DS1019+ : DS216+II : DS118 : DS120j : APC Back UPS ES 700 — Mac/iOS user
You can set a customized port under:
Control Panel > Application portal > application tab
“enable customized port (https)”

Do your testing on the LAN using the IP address, once it works, try WAN access. For this you’ll need to mind the firewall by adding an allow there.
 
3
1
Fixed it! Thanks for your help.
I followed your advice and set a customized port. I can now login using the synology client and can confirm that it works on external network through WireGuard as well.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Similar threads

Trending threads

Top