Solved Synology Drive - Unexpected decreasing of sync transfer speed Drive

Currently reading
Solved Synology Drive - Unexpected decreasing of sync transfer speed Drive

Synology, TrueNAS
Operating system
  1. Linux
  2. Windows
Hi guys,
after 22 days of dummy conversation with official Synology support my patience is on the edge.

Synology Drive unexpectedly decreases transfer speed of sync just for WAN. The LAN sync is OK. Nothing has been changed in the architecture (NAS, WAN, LAN).
Basics- NAS side:
DS1813+, DSM 6.2.1-23824 Update 6 (last ver)
Target Volume - RAID1 by 2x Seagate ST1000NC001-1DY162
Indexing - on, Traffic control - off, Docker with iperf3
Basics- WAN/LAN side:
WAN: 1Gbps/150Mbps FTTH, Router Hua HG8245U (1Gbps/1Gbps)
LAN side: Second Router Cisco RVS4000 (1Gbps/1Gbps), all wired through Cat6a, 10GB switch

HDD benchmarking (ssh,hdparm -t /dev/sda & b) : (RAID1 on Volume 1 - Synology Drive):
/dev/sda: Timing buffered disk reads: 474 MB in 3.00 seconds = 157.78 MB/sec
/dev/sdb: Timing buffered disk reads: 444 MB in 3.01 seconds = 147.71 MB/sec

Test data sample:
1. Data sample for the tests (LAN, WAN, except iperf3)- mixed data from 110MB to 85KB in total 546MB (110 files in 61 folders)
2. Data sample for the tests (LAN, WAN, except iperf3)- single file 1,51GB

To avoid trouble on my WAN, finished benchmarking (except NAS) Download/Upload to LAN:
From Google Drive to LAN device AVG speed of D/U:
1. Data sample 328Mbps/92Mbps
2. Data sample 560Mbps/139Mbps
B. HTTPS direct server (different site, different ISP), to LAN device AVG speed of D/U
1. Data sample 478Mbps/124Mbps
2. Data sample 612Mbps/140Mbps

NAS transfer speed Results:

LAN speed test (averages), direct transfer of the Data samples trought LAN to NAS:

by iperf3: avg 687Mbps
by SMB from LAN (Win10) to NAS: 552Mbps
Synology Drive sync by LAN has same results

WAN speed test (Read/Write averages):
by iperf3
: avg 22Mbps ..... NAS to NAS - directly from iperf Docker container Terminal to iperf Docker container Terminal through WAN IP address
by iperf3: avg 26Mbps ..... from iperf client hosted on LAN (Win10) to iperf Docker container Terminal on NAS (WAN IP address of NAS has been used as target)
same speed rates for Synology Drive sync (Read or Write) from WAN devices to NAS (100Mbps/100Mbps guaranteed symetric data connection). Same speed also for cellular data Drive sync (of course it's no guaranteed line).
by FreeFileSync SW (SFTP): 112Mbps .... upload from FreeFileSync clinet (Win10) to NAS (WAN IP address of NAS has been used as target)

Different WAN speed test :
Shared folder created on same NAS Volume synced with Google Drive by Synology Cloud Sync services.
1. Data sample for the test uploaded to Google Drive from LAN, then synced to Synology (by the WAN) with avg speed of NAS Write 296Mbps.
Same index (on) services on the Volume. Same utilization of CPU/RAPM. It is >10x faster like direct Synology Drive.

Ookla WAN speed test is running every time ... avg 860/145Mbps for the WAN. No anomalies. Of course the Download sometimes is dynamic (aggregation), but never under 560Mbps. But Upload is still in awaiting speed line.

All external services like Google Drive, One Drive, ... are providing perfect transfer speed for D/U between LAN/WAN sync tasks .

Same results with standard Synology packages in usage or with feew of them (can't stop because Synology or Testing purposes):
(you can't stop these) Universal search, Pearl, Recover Root Shell, Node.js v4, Java7 + (testing purposes) File station, Drive, Cloud Sync, WebDAV Server

And of course - no heavy traffic on LAN/WAN during the scenarios.

So, how I can stabilize the WAN speed connection to NAS, from Synology Drive or DSM point of view?
Thx for a help

additional findings:
the degradation of transfer speed is same for Syno File station and SynoDrive - just for WAN (domain or direct public IP) connection.
HTTPS direct download from external server to NAS (same Volume) by Syno Download station is ok from my speed expectations
4 HOPs tested between my NAS and my ISP:
NAS ->router, GPON, ISP, same GPON, router, NAS ... no leakage
direct GPON connection to NAS (inactivate LAN router) .. no change

There must be trouble in Syno Drive & Syno File station processes. Not discovered any correlations.
Hi. Is this still a problem?

It doesn't sound right that LAN is working but WAN gets throttled. Have you checked your ISP doesn't throttle connectivity or apply QoS so that Internet services used by home users are prioritised over a home 'datacentre'?

Obvs. I don't know your setup and it could be a business setup on business Internet, and then the ISP shouldn't be applying unknown restrictions.
Measured and inspected bot side, there is no QoS shaping (as usual for Http/s or heavy users policy for home users) next week I will check measurement of the line losses (dB) with technicians.
I many cases in my country the FTTx is stable, but seems to be a kund of anomaly.
line losses is about 19.2dB, it is pretty fine. GPON test passed also.
Definitely it is about NAS:
  • NAS HW is out of suspicion
  • then there is just DSM side
from Drive 2.0 it’s solved, as you can see (May/2019)
you have to check all the network parts E2E, e.g.:
1. LAN/WAN network environment parts of your colleagues connection points - routers, switches, WAN medium (xDSL or WiFi, FTTx, cellular, ...). Especially for heavy aggregated WAN mediums.
2. your WAN medium environment (similar check)
3. your NAS WAN/LAN environment parts

standard low cost router (delivered by ISP) is common performance killer, e.g. lack of switching capacity, ...

You have to perform many tests.
iPerf3 container hosted by your NAS is necessary tool to find exact patterns. You can test E2E performance from the remote site to your NAS. Also Packet loose measurement is necessary (up to your computers OS).
As you can see, you have to also perform QoS with your ISP.
Good luck

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

In Drive Admin Console go to Team folder, click on My Drive folder and enable version control.
Look, everything is the same for us, file and path, access rights and folder, only I can download and he...
You mean to stop the first-time display of the notification? There's a box there for the user to decide...
It'll be somewhere in the package files, I did a similar thing for Mail Station that still used the...
OK, one more Synology drive? After Gerard and Fredbert got thing straightened out I went and checked the...
Ah, yes that would do it. You were going out to the Internet and back to the router.
  • Question
Following thread too as 6 months ago I removed it on one NAS, and had no issues?

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads