Synology NFS VAAI plugin 1.2-1008 - doesn't install on ESX 6.7

Currently reading
Synology NFS VAAI plugin 1.2-1008 - doesn't install on ESX 6.7

218
86
NAS
DS1621+, DS1522+, DS720+
Router
  1. MR2200ac
  2. RT6600ax
  3. WRX560
Operating system
  1. Linux
  2. macOS
  3. Windows
  4. other
Mobile operating system
  1. iOS
I upgraded my homelab hardware to 4x Gen 7 Intel NUCs and so I decided to rebuild my homelab with ESXi 6.7U3 (I was previously running 2x Gen 6 NUCs and ESXi 6.5).

All went well, until I tried to install the NFS VAAI plugin - no joy. tried both online and offline installs, disabling the signature check, using VUM to install - nada. :(

Looking at the various xml files in the package, it seems that only version 6.5 is referenced, not 6.7 (despite Synology stating in the release notes that the v1.2 plugin works on 6.7).

Installing on 6.5 and then performing and upgrade seems to work ok, but a clean install on 6.7 fails every time. I have logged the issue with Synology tech support.

Has anyone else been successful clean installing the VAAI plugin on ESXi 6.7?
 
Hi,
I have ESXi 6.7.0 (Build 10176752)
I've had the problem with the signature.

esxcli software vib install -v $(pwd)/synology-nfs-vaai-plugin-1.2-1008.vib
Code:
[InstallationError]

 ('Synology_bootbank_synology-nfs-vaai-plugin_1.2-1008', 'Could not find a trusted signer.')
       vibs = Synology_bootbank_synology-nfs-vaai-plugin_1.2-1008
 Please refer to the log file for more details.

I had to add --no-sig-check to my command line

esxcli software vib install -v $(pwd)/synology-nfs-vaai-plugin-1.2-1008.vib --no-sig-check
Code:
Installation Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed: Synology_bootbank_synology-nfs-vaai-plugin_1.2-1008
   VIBs Removed:
   VIBs Skipped:

How did you check that the nfs hardware acceleration is working? Can you do it without vSphere?
Cheers
 
I have exactly the same problem with ESXi 6.7U3 :(
The "--no-sig-check" option seems to have no effect.

Also I am not able to use Update Manager to install the offline package.
The update tagged for ESX 6.5 only :(

@itsjasper Did you get a response from tech support?
 
Intel NUCs are fabulous rigs for ESXi homelabs, as they work ootb with a vanila ESXi installation.
Just a wild guess: don't you need to set the "acceptence level" of ESXi at least to "Partner" or "Community" to install unsupported vibs?

I patched the acceptence level to "Community" in the installer for one of my machines in order to use a network driver that was officialy supported up to 5.5. You don't necessarily need to patch the installer, you should be able to change the setting in the web-ui: Manage -> Security & users -> Acceptance Level
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Old thread notice: There have been no replies in this thread for quite some time. The last reply was on .
The content in this thread may no longer be relevant. It might be better to open a new thread instead.

Similar threads

  • Question
I have been digging down a similar path with SMB multichannel. I was expecting the mounts for Filestation...
Replies
1
Views
1,249
  • Solved
Well, I sorted the problem out. I ensured that the Windows firewall rules were meant specifically for the...
Replies
16
Views
2,864
Yes. Create a task that is direct to the sub-folder and sync it to your Mac/PC. Just don't have another...
Replies
3
Views
1,546
I never really quite got to the full objective, which was to have a self hosted cloud solution which iOS...
Replies
6
Views
9,474
  • Question
it is a simple answer: NO WAY to collaborate over single file with more than single user in real time...
Replies
3
Views
1,456
From the changes it looks like the M1 was not playing well with some Realtek NICs over SMB. So I guess...
Replies
21
Views
14,007

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top