Time Machine

Currently reading
Time Machine

Operating system
  1. macOS
Mobile operating system
  1. iOS
Back again with either something new or something forgotten...ah age. As my 1 T USB connected drive to NAS for secondary backup became full again I decides to repeat the process ....alas I may have screwed up. I went to File Station and deleted the Sparse Bundle Folder....then Time Machine (menu bar) I deleted that destination (USB drive). Then I tried to add a new destination folder... I got the attached message. Then I created a new Sparse bundle folder .... but still same message. any thoughts appreciated


  • Screenshot 2022-11-19 at 8.34.17 AM.png
    Screenshot 2022-11-19 at 8.34.17 AM.png
    31.9 KB · Views: 32
Well the destination should be detected regardless of the status of the content on that drive, as that comes later (after connecting TM with the actual drive and authentification).

This would indicate that the problem is either with the USB device not being detected by the NAS, to begin with, the root folder on that NAS is missing and is not associated with the TM functionality inside DSM, or the TimeMachine protocol are checked off (both AFP or SMB).

All of these elements can be checked inside the Control Panel following the official KB article on the matter. How do I back up files from my Mac to Synology NAS using Time Machine? - Synology Knowledge Center
My experience of using Time Machine with a NAS:

When using a network location as the destination, once connected to the NAS, TM will create a sparse image on the destination and mount this image as a local drive on the Mac. You don't have to create the sparse image yourself. TM does it and maintains it.

On the NAS the USB drive has to be accessible to the NAS user account you will use to access it from the Mac. Normally the NAS will assign the same usbshareN name for the USB drive's shared folder. You should add this to the Bonjour settings of Time Machines Folders, and enable broadcasting on SMB and/or AFP.

Provided there isn't a previous corrupted TM sparse image on the USB shared folder for this Mac then the new one should be created.


Finally, our two old Mac Minis (one always on [mine], the other gets turned off) are very reliable for not corrupting the sparse image. My MacBook Air is more prone to corruption, usually coincides with my DS215j TM NAS getting rebooted. I will probably stop using TM when ABB for Mac beta is stable, and move the backup destination to one of the my NAS+.
Thank You both for taking the time. I checked all the above and it is set up as it was. Both my wife and I are set up exactly the same. (Her's is usbshare1-2 and mine usbshare 1-3.) Photo below shows hers is backing up fine so her's is seen by the NAS. I deleted my Sparsebundle folder as it was full and unable to update as TM does. Each 6 months I delete the sparse bundle and start over. When I look at the USB I see it still contains the 1-3 data. I will reread the HOW TO link listed above again and see what I might be missing. Thanks again.


  • Screenshot 2022-12-01 at 11.16.15 AM.jpeg
    Screenshot 2022-12-01 at 11.16.15 AM.jpeg
    118.3 KB · Views: 24
  • Screenshot 2022-12-01 at 11.12.40 AM.png
    Screenshot 2022-12-01 at 11.12.40 AM.png
    124.8 KB · Views: 24
  • Screenshot 2022-12-01 at 11.35.16 AM.png
    Screenshot 2022-12-01 at 11.35.16 AM.png
    154.1 KB · Views: 24
Personally I wouldn't have Recycle Bin enabled on these two usbshares, there's nothing you're going to be able to do with these bin'ed files. To make life easier you can rename usbshareN-M folders to something more helpful, but do it before you start accessing them or you'll probably have to re-setup whatever things are accessing them. And if usbshare1-1 is not being used then I would hide it using it's Shared Folder settings.

From the TM backups screen shot (I don't recognise the style, it may be a newer macOS than I use) it looks like you have your wife's Mac backing up alternately to two destinations on the NAS. The way I have seen TM display the destination is 'NAS share name - device name/IP' which is the running backup. The second stopped backup is showing the name of a mounted sparsebundle image which is /Volumes/Time Machine Backups (without the /Volumes bit from the Mac file system). If this is being problematic then usually I find that deleting the destination in TM settings and then deleting the associated sparsebundle image folder will get the me back to a fresh beginning.
Thanks again for input. Both my wife and I have two backups each: Both to the NAS and both to the attached USB 1T HD. We take the HD with us if we go on trips incase the house burns down! They have been running smoothly for 18 months. It was when I tried to "start over" i.e. when the drives get full TM no longer erases the oldest so necessitating a start over. A pita but better than none. Maybe it is time to leave time machine and seek out a Synology solution.
I have way too much on my plate at the moment so was hoping for a reset and move on. Not my lucky day! I am perplexed as to why the NAS sees the USB drive but mine is not. I also disabled the recycle bin and emptied it of the sparsebundle which was in there
I have also been checking out the Apple thread and have found a number of folks who recently have had the same issue was a TM to a NAS. If if \was there it worked up until it was 'full' and then after deleting and trying to connect again it could not see the NAS or it's connected usb drive through the search on TM. Even with the server files open on the desktop.
I am beginning to think a Carbon Copy Cloner backup. If y'all have other suggestions do tell. I have not explored whether or not Synology has a usb backup possibility. The TM to the NAS continues to work fine. What I intend to do as we leave for a trip soon is to simple plug in a HD and make a TM copy to it to take with us. But on our return I'd like to come up with a fairly simple solution. Just a few devices to keep safe. Thanks again to those who have taken the time to help.
I have also been checking out the Apple thread and have found a number of folks who recently have had the same issue was a TM to a NAS. If if \was there it worked up until it was 'full' and then after deleting and trying to connect again it could not see the NAS or it's connected usb drive through the search on TM. Even with the server files open on the desktop.

Ran into the same issues with Ventura. The new System menu is a bit bodged and if it has a TM connection to a detonation(working or otherwise) and you have no other TM destinations (like almost everyone) then the list of available TM destinations is empty. With previous versions of macOS the menu would show the existing connection too.

If you deselect the TM destination it then shows as available. You will then find that TM can select and use it - either picking-up where it left off (albeit showing initially that it will start afresh, when it will not do so) or if that does not work you have to remove the existing sparse bundle from the drive, which will genuinely allow you to start a fresh backup.

I was a bit miffed that my TM backups had stopped on all my machines with no alert. Only caught it by accident some 5 days after the backups ceased. I'm not a fan of silent failures...

Oh! Thanks on that... I did not make the connection. Appreciate the steer, I will definitely look not this when I can get the update. Something new to learn and hopefully get it to work!
Well that is great news and appreciate your Beta work. I look forward to getting the update and getting a reliable setup. I felt like the sword of Damocles was always about to fall. (and it did ).

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Solved
Ofc, and using ABB once you connect it to your hypervisor. But keep in mind that Proxmox is not supported...
If it does start the slowdown again, could you try clicking "Clear SMB cache" in the SMB advanced settings...
  • Question
Yeah, that's what I was afraid of. Well in that case I'll probably leave it as is. Thanks.
Hello Rusty. Sorry for being late! Don't know how but now I can see without problem my old daily backup on...
Another option would be to use Acronis True Image to snap your macOS and then back up that image up to the...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!