• Hello Guest! SynoForum.com is celebrating its 5th anniversary! 🥳🎉 Read more...

Threat Prevention TP Map blank?

Currently reading
Threat Prevention TP Map blank?

Last edited:
I've loaded the Patch... Still awaiting for TP to start service..... BUT MAP IS BACK!

There are different Patches for 2600 and 6600 I hear..... Contact Support!

Takes quite a while for the update 6-7 min more later
BOTH SRM & TP Versions remain the same.....
So far... No issues..
DS Router sees same Router CPU & RAM useage as before the update....
-- post merged: --

TP.jpg
 
Last edited:
Second 2600 had the issue (Blank TP Map)..... and the "Patch" fixed it!
Also note that both 2600's manual update with the Patch takes longer to install than an SRM update does..... Install sticks at 1% for nearly a minute....
Both show same CPU & Ram useage (DS ROUTER) after the patch install!

But it's now Fixed!!! Thanks Synology!
 
Last edited:
As an FYI:
Installed patch on 2x 2600’s. Both needed it (Blank TP MAP).. IT FIXED BOTH 2600’s!! Fantastic!!
2nd one took offline,first one running, and I went out of town….

THIS IS CONJECTURE:

Starting a week later, and Once a week since leaving, I get an email saying that malware has been found on 2600..

Away from home, All I have is DS ROUTER via QC.
DS ROUTER doesn’t give access to desktop like DS FINDER does, and NO ACCESS to the program the email says I should use to fix this issue, either. Am I trapped?


So….

I Contact Support, and they agree with my above statement, (That there is nothing I can do from DS ROUTER), and surmize that they think it’s it’s the patch Iinstalled but they are unwilling to assist me by testing that idea, to confirm this is the case. I ask why— no available hardware, no access to patch. They suggest when I get home test it and confirm back to them!! How Nice!

I have then asked Support if it’s possible when I get home, to run anything that would confirm it’s the patch, and not something bad, and if so, What to do to negate subsequent emails inficating it’s a problem.

Not heard back from them on that.

I surmise Mr. Telos will have a field day with this post.

Hey! I’ll post more when home 3 weeks from now!
Obviously Support has not done their homework on this fix!!

As I stated before: FYI!
 
Last edited:
I just got a reply from Synology support

THEY HAVE REPRODUCED THE ISSUE!

THEIR PATCH IS BEING BEING REPORTED AS MALWARE: AS THE CODE HAD BEEN CHANGED. I guess they didn’t consider this fact!!

Gee! Change source code of a program…. and FORGET to recalculate a new Checksum???

They say: ‘Just ignore the malware prompt’

OK I can deal with that! I’m assuming a new version is in the works?

-- post merged: --

So much for This being anything but Conjecture, Until Support admits it is them, and then it’s CONFIRMATION AND NOT CONJECTURE…. Is it— Tellos?
Even Support mentioned that this was a test that was missed!!
 
At least you got this confirmation. And you could tie down when the alert started to the patch being applied. If you had been running [more] end-user features on the router it might have been harder to deduce: one reason I use the router for perimeter network functions and NAS for data and services.
 
Last edited:
I suggested (To Support) That they Calculate the Correct Checksum for SRM Plus the ‘patch’, and RE-ISSUE the “Patch” (With Correct Checksum)….
Then BOTH ISSUES would be Fixed🤗😉😁😎👍

But: My suggestion DOES NOT SOUND - like something an end user should have to be saying to Support personnel???
I would have thought this would be an automatically accomplished action!
Like testing new code
 
Last edited:
Everything in this thread (After patch installed) happened with me being thousands of miles from home.
Support agrees access to desktop of router with DS ROUTER would be a necessity if this Malware had been real.

DS ROUTER presently does not support all functions as DS FINDER does, remotely.
Access to desktop would give acceptance to everything.
For all these, and another he commented on that I was unaware of, he is approaching higher ups with these senerio’s for reasons for an upgrade to done to DS ROUTER. (To add Desktop access)

👍
 
Last edited:
Finally back home! Examined SA,(Security Advisor) and yes, it matches the pics support sent me when they ran SA after loading the Patch.... Yes SA is seeing 'the Patch'.... All I was getting was emails saying Malware was found on 2600, and I should run SA to see my options..... But.... Via DS ROUTER, I CANNOT access SA from DS ROUTER!!!
And Yes, Patch has still fixed the TP Map! (THE REASON FOR ALL THIS well over 2 months ago!)
Selected the Malware result, and selected SKIP... then scanned multiple times to test.... Yes, it's now passing.... Now Obviously, if something gets in an modifies anything.... I won't be notified.... But this will have to suffice until Synology releases and update fixing TP Map and providing the correct SRM checksum....

I could NOT do any of this remotely, as DS ROUTER does not allow for Access to SA, Nor, Desktop Access.... from within DS ROUTER, and why I pointed out that Simply adding Desktop access in DS ROUTER, as DS FINDER NOW HAS....... This prevents you from doing multiple actions, remotely.... Even when the system is emailing you to do so!!

Obviously I needed access to it! to Patch: "The Patch", for TP MAP, that was fixed: in SRM, Not TP, but didn't 'patch' the SRM Checksum! :)
 
Last edited:
An interesting (GOOD) feature of the "SRM TP MAP PATCH"....... (Which is still displaying fine)
System Databases updates are occurring more frequently!

That is, Prior to Patch, a Daily login would usually have one or more Database Reporting that an update is available....

Since the PATCH ----- I've yet to see one login that reports ANY Database needs an update....

I'm seeing this occurring on both 2600 Routers....

I'm just the postman!
 
Last edited:
nearly a week later. (Since return) all results remain the same on both 2600’s: TP Map still functional, and System Databases still appear to be being updated more frequently.
CPU= 35-45%, RAM 54% approx same as before patch.
 
Last edited:
Looking forward to this! Did they fix it?

From Starting point of: 1.3.1-8 with PATCH
In 2600 SA program, turned back on all Tests...
Ran TP, verified Maps worked... Does...

Downloaded, Updated SRM 1.3.1-9

on reboot updated database files.... good
Waited for TP recognize drive and load settings.. and start service...

Checked TP MAPS GOOD under 1.3.1-9!!!!

Then ran Scan of SA.... NOTHING Bad in Reports

18 min after 1.3.1-9 CPU 40-48% Ram 55%


ALL GOOD BOTH 2600 Routers!
EDIT: Followed up with tests of: DS CAM, DS FILE, DRIVE, DS FINDER, DS ROUTER... All good!
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top