Question Transmission-3.00-18 session-id can't create session lock file

Currently reading
Question Transmission-3.00-18 session-id can't create session lock file

7
1
NAS
LS420D
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
Hi,

I have running transmission 3.00-18 a day, and read in log file that every hour, session-id want to create a lock file. I don't really understand what is this error about.

Unable to create session lock file (22): Invalid argument (session-id.c:96)

Is this something related to permission? I didn't have this problem in 2.94-16. Although getting that error, everything working just fine without problem so far.
 
7
1
NAS
LS420D
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
I did that too, but still not receive any instrucstion yet. BTW, the package has built and combined by synocommunity, I hope there will be someone know this things.
 

jeyare

Subscriber
1,587
537
frankly, Syno-community APPs is a death way. Reason - last version (3.0-18) of the Transmission package has been published in 2015 =5y ago.
Docker is more flexible platform than these old packages.

When you check GitHub of Transmission you will see, that there isn't heavy support and pulling speed is really slow.

In this forum you can find more interesting solutions for such BT services.

Another problem is, that you have notified only Buffalo LinkStation 420D NAS .... and there isn't support for the Docker :cool:
 
7
1
NAS
LS420D
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
Well, I don't have any better option. I can only effort for this NAS, Syno is too much for me.

BTW, I don't really know who maintain this repo, but there is a mistake in published day, 5 years ago is correct for 2.94-16. The 3.00 has just published almost 2 months ago (the github). On syno I think it has just published aroud 2-3 weeks and the maintainer just copy the info from old one so it is incorrect. I would like to check for docker too, but how can I access docker without a Syno NAS? VM or something, and I don't know if docker would works on my NAS. If you can help me, I hope you can get the transmission 3.00 from docker and post it here.

Also, I think I get the problems, but don't really know how to fix it. This error meanings that transmission-daemon can't save a ession file, so If the electric cut down randomly, I will lose process from the last time I started.

Thank you.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Similar threads

Trending threads

Top