Updated to DSM 7 and I cannot access my nfs mounts except as root

Currently reading
Updated to DSM 7 and I cannot access my nfs mounts except as root

Operating system
  1. Linux
  2. macOS
Mobile operating system
  1. iOS

I just updated to DSM 7 (DS216j) and all of my nfs mounts are now no longer accessible to regular users. They still get mounted (accessing from a CentOS 7 box), and I CAN access them if I su to root.

I have gone to File Services and made sure that Enable NFS service is on, and the maximum protocol is set to NFSv4.
Under Advanced Settings "Apply default UNIX permissions" is enabled, and both read and write packet size is 8KB. I have not touched the Kerberos Settings, and NFSv4 domain is blank.

If I go to one of my shared folders, and hit edit I get the following:
Encryption is off.
Permissions shows my users with both Read and Write access (Preview shows Read/Write, and the Read/Write column is checked for these users).
Nothing is checked under Advanced Permissions
NFS Permissions has a single line:

Client: * Privilege: Read/Write Squash: Map root to admin Asynchronous: Yes Non-privileged port: Denied Cross-mount: Allowed.

Doing a long-list in my shell (on the CentOS side) gives me the following listing:

total 72
drwxr-xr-x. 11 root   root    130 Aug 28 01:54 .
dr-xr-xr-x. 20 root   root    279 Aug 28 22:38 ..
drwxrwxrwx. 11 root   root   4096 Aug 26 00:59 backups
drwxrwxrwx. 23 root   root   4096 Aug 26 16:18 dev
drwxrwxrwx. 10 root   root   4096 Aug 28 22:52 homes
drwxrwxrwx.  7 root   root   4096 Aug 26 02:47 music
drwxr-xr-x.  7 138862 138862 4096 Aug 27 13:24 photo
drwxrwxrwx. 17 root   root   4096 Aug 26 02:42 shared
drwxrwxrwx.  4 root   root   4096 Aug 26 02:12 studio
drwxrwxrwx.  6 root   root   4096 Aug 26 02:07 sys_shared
drwxrwxrwx.  7 root   root   4096 Aug 26 01:44 video

And my fstab looks like this:

XXX.XXX.XXX.XXX:/volume1/sys_shared /Server/sys_shared nfs4 auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
XXX.XXX.XXX.XXX:/volume1/shared /Server/shared nfs4 auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
XXX.XXX.XXX.XXX:/volume1/backups /Server/backups nfs4 auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
XXX.XXX.XXX.XXX:/volume1/music /Server/music nfs4 auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
XXX.XXX.XXX.XXX:/volume1/photo /Server/photo nfs4 auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
XXX.XXX.XXX.XXX:/volume1/video /Server/video nfs4 auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
XXX.XXX.XXX.XXX:/volume1/homes/ /Server/homes nfs4 auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
XXX.XXX.XXX.XXX:/volume1/dev/ /Server/dev nfs4 auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0
XXX.XXX.XXX.XXX:/volume1/studio/ /Server/studio nfs4 auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0

I have rebooted my CentOS box in case that is the issue, but to no avail.

Not sure what else to check. Any thoughts?

Last edited:
Sorry, I thought I could edit my post but I can't see where to do that.

Some additional info: I have also enabled the permissions for the groups as well as the users. So that is not the issue.

I have also tried disabling the firewall to no avail.

Also, I am getting permission errors trying to run rsync backups to the server.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Thanks Rusty. I'm going to research and try the reverse proxy in the meantime. I'll PM you as well...
Dear Rusty, Thank you for your response. You are correct about using version=3. However, I am currently...
  • Solved
<<<<< SOLVED >>>>> OK so I decide to solve this by myself accordingly. Synology did offer me to go check...
Port forwarding is the other way around: router port to NAS port. For reverse proxy is NAS to destination...
I'll try to explain it better. At home I use a DS918+ with the following setup. server { listen...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!