Updating Container with Portainer fails on DSM 7.2

Currently reading
Updating Container with Portainer fails on DSM 7.2

DS920+, DS918+, DS214+, DS211j
Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
  2. iOS

Since updating my DS to DSM 7.2, I cannot update any containers on that machine with Portainer. Portainer is running on a second DS, inside docker.
OTH, using Portainer to update any containers on the second NAS, works as usual. However, the second DS is still running DSM 7.1.

So, am I not able to use Portainer anymore for this task with DSM 7.2 or is there a solution I did not found so far?
So, am I not able to use Portainer anymore for this task with DSM 7.2 or is there a solution I did not found so far?
I recently migrated my main Portainer onto a new RS with 7.2 and connected other hosts via agent to it. It all works well, so I wouldn't say this is a 7.2 issue. I also have a mix of DSM 7.2, 7.1.1 and one 6.2.4, all work fine.

I cannot update any containers on that machine with Portainer
What is happening exactly when you try and update? Anything in the logs?
Thanks Rusty for your reply!

I guess I found the cause, later in the evening yesterday already: My firewall blocks the access to the docker registry. I guess Portainer or Dockerhub changed something in their configuration.

Before, I additionally tried to download the container image (from within Portainer) solely without recreating the container and got a more readable error message. Don't have the message by hand at the moment. It was sthg. with a dockerhub URL that cannot be reached and the request timed out.

I'm not sure, however when disabling all firewall rules the access works. I don't know why Portainer on the second NAS does not have any problems though while recreating containers without shutting down the firewall beforehand.

So, it must be any combination of NAS, Portainer, firewall, proxy. I will do further tests and report back this weekend.

Thanks for reading!
Root of this issue found;)

For unknown reason, the docker package on the first, failing DS, uses the second LAN port to access internet, which means to download container images for dockerhub.

After adding the IP-address of LAN2 to firewall rules, Portainer is now able to download images or recreate containers.

Still wondering why this issue is not present on second DS, that too has got two LAN ports and only the first IP-address has open ports in firewall.
Must have some relationship between the ContainerManager of first NAS with DSM 7.2 and old docker package on second NAS, still running DSM 7.1


Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

One note to the approach: copying the files from inside the container might cause inconsitent copies if...
Why would it? phpMyAdmin is neither related to, nor required for Wordpress. The only thing both have in...
@one-eyed-king yes, homebridge maps to a folder like the typical "/config" and also includes...
btw that shadowsocks image you're trying to download was deprecated in 2020. It's up to date replacement...
I don't have the step by step config you're after, but can tell you that you can SSH into a docker...
  • Solved
If you are still interested in learning it: If you know how to write bash scripts, it should be possible...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads