DSM 7.1 Using ONVIF and Chinese camera in SS

Currently reading
DSM 7.1 Using ONVIF and Chinese camera in SS

1,322
263
NAS
DS 718+, 2x-DS 720+
Router
  1. RT2600ac
Operating system
  1. Windows
Mobile operating system
  1. iOS
Last edited:
Actually 7.2, but that wasn’t an option. This is a Pre-Attempt question.
I had a camera with 16MM lens fail — used in SS on a NAS. Temporarily replaced with a 4MM camera, but that is not acceptable.
And that camera/lens is no longer sold. Moving 16MM lens not possible, 16MM lens too large for housing, darn!

I did find a Chinese camera (XMEye is name, and is 16MM, Not delivered yet) and going to try it, though I’m aware of the issues it may have:

I’m going to Attempt to use GENERIC/ONVIF inside of SS.

My plan, and would like constructive comments:

Connect spare 2600 router to extra modem output (different IP than main 2600, and move experimental 720+ to spare 2600, isolating these from home system. Then add Chinese cam to this system.

I’ll attempt to move default IP and port of Chinese camera to new IP & Port.

Configure camera via ONVIF, set gateway to spare 2600, and if it becomes operational in SS, in Spare 2600 & NAS add firewall rules to isolate the Chinese camera from internet.

After testing on this somewhat isolated system, if it works there, then remove Spare 2600, normalizing network as before, copy the SS Cam info from oneNAS’s to another, and add Chinese camera to the NAS wanting it, knowing that camera gateway is set for non-existent Gateway IP, to further isolate it, and then add firewall rule isolating this cam, in main 2600 and NAS where it will finally reside.

Obviously if i can’t get ONVIF to set camera correctly all this is for naught, but a 16MM lens or greater is necessary even with camera 75’ from house. Yes, target is too far away for night vision to be useable.

Comments
 
Last edited:
Camera in. Second 2600, laptop, camera, alone on isolated network.

Using OMVIF Device Manager got to camera, changed login, password, IP, port, looked at image (only does 25fps, have yet to find USA switch as in HiKvision cams).
As yet no ftp settings found.
Added block in 2600 firewall. As yet, no ‘hits’.
No NAS on line yet. Letting this sit for a while.
 
No apparent ftp or pix save except through web. (Disabled) in camera.
No apparent editing of on-screen name or size of text in camera.
Added experimental 720+ to the mix.
In SS, had to delete a camera, disable not good enough to access license. !?
After all that, Cam configure via SS automatic find and complete configuration was straight forward and un-eventful!
Let SS do motion detect. Shows up as new folder in Surveillance.

All quiet in Firewall and SA.
Looks promising….
Ongoing
 
Last edited:
Happy where it is, with one issue.... I can't seem to edit or change the on screen Text....
Using OMVIF Generic settings in SS, or, any software package.... I've tried....
The closest software to work is OMVIF Device Manager, which does most everything Except OSD changes...

SS does have a setting that erases OSD displays from camera, but doesn’t have a way to turn it back on or enter a name, which cleared OSD from image.! Darn!!

Suggestions of software package that will control it...

Works flawlessly with DS CAM..... All I need to do is re-enable and adjust OSD....
 
I have a couple of Chinese ONVIF cameras working with my NAS and discovered that my cameras have a web interface that provides direct access to various extra settings, including the ability to edit or turn off the OSD text. The interface is accessed by simply entering the camera's IP address into a browser and then logging into it using your username/password. Have you tried that?
 
Last edited:
Oh boy did I!!
(Support said in jinglish to use: ONVIF Device Manager)... Which allowed me to get it going origionally, Pre SS...
So I tried your idea http... (Good suggestion by the way!)... and it said I had to load Video Play Tool first... So I did!
Selected English. Then http'd into it...
Came up in Chinese... (But used login and password from ONVIF Device Manager)
eventually found a chinese pulldown at login screen to set language....

After that... THEN IT WAS (ALMOST) SMOOTH SAILING!, But had to re-edit the Login I created with ONVIF Device Manager: Login created was Configured as adminstrator, but still had to edit it to select ALL THE FEATURES of the Play Tool program, Including Setting up the camera....

After all that..... I found both the NTSC Switch (for 30fps) and the OSD Settings.... Cannot change Time size but it's set...
AND STILL NO HITS ON THE FIREWALL RULE BLOCKING THIS CAMERA!!!! Yippee
-- post merged: --

An Update on recent findings.... Though Camera set for NTSC and re-booted... Camera or SS (Believe camera, because HikVision cams do work correctly with SS NTSC Switch, allowing 30fps) Camera Says 25 fps max, (25fps is PAL) even at 1920x1080... (17 at 4K, though 15 maxed out at DS CAM at 4K and 25fps at 1920x1080 with NTSC Switch)

I see cam ftp, but decided to not use it... Testing continues on isolated network
 
Update:
With rule blocking new camera in firewall. Network returned to normal.
Tested DS CAM with dissimilar cameras & video format resolutions.
Looking good!
Testing continues, delay moving cam outside while I await waterproofing silicone glue to augment whatever this camera has.
IMG_7259.png
 
Last edited:
No hits in firewall rules, SA info, or TP events on laptop running program to access camera, nor camera itself.

Removed camera from experimental NAS, and added it to NAS where it will reside.

DS CAM showing new cam in it’s mix!

Waterproofing done. Only thing left is to move camera outside and final aim of it!

Edit: Ended up being we had a Bald Faced Hornet’s nest on house. That taken care of too (Throw money at it!)
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

This is all available in the source and destination IP address options when creating a firewall rule...
Replies
22
Views
2,544

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top