SRM Update Version: 1.3.1-9346 Update 4

Currently reading
SRM Update Version: 1.3.1-9346 Update 4

fredbert

Moderator
NAS Support
Subscriber
5,244
2,117
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
  3. RT6600ax
  4. WRX560
Operating system
  1. macOS
Mobile operating system
  1. iOS


(2023-03-23)
Important Note

The update will be available for selected regions within the following weeks, although the release time in each region may vary slightly.

What's New

  1. Added support for Google Pixel 6a USB tethering.
  2. Updated SRM to comply with current Wi-Fi connection laws in Thailand.
Fixed Issues

  1. Fixed the issue where Wi-Fi clients might become disconnected after a few days.
  2. Fixed the issue where SRM might fail to retain the previous Wi-Fi settings after updating the RT2600ac or the MR2200ac from SRM 1.2.5 to 1.3.
  3. Fixed the issue where region compatibility might not be enabled after enabling it through the web interface.
  4. Fixed the issue where wireless clients might be unable to access the Internet when connecting to an additional Wi-Fi point.
  5. Fixed the issue where additional Wi-Fi points might not automatically reconnect to the primary Wi-Fi point.
  6. Fixed the issue where SRM might not generate logs when a mesh Wi-Fi network is established via Ethernet connection.
  7. Fixed the issue where SRM might be unable to correctly save the LED settings on additional Wi-Fi points.
  8. Fixed the issue where the RT6600ax might be unable to connect to the Internet through Frontier Fiber ONT Internet service.
  9. Fixed the issue where the SRM might not be able to display the web interface.
  10. Fixed the issue where the Network Tools are unable to show the map.
  11. Minor bug fixes.
Source: Release Notes for SRM
Manual download: SRM 1.3.1-9346-4
 
I installed it on m 6600. Seems to be working. My Mac still cannot by default hook up to 5ghz-1 and keeps defaulting to the slower 5ghz-2 connection, which is super annoying. Never had this issue with my 2600ac router using 1.2.x series of software.
 
Last edited:
Out of curiosity, does fix#1 have anything to do with static or dynamic devices not being seen?
If not, I’m not seeing any of issues with -3 on either of my 2600’s.
At -3 and before. On a 2600, we have not had any issues with WIFI devices not accessing internet: iRobots, iPhone’s or iPad, older Amazon fire6, but have had issues with router not seeing static or dynamic devices, wired or wireless, that is connected to it, and works correctly (from the standpoint of the device)..

I’m using a home-made mesh: 2-3 years ago, a Linksys E2000 in garage, wired back to 2600, and only thing disabled in wireless was 802.11r and U-APSD. This has worked so well — that when we acquired a 2nd 2600, we put the newly acquired 2600 on the shelf as a spare, instead of installing & using it as a mesh device.
 
Not sure. You probably saw my post in the official thread that asked for feedback, over at The Other Place. I'm hoping this is more robust.

I only started having some issue after adding the WRX560 as an access point, replacing the MR2200ac. But these problems have mostly subsided after messing with Radio settings (mostly switching the unused uplink to 5GHz-2, which is always a channel sub-100). Also messing with channels widths and modes, I'm back at each band's setting for all widths and all modes. One thing I also changed was the managed switch, to use 2.5GbE, and the Netgear web interface can be a bit iffy: had to revisit the VLANs on ports and LAGs a couple of times to redo them.

Your homemade 'mesh' isn't probably the same as actual meshed devices: I guess you have the same SSID and authentication on both routers, and they are far enough apart that devices drop/create connections at some point when you travel between the two. In the meshed devices the primary router acts as the wireless access controller and pushes policies to the access points, they then try to use a smart policy to cause devices to transfer connections.
 
Last edited:
Yes I’m monitoring there, too!
I agree with you (my mesh not a ‘full mesh’, but a work-around of that system)…. but my posting that I’m OK, kinda points that something in mesh code is not yet right. Your 2200 to 560 issues would also seem to support this is model specific as well.
Seen posts with 2200, 2600 as mesh and now 560.

For that reason, for now, on both 2600’s, I’m staying put at -3, cause I’m not seeing Any of the issues -4 is to fix.

As a PS to this: I contacted Neighbor with 2600 (End User: Not Network Savvy), who I just updated his 2600 from 1.2.5-3-4?? To: 1.2.5-7 a few days back, asking him if they Ever, Ever encountered WIFI issues not working…… and both he and his wife said No, nothing unusual… Ever!
They are all DHCP, and all WIFI
 
I've a very weird issue with this update.
I have a ONT connected to my 6600AX Wan. My normal speed is 1gbps. But now it's only 200mbps ! If i restart my 6600AX i recover my speed, for 10 minutes after going back to 200mbps.
 
Last edited:
I’m guessing that -4 is playing with the MESH code area. I say this because……
Please understand that all code versions on RT2600ac Router in past 2-3 years worked with U-APSD & 802.11r enabled for WIFI.
BUT….
Once I started usig a Linksys E2000 as Wired access point, in order to achieve fast reconnection between 2600 & E2000…., I had to DISABLE U-APSD AND 802.11r in order to get a quick WIFI Switchover on 5 or 2 WiFi to occur!
It never made any sense why I had to do this, but it worked, and you can’t fault success!!!

This was 2-3 years ago…. I’m still at 1.3.1-3, and I must say it Still works Flawlessly!
I’ve got a spare 2600 and will try it on any code that many others first reports is OK. I do not believe We are there yet (For me to try on spare 2600).. Again $.02, and I think something basic is being missed

PS: I’m using the setting in SA where I specify my upload & download is 1GB, when in fact it is: 200dn 20 up. Would love to test & say I’m at GB up/dn, but with Zito that will never happen unless they sell to someone else!
 
In this version threat prevention seems bug. Slowing by 4x my bandwidth when on.
Yes, I can confirm it as well. The same at me, it slows down download and upload speed by 80 % (form 500 Mbit it is now around 100 Mbit)! Well, this is really bad. :( If I tried to deactivate Threat Prevention (just deactivate in Settings section, not stopping the package), it was back on full speed, but after I turned it on again and TP fully started, it dropped again back to 20 % of my full internet speed.
 
There is a long discussion anout this issue on the syno community forum. Looks like it can be fixed remotely by installing newer unofficial version on FT package plus some tweaks and modifications in /lib/libsynotc.so.5.2.
Synology Community
In my case, I contacted tech support two weeks ago. They shortly asked for remote acces to my SRM, mńow I am waiting and hope they will fix it.
 
Last edited:
After reading posts at multiple locations, I’m curious….
Is the TP slowdown only visible by folks with GB Connections, or, is it seen by folks with 100/10, or 200/20 connections as well?

Way back when, in the rudimentary packet sniffer on Cisco/Linksys’s Small Business RVS4000 router, a built in limitation at approx 22Mb/sec was discovered.
When Comcast gave the 20MB to 40MB or 100MB Upgrade years ago, everyone with RVS routers maxed out at 22Mb/sec, a brick wall for everyone. Had to turn it off - that rudimentary packet sniffer - to get 40, or later to 100. It was repeatable. The last firmware upgrade did not help, and router was deemed retired by support.

Now, Early in TP on Synology routers, a TP limit was discovered, and, I remember posts from Synology how TP no longer had this issue. So, is this a new thing or just a re-visiting of a prior issue??

If this affects all connection speeds, it would point to a software bug. If it only affects GB connections….. Maybe something more complicated!

Now, the fact that TP has the default setting to pass un-processed packets when ‘needed’, (on my 200/20 RT2600 systems I set this to process all packets-and have not noticed anything unusual on either 2600, but I’m using a home-made mesh.). It would seem to indicate Synology knows ‘something’ might happen at times. Seeing that both 2600 & 6600 routers are seeing this, it probably is not a CPU Speed issue either. Just Another thing to notice. I wish more info was available for this. $.02
 
Hi,
It became very complicated for me. The assistance made me the modification of tp and the file to correct the problem of speed. Except that since all my computers connected on switch behind the 6660ax cannot load any more a single Web page. The ping works but no more loading. It works if I launch a vpn on these machines to the outside, then I can surf. Without vpn no traffic ... Support answer: wait for an update. I would rather have my limited speed back but not my blocked machines!
 
Last edited:
At another site someone discovered that -4 limited the maximum Link rate on wifi... Compared to -3
He test this, he used DS ROUTER App on his phone :
DEVICE
Right Arrow on Device name
Link Rate....

His GB rate ON -3 fell to 573 with -4

iI had Never checked that... before.. Nothing to do with ISP Speeds.... It's WIFI to Device link related... Via Router WIFI.
As a Point of Reference: My 2600 with 1.3.1-3 gives 866... (Which I think is the maximum on a 2600)
I passed on -4 Awaiting -5 to test on my 2600...
 
There's a lot of things being raised regarding Update 4. I think the only one I see now is that TP (as latest available, not the one via Synology Support) impacts my inbound bandwidth: without TP running I get my max. as paid-for of 380 mbps, but with TP running it is reliably max'ing out at 180 mbps. The outbound speed is unaffected because I suspect the 36 mbps I get from the ISP is below any impact level.

When I have turned off VPN Plus I see the inbound speed back to normal, likewise when I change some TP settings (mode and monitored interfaces). But the reason the speed comes back up to expected level, in all these cases, is because TP is restarting itself and for these few minutes it's not working on the traffic.

As for the iPhone getting a reduced link rate, I just checked and my work iPhone 13 has a link rate of 1201 mbps. My iPhone XR has 866 mbps. That's covering both 5 GH-1 and -2.
 
Last edited:
Thanks for input. Gives more input as to what is going on. Knew about TP, and the 4-5 min pause while updating, heard about edit to SMB, but first clear input on VPN.
No VPN Here. SMB not updated. 2600 Still ok with -3.. Rumor is Tuesday is -5 and assume TP & SMB Too?

OK CURIOSITY GOT THE BEST OF ME!!! Since I have a spare 2600 on shelf..... Upgraded to 1.3.1-4

WIFI SPEEDS STILL SAME.... Link Rate Also same... Before and After -4 update.... TP and System Databases were fully updated and operational at the time of the tests.... Tests done ~7-8 min after -4 update completed..

My ISP is 200/20 I guess you DO HAVE TO HAVE a GB Connection to see speed roll off????

PS: DS ROUTER CPU & RAM usage appear to be the same as -3

Walking to garage to test Linksys E2000 as Mesh on -4
 
So I walk to the garage to test Linksys E2000 used as MESH.... There I only got 86/26... Usually it's whatever I get at house...
Reboot E2000... Same.... ???? Ya Think???? Walk back to house.... NOW 2600 5GHz is 86/26!!! Link Rate is Less than 866!
Turn off TP.... Wifi Speeds Return! As does Link Rate, but takes a bit longer.... Return TP to Enable... Speeds fall, But Now Link Rate Stabilizes at 866!
During all this... Ethernet connected PC remains at 200/26 on my 200/20 service.
I can co-exist with this until update (Not Contacting Support) but THERE IS A PROBLEM!!!
 
Last edited:
12 hours after -4 update, speeds have ‘somewhat’ returned. Cable ISP 200/20 service. (Pings to ISP Server feeding modem identical -4 to -3)...
I would say it’s not a slowdown as much as: erratic WIFI operation, seen in Link rate as a reduction in rate, for a phone in same physical location/distance from 2600, on -4 vs -3. I noticed this big time last PM in Upstairs bedroom... This morning. walking from router back to bedroom multiple times gave different Link Rate Numbers per trip... Erratic.
Stopping, starting TP may help, but TP loading delay further confuses things. Erratic.
Ethernet connections appear normal.
Awaiting -5 update rumored to arrive Tuesday...
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Sticky
Long term -9 use post.... 2600. NOT SEEING more frequent System Database Updates.... I swear the TP patch...
Replies
10
Views
1,911
No significant differences noted for me - still the intermittent mesh wifi uplink stability issues that I...
Replies
10
Views
2,511
Did find something new.... You cannot add a List of allowed IP's in Auto Block any more.... Only one IP...
Replies
12
Views
2,594
Update on this.... All access to passwords has been deleted -- removed on all devices there... no...
Replies
3
Views
778

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top