DSM Update Version: 6.2.4-25554

Currently reading
DSM Update Version: 6.2.4-25554

Hi everybody!
Anyone having problems with 2FA login in mobile apps (Android) after the DSM 6.2.4-25554 update? I updated my device, everything works fine, even 2FA login into DSM from Windows. But all my mobile apps say "wrong code, try again later". :(
As I said, when I login from my PC (Windows device), everything works.
I tried another user's device and no problem. I tried next one user and some apps login OK (DS audio, DS video), some say "wrong username or password".

OK, I disabled the2FA in my DSM account and re-created again, so new 2FA number code is created. Still the same problem when I try to login with my mobile apps...
For me DS Audio, DS Video, DS Note, Drive, DS Get works.
Moments don't work... all on Android 10.
 
Mine (Android 10 as well) does not work, even that I restarted my NAS, hoping it will fix it. Nope, nothing changed... :(
Going to turn off/on my phone, but this will probably not help, because I already did a phone restart, but no success at all with those mobile apps.
 
I have now re-installed my Synology Moments app on Android and it works..!
OK, I reinstalled DS video (one of those apps making the problem) and now it even says "wrong user name or password". it looks like it could have something to do with the password strength, acccording to the release notes of DSM 6.2.4 (my user password does not fit all the password strength criteria), but then I don't understand, why I have no such a problem when doing a login into DSM via web browser (Windows PC).
 
OK, I reinstalled DS video (one of those apps making the problem) and now it even says "wrong user name or password". it looks like it could have something to do with the password strength, acccording to the release notes of DSM 6.2.4 (my user password does not fit all the password strength criteria), but then I don't understand, why I have no such a problem when doing a login into DSM via web browser (Windows PC).
Yeah, this could be the case, because my password strenght is compliant...
Maybe, it is time to change your password? ;-)
 
Yeah, this could be the case, because my password strenght is compliant...
Maybe, it is time to change your password? ;-)
Worked years perfectly, never had any security issue (probably also thanks to well tuned firewall, security settings, auto-block list etc., etc.).
For me it looks like a bug. Created a ticket for Synology tech support already.
 
DSM just started to block my mobile client (I mean mobile apps) as they are continuously trying to connect, but without success. Going mad of it! What the hell is wrong with the mobile apps after the DSM 6.2.4 update???
 
Last edited:
This one is OK, I have all my local devices IP addresses in my white list. I have there not only the exact IP, but also the whole subnet 192.168.1.1/255.255.255.0, so they are never blocked.
The problem is blocking by client app (or may say client device?) - account security. This is independent on IP list.
-- post merged: --

Well, does it make sense that right after the DSM update I also updated all packages which I found available as newer ones, so now the mobile versions are older and incompatible with those installed in the NAS device? Could this cause the login/2FA problem? I didnt't read anything about changed login/2FA mechanism in apps release notes, though.
 
Hi all. This tip resolved the problem with my mobile apps (2FA): stop (kill) the mobile app, clear cache, clear data.
Now it works as expected and no more false 2FA error.
BUT UNFORTUNATELLY: I still see lots of "failed log in via DSM due to authorization failure" record in my DSM Log Center. User name is my account name (that's me) and IP address is the local IP of my NAS device. I really would like to solve also this.
Does anyone here know, how can I monitor my system (all log in attempts), and figure out what service or app is trying to log in to the DSM? Some kind of software tool, some service (can be running in docker or different way)?
I would be very thankful for that.

1614457783663.png
 
just small update: I resolved my problem with failed log in records in the Log Center. In was the Home Assistant running in Docker. As I changed my 2FA code few times when I tried to fix the mobile apps, I forgot that I need also logout/login with that new 2FA code with my Home Assistant. Now everything works as expected (including all my mobile apps), no more issues.
 
Seems to be quite varied issues with this release... particularly within the "community". I would avoid for now and wait for reports from the inevitable "update 1" release.
 
One issue I raised with Synology Support is supposed to have been fixed. It took remote support to fix my DS1520+ before DSM 6.2.4 was released:

In Storage Manger I wanted to run data scrubbing on my SHR-1 (3 drive) array. This seemed to run up to 100% and then paused with a status 'waiting for another task'. Nothing could budge this: not rebooting; not running manually; not scheduled; nothing.

After Synology Support remote access they somehow fixed it and now it says it has completed. Also that this is known and fixed in DSM 6.2.4, even though I challenge anyone to point to the item in the release notes that says this.

I've scheduled the monthly data scrub for each 14th so I'll know if it's been fixed soon after that.
 
Good to know, however I haven't had scrubbing issues w6.2.3. Lucky maybe.
 
Good to know, however I haven't had scrubbing issues w6.2.3. Lucky maybe.
Maybe DS1520+ specific (or DSxx20+ in general). Could be Ironwolf, 8TB, built up from 2 drives to 3, whatever. There was very little about it when googling. I know others do data scrubbing and would expect someone to say if they had issues. This only got resolved a few days ago and the DSM 6.2.4 dropped.

When using btrfs then there two capabilities supported "data scrubbing' and "RAID scrubbing". I think it probably does both if supported but the status progress only says 'data scrubbing'. Confusing.

My main reason was to have as reliable a SHR-1/RAID 5 as I could (so backups [obvs], snapshots, and data scrubbing) and then add a fourth drive, which I'm getting towards needing. Plus a spare drive for early recovery. Yeah, I know it's an insurance policy that could be bought when needed but I prefer to have it here.
 
My issue with Download Station not running under 6.2.4-25554 appears possibly related to accessing remote CIFS folders on other synology machines, as I have Download Station saving downloaded torrents to a folder on another Synology that is mounted via CIFS. Rolling back to the prior DSM fixed the problem. I think STOPPED Download Station, and restarted 6.2.4-25554. This time, Download Station started running, but only after considerable delay, and wouldn't save to CIFS-mounted folders. My assumption is that the considerable delay in starting was due to futile attempts to connect to the default destination for file saving. Again rolled back (tiring!) and it's all working fine under the older DSM.

So now my question is whether anyone is seeing issues with 6.2.4-25554 with EITHER Download Station, ORCIFS-mounted folders on other Synology machines?
 
So now my question is whether anyone is seeing issues with 6.2.4-25554 with EITHER Download Station, ORCIFS-mounted folders on other Synology machines?
I'm guessing your usage is not widespread. I would submit a support ticket to help quash that bug.
 
Thanks @Telos . What I really need to do, I guess, is try upgrading DSM and setting Download Station to save to a local, non-CIFS folder, and see if it works then. If so, then I guess the problem is the CIFS interaction. But the thought of going through this again is so painful...
 
Confirmed, under the new DSM version, Download Station doesn't play nicely with CIFS-mounted folders, for either the location of the downloads, or the monitored folder. Annoying.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Sticky
(2023-11-24) Important notes Your Synology NAS may not notify you of this DSM update because of the...
Replies
0
Views
694
RS1221+ and RS819 done with nothing of note so far. Meanwhile I've got no response from my RS217, so that...
Replies
6
Views
1,346
I'm feeling this is verging every so slightly towards ... off topic. I may be wrong? There's The Lounge...
Replies
4
Views
1,034
I can't argue your trepidation, I've been running stable on 7.1.
Replies
13
Views
2,385
I trieded to update my DS220j but it wouldn't update for some reason.
Replies
2
Views
1,067
After reading fredbert’s post and having already tested, updated 718+ too! All are at 7.2-3 now. No issues...
Replies
7
Views
1,169

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top