DSM Update Version: 7.1-42661 (final)

Currently reading
DSM Update Version: 7.1-42661 (final)

Last edited:
Haven't got the notice but I am going to wait for the "sorting out" to happen, with many docker containers some where I have custom scripts to fix like the reverse proxy to work right, along with local firewall rules to keep my dual homed configuration secured from IoT devices and the business end of my network. Plus it's crunch time for taxes and I have about 30 more returns to prepare and can't afford to lose it. :)
Last edited:
I setup a DS118 for a friend yesterday, it was running like a charm under DSM 7.0.1 but I had to go and update to 7.1... doh! Now it is near unusable, lots of I/O waits and the GUI constantly timing out.

Only iTunes Server, Plex and Drive were installed over the standard install. I think a reset/downgrade is on the cards.
Working fine on my 1515+

Last update set for the old girl.
I too have same NAS was not sure yet to upgrade to it.....I`m stil running 7.0.1-42218. Everything was all working so thought I might hang back........
Took the plunge today and updated latest DSM to my DS1515+ seems ok so far
I’m sharing my personnal experience. I started the update process of my 2 x 1513+ to 7.1-42621. They were running DSM 6.2.4-25556 in SHA Cluster mode. I upgraded them to 4Gb each years ago and attached a DX-213 on each.

First step : update to 7.0.1-42218 went well. It took 40 minutes.

I had to manually update MariaDB10 and WebDAV packages and manually remove all deprecated ones (PhP, Nodejs, Python).

Docker, lets encrypt acme script, reverse proxy… are still working fine, iSCSI too and more importantly : SHA cluster seems stable.

So far so good.

Next step will be to update to 7.1 when officially available.
Ok thanks.
I was about to install it when I read the disclaimer that said that it was going to install beta software (Synology Drive 3.1)… I do not want any beta software on this server so I think I will wait a little bit longer.
Is 7.1 still rolling out? I’m surprised I haven’t seen the update yet on my two NAS’. I won’t manually update just in case they pull it for some reason, but surprised it’s taking this long. Usually the update comes thru when everyone else is talking about it and getting it.
Is 7.1 still rolling out? I’m surprised I haven’t seen the update yet on my two NAS’. I won’t manually update just in case they pull it for some reason, but surprised it’s taking this long. Usually the update comes thru when everyone else is talking about it and getting it.
It can take weeks for the rollout to reach you. Considering they haven't pulled it until now, its is 99% they won't pull it at all.
I received the newsletter in email today on the availability of 7.1. I do like that they are seeding the rollout vs. a big bang.
Just a heads up income tax time wrapped up over the weekend and I took the plunge today for 7.1 on my DS1019+. The update took about 10 minutes and about another minute or so after login for it do some maintenance. The admin account "nag" message was back so I just changed the value "autoLaunch" from true to false in the file below and had to reboot one more time:


As for impacts to my docker everything came up just fine, the advanced extensions installed with no issues along with other package updates:

  • Active Insight
  • Audio Station
  • Advanced Media Extensions
  • Docker
  • File Station
  • Hybrid Share
  • Hyper Backup
  • oAuth Service
  • Python
  • Replication Service
  • SMB Service
  • SAN Manager
  • Secure Single SignIn
  • Snapshot Replication
  • Universal Search
  • Synolgoy Application Service
  • WebStation
  • exFAT Access
I think the only thing I had was the Windows Synolgoy Drive client 3.1 hung up and I had to shut it down and restart it on my laptop. The other computers had no issue. So far happy that everything works, None of my NUT modifications for UPS were over written and the Vaultwarden Web Socket fix still works.
Last edited by a moderator:
I have very sad news, and its big one.
After upgrade to DSM 7.1 - and restart of the NAS its no longer booting.
So it seems any non-synology RAM means blue light blinking and no boot.

Tested - DS220+, DS1821+
Memory - 2x16GB Kingston, 8GB 2666 Crucial

Both systems were runing fine on DSM 6 and I think also DSM 7.01. Letest official DSM 7.1 breaks all and even crashed 1821+ with no way to finish upgrade after power loss or Migration.

Simply they locked it to their super expensive /4-5x the price/ memory.

If it will be confirmed with more models its deal breaker. Truenas Scale is the way.

[Moderator edited]
This is indeed very bad news.I also purchased non-Synology (16GB Crucial) RAM for my DS920 and it works fine under DSM 6.2.* and 7.0.1.

But after reading your post I will definitely not update to 7.1 for now. Hopefully this is a bug and will be fixed soon. Should they have decided at Synology to exclude non-Synology RAM, then we have a problem indeed!
It must be only on their newer models. My aging 1515+ has a couple of random 8 gig sticks inside and updated without issue.
Last edited:
I'm running crucial 4GB Ram expansion on a brand New 720+ that loaded 7 from the get-go and upgraded to 7.1.... and it didn't complain about ram, but did complain about the Seagate Barracuda's I had installed.... but used the Seagate's anyway... Ram still reports total of 6GB, uses it fine.... FYI

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

I've a friend who has had Gmail issues with 7... I haven't but tried -4 on one 720+ Gmail worked before...
Just installed it everything went smooth
So I sent a support request and I have to say, the pigeon English replies weren't very helpful at all...
I manually updated my unit RS820+ weeks if not a month ago with no issues. Still waiting for the push to...
  • Sticky
(2023-11-24) Important notes Your Synology NAS may not notify you of this DSM update because of the...
RS1221+ and RS819 done with nothing of note so far. Meanwhile I've got no response from my RS217, so that...
I'm feeling this is verging every so slightly towards ... off topic. I may be wrong? There's The Lounge...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads