Question VPN Client very slow connected to VPN Server on DS718+

Currently reading
Question VPN Client very slow connected to VPN Server on DS718+

daptap

Byte Poster
NAS
DS718+
Router
RT2600ac
Have a vpn server set up on my DS718+ with OpenVPN protocol (UDP / 1194). I've got the config files on my ios devices and windows 10 laptop. I get like 1/3mbps when hooked up to my vpn server, but like 50/50mbps when hooked up to Mullvad, also on vpn server. This is all on my office's att wifi network that is about 75/75 with no vpn. So, should be fast. My home connection to fios is 500/500 mbps. I've had similar results with other networks (i.e. - very slow when connected to my vpn server on the DS). I'm using to connect to my local network and check on router settings, use DS File, check my Blue Iris ip camera software, etc.

Suggestions to troubleshoot? Should I try a different port number or try TCP? I looked and the mullvad is on UPD/1301 (think it switches around though).
 
Last edited:

WST16

Giga Poster
NAS
DS216+II : DS118 : APC Back UPS ES 700 — Mac/iOS user
Hi,

What happens if you connect to your DS from the same location (office?) without using the VPN connection?
(couldn’t deduct from your post if you have done that).
 

Rusty

Moderator
NAS Support
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
RT1900ac, RT2600ac, MR2200ac
I’ve set it up to only connect through VPN
Well, I use it via TCP and have about 10% penalty but that's on a 30/40 MBit connection, not 500. Guessing it would be more with more speed as well. What ovpn client are you using?
 

WST16

Giga Poster
NAS
DS216+II : DS118 : APC Back UPS ES 700 — Mac/iOS user
I’ve set it up to only connect through VPN
So was it fast before and all of a sudden started behaving like that, or has it been always slow since you’ve set it up?
 

daptap

Byte Poster
NAS
DS718+
Router
RT2600ac
Well, I use it via TCP and have about 10% penalty but that's on a 30/40 MBit connection, not 500. Guessing it would be more with more speed as well. What ovpn client are you using?
iOS app version 3.0.3
 

WST16

Giga Poster
NAS
DS216+II : DS118 : APC Back UPS ES 700 — Mac/iOS user
So we can’t say for sure it’s the VPN service. It might be general communications issue.

Did you try connecting to the VPN service while on your LAN? What’s it like?
 

jeyare

Giga Poster
NAS
1811+, 3x 1813+, 214play ... multisite Ubiquiti Unifi networks (USG-Pro,PoE,NanoHD)
Operating system
Linux, Windows
Mobile operating system
Android, iOS
back to analytical approach

1. try to test direct connection speed to NAS from WAN w/o VPN:
- not just single file, but bunch of mixed files (small docs, photos, ....) more than 100 in the bunch
- same for upload from the NAS
For better scenario you need prepare WAN connection for your Win laptop through your mobile. Why? You will test same conditions of WAN routing to your LAN for your testing devices (phone, laptop). Do it again between phone app and NAS.

2. then you need switch ON the VPN a make the test again in same way

send here the results, include simple draft of your network scheme
 

daptap

Byte Poster
NAS
DS718+
Router
RT2600ac
@WST16 - I have done that test but will need to do it again to remember results. Will post when done.
@jeyare - I have not done this test as I do not connect to my LAN from the WAN without a VPN connection. Don't feel like I know networking well enough to set up the machine securely without the VPN.

I did the following tests today: on both ATT (cell) in NYC while traveling, tested with and without VPN using speedtest app in iphone and ipad. Saw a hit of about 50%. Same test on ipad/iphone/laptop on 75/75 open network in airport and still decent results (30/30). I can live with that. Though the ping is near zero without vpn and around 50-100ms with VPN. So, maybe the problem is my wifi connection at work; maybe they throttle somehow. Work is where I try this most often as I like to tinker on my home network sometimes. EDIT - after surfing for a while on this network w/ VPN, the speed defintely feels extremely sluggish even if the speedtest shows it being 30/30ish. Also, I switched to chrome from firefox (had it pretty locked down) and it at least passable, but still sluggish (just not extremely sluggish). Connection seems to drop in and out as well. No problem on the wifi w/o VPN though.

Interestingly, I can get to files on my NAS through DS File from ipad/iphone (openvpn) but on my laptop with windows explorer (even though I've mapped drives and it works at home on LAN). I'm using the same config file for both through openvpn. Maybe the culprit is the tap adapter that I installed to be able to use the Mullvad app on my laptop (no reason to think so, it is just one of the only changes I've made)? See the log below (redacted some). My ip address is showing my local public facing IP address. EDIT - I am able to get login to my NAS on laptop/chrome, so clearly I am on my LAN.

Code:
Wed Nov 20 12:34:31 2019 OpenVPN 2.4.7 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 25 2019
Wed Nov 20 12:34:31 2019 Windows version 6.2 (Windows 8 or greater) 64bit
Wed Nov 20 12:34:31 2019 library versions: OpenSSL 1.1.0j  20 Nov 2018, LZO 2.10
Wed Nov 20 12:34:34 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]xx.xxx.xxx.xxx:1194
Wed Nov 20 12:34:34 2019 UDP link local (bound): [AF_INET][undef]:1194
Wed Nov 20 12:34:34 2019 UDP link remote: [AF_INET]xx.xxx.xxx.xxx:1194
Wed Nov 20 12:34:34 2019 [username.synology.me] Peer Connection Initiated with [AF_INET]xx.xxx.xxx.xxx:1194
Wed Nov 20 12:34:36 2019 open_tun
Wed Nov 20 12:34:36 2019 TAP-WIN32 device [Mullvad] opened: \\.\Global\{13841377-214F-4001-97ED-EFF84CC4B22D}.tap
Wed Nov 20 12:34:36 2019 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.8.0.10/255.255.255.252 on interface {13841377-214F-4001-97ED-EFF84CC4B22D} [DHCP-serv: 10.8.0.9, lease-time: 31536000]
Wed Nov 20 12:34:36 2019 Successful ARP Flush on interface [6] {13841377-214F-4001-97ED-EFF84CC4B22D}
Wed Nov 20 12:34:41 2019 Initialization Sequence Completed
Wed Nov 20 12:41:10 2019 SIGHUP[hard,] received, process restarting
Wed Nov 20 12:41:10 2019 OpenVPN 2.4.7 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 25 2019
Wed Nov 20 12:41:10 2019 Windows version 6.2 (Windows 8 or greater) 64bit
Wed Nov 20 12:41:10 2019 library versions: OpenSSL 1.1.0j  20 Nov 2018, LZO 2.10
Wed Nov 20 12:41:19 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]xx.xxx.xxx.xxx:1194
Wed Nov 20 12:41:19 2019 UDP link local (bound): [AF_INET][undef]:1194
Wed Nov 20 12:41:19 2019 UDP link remote: [AF_INET]xx.xxx.xxx.xxx:1194
Wed Nov 20 12:41:20 2019 TLS Error: local/remote TLS keys are out of sync: [AF_INET]xx.xxx.xxx.xxx1194 [0]
Wed Nov 20 12:41:21 2019 [username.synology.me] Peer Connection Initiated with [AF_INET]47.185.185.12:1194
Wed Nov 20 12:41:22 2019 open_tun
Wed Nov 20 12:41:22 2019 TAP-WIN32 device [Mullvad] opened: \\.\Global\{13841377-214F-4001-97ED-EFF84CC4B22D}.tap
Wed Nov 20 12:41:22 2019 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.8.0.10/255.255.255.252 on interface {13841377-214F-4001-97ED-EFF84CC4B22D} [DHCP-serv: 10.8.0.9, lease-time: 31536000]
Wed Nov 20 12:41:22 2019 Successful ARP Flush on interface [6] {13841377-214F-4001-97ED-EFF84CC4B22D}
Wed Nov 20 12:41:27 2019 Initialization Sequence Completed
 
Last edited:

daptap

Byte Poster
NAS
DS718+
Router
RT2600ac
Any thoughts? I’ve test at home WiFi with and without vpn and with seems to be about 40% of without. Pretty good at high speeds (best with vpn is 80mbps).

At friends house trying to help him with DSM setup and tried to vpn to my DSM, it was basically unusable.
 

WST16

Giga Poster
NAS
DS216+II : DS118 : APC Back UPS ES 700 — Mac/iOS user
I’m not sure what’s going on!

Are you going through a double VPN connection?
Why is Mullvad involved while you’re connected via your OpenVPN to your NAS? Am I reading this correctly?

Fom your log above:
Code:
Wed Nov 20 12:41:22 2019 TAP-WIN32 device [Mullvad] opened: \\.\Global\{13841377-214F-4001-97ED-EFF84CC4B2
 

jeyare

Giga Poster
NAS
1811+, 3x 1813+, 214play ... multisite Ubiquiti Unifi networks (USG-Pro,PoE,NanoHD)
Operating system
Linux, Windows
Mobile operating system
Android, iOS
@jeyare - I have not done this test as I do not connect to my LAN from the WAN without a VPN connection. Don't feel like I know networking well enough to set up the machine securely without the VPN.
1. could you pls send us a simple scheme of your network, use paper and pencil and make a screenshot
2. this must be done in place where is your NAS connected to your router (your home). your Laptop and Smart phone must be connected to your WiFi, then:
open browser with your Win Laptop and smartphone and open page:
write your results from Laptop and smartphone to some notepad
3. open your DSM by browser, then open Control panel/External Access/DDNS
click to “Add” button, there you will find you External address. Compare it with addresses from point 2.
4. is there:
- same address (NAS, Smartphone, Laptop)?
- is there difference? Where?
5. now you switch off VPN Mullvad clients in your Laptop and your Smartphone. Repeat all steps in point 2.
6. compare the addresses again, follow point 4.
7. now you switch off VPN in your router (keep switched off the clients in Laptop and Smartphone). Repeat steps in point 2. and 3.
again repeat the point 4.
Send here an evaluation of your test
 

daptap

Byte Poster
NAS
DS718+
Router
RT2600ac
1. could you pls send us a simple scheme of your network, use paper and pencil and make a screenshot
2. this must be done in place where is your NAS connected to your router (your home). your Laptop and Smart phone must be connected to your WiFi, then:
open browser with your Win Laptop and smartphone and open page:
write your results from Laptop and smartphone to some notepad
3. open your DSM by browser, then open Control panel/External Access/DDNS
click to “Add” button, there you will find you External address. Compare it with addresses from point 2.
4. is there:
- same address (NAS, Smartphone, Laptop)?
- is there difference? Where?
5. now you switch off VPN Mullvad clients in your Laptop and your Smartphone. Repeat all steps in point 2.
6. compare the addresses again, follow point 4.
7. now you switch off VPN in your router (keep switched off the clients in Laptop and Smartphone). Repeat steps in point 2. and 3.
again repeat the point 4.
Send here an evaluation of your test
Haven’t forgotten and thanks for the reply. I just need to set some time aside to troubleshoot. Thanks!
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Top