Solved Why does this reverse proxy fail

Currently reading
Solved Why does this reverse proxy fail

1,057
353
NAS
DS418play, DS213j, DSM 7.0.4-11091
I set up this reverse proxy for the DS File app (Android)... but it fails to connect.



When I enter "hot.synology.me:5001" in the DS File app, it connects. But if I enter "ds.hot.synology.me" using this reverse proxy, it fails. FWIW, ports 443 and 5001 are forwarded to the NAS (192.168.1.10). I've dropped the firewall without effect. I have the HTTPS box in DS File checked.

What am I missing?
 
1,464
636
NAS
DS220+ : DS1019+ : DS216+II : DS118 : DS120j : APC Back UPS ES 700 — Mac/iOS user
I think because the DS apps are hard coded to use 5000 and 5001 if you don’t explicitly add a port. If you try (your example), ds.hot.synology.me:443 it should work. But I know that’s not what you‘re looking for :)
 

Shadow

Subscriber
453
158
NAS
DS216+II, DS118, DS718+
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. Windows
Mobile operating system
  1. Android
Well strangely enough according to this article DS File uses port 5005 (HTTP) and/or 5006 (HTTPS) as default? So as @WST16 rightfully pointed out, entering "ds.hot.synology.me" in the app will not hit the reverse proxy at port 443..

Now that we are talking about it, I do sure hope Synology changes this one day and make every mobile app use port 80/443 as default or something:

1601115979520.png


The only reason I have port 5001 open on my router is for the Synology Drive app on Android... But when using a computer the Drive application is browsable just fine by just entering: https://drive.mydomain.com .
 

Rusty

Moderator
NAS Support
2,350
700
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
using DSFile will work just fine via reverse as long as you type in the 443 port at the end as @WST16 said.
 
1,057
353
NAS
DS418play, DS213j, DSM 7.0.4-11091
If you try (your example), ds.hot.synology.me:443 it should work.
using DSFile will work just fine via reverse as long as you type in the 443 port at the end as @WST16 said.
You are correct, but as @WST16 said...
But I know that’s not what you‘re looking for :)
as the point was to avoid port entry. So in my example, using "ds.hot.synology.me:443" is the same as using "hot.synology.me:443" as I have "hot.synology.me" reverse proxied to my DSM login page.
I do sure hope Synology changes this one day and make every mobile app use port 80/443 as default or something
We can only dream. Maybe by DSM 8 :cool:

Thanks for the good feedback!
 

fredbert

Moderator
NAS Support
Subscriber
1,592
666
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Some of the mobile apps for the older packages (e.g. File/Audio/Video Station) require the 'Diskstation' link to have the ':port' included.

If you have used Application Portal to define a specific domain 'file.mydomain.com' then you must still add :433.

I think it is a hardcoded condition within these mobile apps, since new package mobile apps no longer need this.
 
209
44
NAS
RS820+, DS718+
Operating system
  1. Windows
Mobile operating system
  1. iOS
I too found this out a few days ago when I tried setting up reverse proxy. Seems like the mobile apps are the ones that would give an issue.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Top