RT2600ac Wireless connection to Mac

Currently reading
RT2600ac Wireless connection to Mac

wwwampy

Active member
NAS
DS418play
Router
RT2600ac
Yesterday a friend tried to connect to my wi-fi with his Mac computer, but he was prompted to enter a username and password for my network.

Username? I connected all my devices without any username, just click on my SSID name and enter the password.

So, we couldn't figure it out ...
 

Rusty

Staff member
Moderator
NAS Support
Website
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2xRS3614RPXS+ (with 2 expansions)
Router
RT1900ac
Are you sure he was trying to connect to your wifi and not a specific device on the network?
 

WST16

Well-known member
NAS
DS216+II : DS118 : APC Back UPS ES 700 — Mac/iOS user
Could it be that his laptop is issued by his work?

I once worked for a company who was so paranoid (and that says a lot coming from a paranoid person like me), that everything was so secure to the point where it could’ve been much more productive had we employed carrier pigeons instead of email!
 
Last edited:

wwwampy

Active member
NAS
DS418play
Router
RT2600ac
Are you sure he was trying to connect to your wifi and not a specific device on the network?
Yes, to my SSID name. He tried with his iPhone and no prompt for username, only from his Mac book.

Could it be that his laptop is issued by his work?
I don't know. I'm not a Mac user so I wasn't sure either what to do. I've never seen anything like that before.
 

WST16

Well-known member
NAS
DS216+II : DS118 : APC Back UPS ES 700 — Mac/iOS user
Mac first and then router if it doesn’t work. I mean we’re turning things off, hardly any logic. Why not go the whole nine yards. The circuit breaker next :)
 

WST16

Well-known member
NAS
DS216+II : DS118 : APC Back UPS ES 700 — Mac/iOS user
Isn’t this the super duper new Synology router you got recently?
Maybe it’s not compatible with Macs?

Good thing you’re not using a Mac. You’ll be stuck now :p

(Don’t mind me another day with too much time on my hands)
 

wwwampy

Active member
NAS
DS418play
Router
RT2600ac
Well, he has 10 year old Mac, not updated. So maybe that's the problem. It doesn't matter now. It works fine for me and my family.
 

fredbert

Well-known member
I saw this recently too.

My old MacBook 2008 (black plastic) is running some old version of OS X, think in might be Lion (10.7). Decided to see if it worked and it too prompted for username/password for my RT2600ac's main SSID and that uses WPS2 Personal.

I didn't investigate further. Was going to try the guest network.
 

fredbert

Well-known member
I might have a look into it, which means google it and then use an ethernet cable if ever it needs to be used again (or the deprecated Airport Extreme).
 

Daddo

Member
Website
127.0.0.1
NAS
DS 211j
Router
RT2600ac
Yesterday a friend tried to connect to my wi-fi with his Mac computer, but he was prompted to enter a username and password for my network.

Username? I connected all my devices without any username, just click on my SSID name and enter the password.

So, we couldn't figure it out ...
In order to change network properties in Mac OS, you must enter credentials of the local user with proper permissions (i.e. Administrator).

I'm not at home at the moment, so I can not post screenshots, but will do ASAP.
 

wwwampy

Active member
NAS
DS418play
Router
RT2600ac
@fredbert @Daddo
Don't bother, he already went into his cave and we don't have any Mac at home so I don't have a problem with it.

Thank you all.
 

fredbert

Well-known member
I might have a look into it, which means google it
As I said, I googled it: Mac thinks the wireless network is WPA2 Enterprise, but it isn't

I have 802.11r enabled on the main SSID but not on the guest SSID. I can connect the very old MacBook (OS X 10.7.5 'Lion') to the guest WiFi but not main WiFi.

Here's the relevant post from Spiceworks:
chrispoppe Jan 12, 2018 at 6:03 PM
We finally figured this out at our place. We have multiple access points and with some of the later firmware a new feature became available called "Fast Roaming" or 802.11r; I'm sure different wireless manufacturers call it by different names. All I had to do was to turn off this feature in the access points/wireless router. Older iOS versions do not recognize this feature and get confused when trying to connect. All fixed for us.
Similar issues found by 'the community' and affecting Surface Pro devices.
 

wwwampy

Active member
NAS
DS418play
Router
RT2600ac
Hm, just checked, but I don't have 802.11r enabled on any of WiFi network.

Maybe it's the security level? I have WPA2/WPA3-Personal.
 

Rusty

Staff member
Moderator
NAS Support
Website
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2xRS3614RPXS+ (with 2 expansions)
Router
RT1900ac
WP3 migh be a problem atm for many "old" clients. Its pretty new standard. Try and lower the encryption type
 

fredbert

Well-known member
'WPA2/WPA3 Personal' didn't work with my iPhone 6 (iOS12) when SRM first started support this authentication. I had to keep on WPA2 Personal (or Enterprise, but that's just adding more aggro to a home setup than I'm inclined to support).
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Top