DDNS failed.....

Currently reading
DDNS failed.....

687
226
NAS
DS918+
Operating system
  1. macOS
Mobile operating system
  1. iOS
Last edited:
I'm seeing an issue today whereby the DDNS settings on the DS918+ are blank (instead of the external IP being shown) and the NAS is reporting there is no external connectivity. On checking the Synology account for the connection that reports all is normal.

I've rebooted the NAS and it looking at the Synology account it now shows that DDNS is offline. Hostname and IP blanked out...
Screenshot 2021-08-25 at 17.53.45.jpg




Any ideas folks?
 
Thanks @tekguru.
My firmware from my Orbi (in Router mode places behind my ISP modem router) is V2.7.3.22. For a few months without problems. The NTP solution could be helpfull. Now i have put time.google.com as NTP server in my Orbi. Also in my Synology. And i have unchecked Automatically adjust for daylight savings time.
In my Synology i also put the Google DNS servers.
Now lets wait......
 
Upvote 0
Glad to try and help fix this darned problem. It lasted 11 and a half hours until DDNS failed again..... darn...... I was so hopeful. I guess you are the same as myself that it worked perfectly and then all of a sudden not? Are you running DSM 7?

Firmware is V2.7.3.22. For DNS on both the NAS & Orbi I have DNS set to Cloudflare (1.1.1.1 & 1.0.0.1), NTP on the NAS is pool.ntp.org, Orbi is still set to the default Netgear NTP. On the Orbi yep unchecked Automatically adjust for daylight savings time.

The next step is to reapply the firmware, factory reset and then configure the Orbi manually instead of re-loading the config.

I'll continue to see where it goes from here. I'm hoping the Netgear Engineer has a solution to offer (maybe a beta firmware I can try out)
 
Upvote 0
Yes suddenly it stopt working. About two weeks ago. Did not change anything to the config of the Orbi and Synology.
Tried a lot of things:
Disabled Bond of UTP cables to 1 cable (new one), disabled PI-hole that i was running as a docker on my NAS. Changed a lot of times DNS IP servers (now its pointing to 8.8.8.8. I have a fixed IP on my NAS.
I have 18 GB of memory on my Synology. But i don't think that causes the problem.
It took me quit a time to find a steady config of my Orbi. It's a great performing MESH but a hell to config it to a steady enviroment.
Also i am running Home Assistant as virtual machine (with own IP adress). No docker.
And VPN server ;-)

My first gut-feeling was that the problem was caused by the Orbi (because of earlier network hickups)
I check Orbi site daily for new firmware updates......
 
Upvote 0
Sounds a very similar story to me, apart from I'm not using Docker at all. I had no problems in getting a stable Orbi setup, as I've used Netgear a fair bit over the years. The only thing I had to do to get it stable was turn off daisy-chaining (I have two satellites).

I'm still thinking about NTP being the issue at the moment. When DNS lookups failed tonight I checked the Netgear NTP server and it was back online.

So I'm now trying to be sneaky.... I've set the NTP server on the Orbi to 'dummy.deadpool.org' which of course fails to get a connection as it doesn't exist :)

Ref the DDNS the problem is that on the domain (DNS controlled by Office 365 & Microsoft domain servers) I have to set a CNAME for 'forum.domain.com' and that has to point at a domain (not an IP address) and that points to my 'hostname.synology.me' quick connect ID. The problem is if DDNS breaks on the NAS then 'hostname.synergy.me' can't be reached.

I had set up DDNS on the Orbi, and have now configured it again. The disadvantage here is that the Netgear DDNS service now uses a No-IP Account and that costs, it's no longer free.

Lets say that DDNS on the Orbi has been set with a hostname of 'mynasname.mynetgear.com' then when the web browser hits it you get an insecure web page warning as the certificates don't match, and if you bypass that the forum appears but under a domain name of 'mynasname.mynetgear.com' and of course as soon as you click on any link that looks to use the forum.mydomain.com domain........ and it all falls apart.

Hmm I wonder if I can change the forum.domain.com CNAME on the domain to point to 'mynasname.mynetgear.com' instead of 'hostname.synology.me'. It might cost, but if it fixes the issue for the forum it might be worth it.
 
Upvote 0
You can try that. But don't you need a certificate for that new adress?
Maybe wait for the Netgear man with ideas? If you bypass this problem with ddns from Netgear i do not think your problem of reaching the Nas is resolved. I also had for example quick connect problems...
 
Upvote 0
Well it wasn't the NTP alas I too had three downtime outages during the night.

I've put a test CNAME in place on my domain pointing at the Orbi DDNS and it works just fine (well it gets to Web Station) so we'll see when the issue next occurs if I can get to the NAS using it.

I'm sure it is the Orbi as:
  1. I did a lot of testing with Synology support which showed things got as far as the Orbi and then no further.
  2. If I turn all the Orbi system off and go back to using the BT Internet Home Hub router/modem the disconnection problems stop completely.
So I guess roll on the call with Netgear this afternoon.
 
Upvote 0
Not with the Orbi mesh system costing circa £600. Plus I tested out a lot of other mesh systems before ending up with the Orbi - and that had been perfect until this last firmware update.
 
Upvote 0
Well I've just had the call with the Netgear Engineer..... I was thanked for all the information I'd provided which was what was needed for the case to be worked on and pushed up a support level. They agreed that the prior firmware did likely not have the issue and it was suggested I went back to the prior version and used the 'beta' configuration page to turn off auto-updating.

I did point out that the option was no longer present on the debug page and that if I did apply the prior firmware it would just auto-update again. He was not aware of this and said he'd pass that onto the higher level support team as well.

He said they'd contact me when any new firmware was ready.

He did say nobody else had reported the issue..... So @cslekniws I think you need to raise a support ticket with Netgear too, feel free to reference my ticket (#45053582) if it helps.

So yeah not a good call I guess as no fix in place and we're still stuck with the problem.
 
Upvote 0
Yeah. I've just updated my ticket and gone back with:

Guys ref the call today (muchly appreciated) it seems that the 2.7.3.22 firmware may be the cause of the issue and that I should downgrade to version 2.7.2.104.

I pointed out that I have already done that but as the 'auto-update' check option has been removed from the beta page there is no way of turning of auto-updating.

This leaves me in the situation that half the features on my very expensive NAS are unusable and I'm at the risk of the forum I host going offline.

I chose the Netgear Orbi system after testing out a lot of Mesh networks and it was the best in class. It was not cheap (even though not your most expensive system) and now I'm stuck with a half-functional product.

This is not a good situation guys and I'm very unhappy with the situation. Is there nothing that can be done?
 
Upvote 0
Not a problem, let me know what they say....

All sorts of times for me:
Screenshot 2021-09-13 at 17.29.26.jpg

And as my forum has a lot of users from Australia even nighttime (UK) issues are a problem.
 
Upvote 0
Tried to contact Netgear but i don't have any support possiblity's anymore for a engeneer. My guaranty for support anymore....
It's not possible to reverse to an older firmware because of automatic updates right?
 
Upvote 0
Ahh I'm still within my first year, but also took up the option to extend my cover to three years.

The only slight hope is if on the 2.7.2.104 firmware that the debug option to turn off automatic updates is still there. I'm not sure at what version it was removed. You can access the debug options by going to <router IP>/debug.htm and logging in.

Other commitments for the next few days prevent me from downgrading and seeing if the option is in that version. If you try it let me know :)

I'm still waiting for the problem to occur during the day time to see if I can access my forum using the Netgear DDNS system. I've set up two CNAMES to hit my forum / web station, one using mynas.synology.me and the other using mynas.mynetgear.com as hostnames. Both connect at the moment. I'm hoping that when the issue occurs that mynas.mynetgear.com will still be operational. If it is I have a workaround I can live with I guess.
 
Upvote 0
Yesterday i installed a second Synology (oldy 712+). I want to place this Synology at my friends home. To have a extra backup outside my home. No DSM 7.0 (was not possible). And on DHCP (because Fixed IP not helpfull because i must move the synology to another network topology at my friends home.
Installed QuickConnect and Dyn DNS xxx.synology.me
Yesterday and today still connection errors on my system but not on my 712+...... Strange...
-- post merged: --

 
Upvote 0
Well I'm back to using the IP router / modem and disconnected the Orbi. The CNAE tests I did didn't help. I could reach the NAS using the Netgear DDNS, but the backend database could not respond due to the DDNS issue.

I've asked Netgear Support & the Netgerar community which version of the firmware did still allow turning off of auto-updating (or allowed telnet access). Will see what responses we get (I've not got a lot of hope).
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

I called the provider and he told me that I don't have a nat, just for business(( :cry:
Replies
2
Views
436
Once I got the NAS up and running with internet connection again, I was able to reauthenticate Tailscale...
Replies
7
Views
641
A quick search of the Zyxel and port forwarding 443 does seem to be a bit of impossible according to one...
Replies
15
Views
1,268
  • Question
Welcome to the forum. I never got it to work. In the end I maintained Namecheap DDNS via DNS-o-Matic...
Replies
1
Views
1,760
Yep. Am on 900/900. Fortunately Fiberhop is small enough to talk turkey with, any of the big isps are...
Replies
7
Views
1,856

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top