DS 220+ "Connection failed. Please check your internet connection"

Currently reading
DS 220+ "Connection failed. Please check your internet connection"

2
1
NAS
DS220+
Operating system
  1. Linux
Mobile operating system
  1. Android
Hi, I'm new here. I've got a new DS220+ NAS which I unfortunately can't connect it to the internet.


# Problem: I get the message "Connection failed. Please check your internet connection" in various flavors.

Control Panel > Update & Restore > DSM Update > Status: "Connection failed. Please check your internet connection"

Control Panel > Synology Account >Popup: "Unable to perform this operation, possibly because the network connection is unstable..."

Package Center > Popup: "Connection failed. Please check your network and time settings..."

Regional Options > Time Settings > Synchronise with NTP server > Status: "Normal" (!!!)


# What I want


I want to a) be able to update my NAS and b) download some packages for a self-hosted setup (docker, git, paperless, ...)



# Things I tried

Finally, as I can update the date/time, I believe this to be a DNS problem. I ran some random commands, but I have no idea what I am doing here..

$ nslookup download.synology.com
Server: 8.8.8.8
Address: 8.8.8.8#53

Non-authoritative answer:
Name: download.synology.com
Address: 203.74.127.91

$ ifconfig -v
eth0 Link encap:Ethernet HWaddr 90:09:D0:2B:C4:C1
inet addr:192.168.178.30 Bcast:192.168.178.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:15275 errors:0 dropped:0 overruns:0 frame:0
TX packets:8879 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3302201 (3.1 MiB) TX bytes:4764704 (4.5 MiB)
Interrupt:84 base 0xe000

eth1 Link encap:Ethernet HWaddr 90:09:D0:2B:C4:C2
inet addr:192.168.178.31 Bcast:192.168.178.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7129 errors:0 dropped:0 overruns:0 frame:0
TX packets:257 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:739914 (722.5 KiB) TX bytes:46551 (45.4 KiB)
Interrupt:85 base 0x4000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:13242 errors:0 dropped:0 overruns:0 frame:0
TX packets:13242 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:1874907 (1.7 MiB) TX bytes:1874907 (1.7 MiB)

$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.178.1 0.0.0.0 UG 0 0 0 eth0
192.168.178.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.178.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1




synology_ping.png




it appears as if pinging to the Synology servers via CLI works. But in the GUI I still get the errors.







# System Information

## Router (Fritz!Box 7530 AX)

fritzbox_DNS.png


fritzbox_network.png



## Info Center


2023-01-21_14-56.png


2023-01-21_14-57.png



## Network

network_general.png


network_general_advanced.png


### Interfaces

network_interfaces.png



network_interfaces_edit.png

network_interfaces_edit_ipv6.png


## Error messages

update_fail.png

syno_account_fail.png

package_center_Fail.png

date_time_success.png
 
Solution
I would reset (short 3s) the nas to reset network settings to default, pick it up from the synology assistant and follow the instruction from fortran. Do not mess with all these settings, no need. this should work right out of the box.
FYI - I checked my NAS (DS-918+) this morning status is now being reported correctly. It appears the upstream issue (reporting: "connection failed. Please check your internet connection") has now been corrected. Many thanks for helping me to understand the issue and to "do nothing" while the upstream error is corrected.

Screenshot 2023-07-31 125545.png
 
Upvote 0
This just starting happening to me today a few hours ago. Wondering if it's the same thing because I cannot enable quickcionnect, I can't access Synology Account, Support Center, Package Center, too much to name. But OP sounds very similar to what I'm encountering. None of the normal suggestions have helped and I can ping everything on their url list
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
As noted above, when you uninstall Plex, it will ask you if you wish to keep its configuration files. Let...
Replies
3
Views
1,182
No. They are different. In that thread, it is about exploring the possibility and possible cons of...
Replies
2
Views
1,247
Thank you all for your very appreciated help!!! I decided to try and go for the NETWORK EXTENDER solution...
Replies
25
Views
4,502
Got it running. I think it didn't like my old password used for the databases anymore..
Replies
3
Views
1,272
This usually happens when the volume is under intensive load. Making a new pool and optimizing it can take...
Replies
1
Views
1,363

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top